Bug 172109 - [PATCH] update audio/csound to 5.18.2
Summary: [PATCH] update audio/csound to 5.18.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 07:10 UTC by Chris Petrik
Modified: 2012-10-02 08:00 UTC (History)
0 users

See Also:


Attachments
file.diff (7.91 KB, patch)
2012-09-27 07:10 UTC, Chris Petrik
no flags Details | Diff
csound.diff (9.12 KB, patch)
2012-10-01 22:30 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petrik 2012-09-27 07:10:02 UTC
Update csound to 5.18.2

Fix: Patch attached with submission follows:
Comment 1 Guido Falsi freebsd_committer 2012-09-27 20:49:35 UTC
Responsible Changed
From-To: freebsd-ports-bugs->madpilot

I'll take it.
Comment 2 Guido Falsi freebsd_committer 2012-09-28 16:32:23 UTC
hi!

Thanks for your patch.

While testing it I noticed that the csound5gui program segfaults when
clicking, for example, on the configure button or the csound one from
the options drop-down list.

This is happening on FreeBSD 9.1-PRERELEASE r239488.

Is this a known problem from upstream? Am I doing something wrong?

This should be checked before committing to avoid surprising users.

Could you please investigate?

Thank you!

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 3 Guido Falsi freebsd_committer 2012-09-28 16:34:02 UTC
State Changed
From-To: open->feedback

Ask for maintainer fix.
Comment 4 Chris Petrik 2012-09-29 17:22:00 UTC
Hello,

FInally got mailto: links working in Chrome.

I will test/fix this in a bit.
Comment 5 Chris Petrik 2012-09-30 04:29:22 UTC
Seems to run fine here ?

http://cpet.multics.org/images/snapshot6.png
Comment 6 Guido Falsi freebsd_committer 2012-09-30 17:10:23 UTC
This is strange, this is what I'm getting also on another machine when 
clicking on the configure button in the main GUI:

 > gdb `which csound5gui`
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain 
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...(no debugging 
symbols found)...
(gdb) run
Starting program: /usr/local/bin/csound5gui
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...[New LWP 100540]
[New Thread 806006400 (LWP 100540/csound5gui)]
[New Thread 806007000 (LWP 101411/csound5gui)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 806006400 (LWP 100540/csound5gui)]
0x000000080782ae53 in csoundModuleInit ()
    from /usr/local/lib/csound/plugins64/libwidgets.so
(gdb) bt
#0  0x000000080782ae53 in csoundModuleInit ()
    from /usr/local/lib/csound/plugins64/libwidgets.so
#1  0x0000000800b3e454 in csoundInitModule ()
    from /usr/local/lib/libcsound64.so.5
#2  0x0000000800b3e544 in csoundInitModules ()
    from /usr/local/lib/libcsound64.so.5
#3  0x0000000800b429e7 in csoundCompile () from 
/usr/local/lib/libcsound64.so.5
#4  0x0000000000432b67 in 
CsoundPerformanceSettingsPanel::querySoundDevices ()
#5  0x000000000043d83f in 
CsoundPerformanceSettingsPanel::CsoundPerformanceSettingsPanel ()
#6  0x0000000000412c21 in CsoundGUIMain::openPerformanceSettingsWindow ()
#7  0x0000000801c23c83 in Fl_Widget::do_callback ()
    from /usr/local/lib/libfltk.so.1.3
#8  0x0000000801bdd18a in Fl_Button::handle ()
    from /usr/local/lib/libfltk.so.1.3
#9  0x0000000801bd6653 in send () from /usr/local/lib/libfltk.so.1.3
#10 0x0000000801bd7dd0 in Fl::handle_ () from /usr/local/lib/libfltk.so.1.3
#11 0x0000000801c2a580 in fl_handle () from /usr/local/lib/libfltk.so.1.3
#12 0x0000000801c2bbe3 in do_queued_events ()
    from /usr/local/lib/libfltk.so.1.3
#13 0x0000000801c2c012 in fl_wait () from /usr/local/lib/libfltk.so.1.3
#14 0x0000000801bd6f66 in Fl::wait () from /usr/local/lib/libfltk.so.1.3
#15 0x0000000000416a2a in CsoundGUIMain::run ()
---Type <return> to continue, or q <return> to quit---
#16 0x00000000004264e7 in main ()
(gdb)


And this when clicking on the Options -> CSound one:

 > gdb `which csound5gui`
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain 
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...(no debugging 
symbols found)...
(gdb) run
Starting program: /usr/local/bin/csound5gui
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...[New LWP 101012]
[New Thread 806006400 (LWP 101012/csound5gui)]
[New Thread 806007000 (LWP 101423/csound5gui)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 806006400 (LWP 101012/csound5gui)]
0x0000000807c39e53 in csoundModuleInit ()
    from /usr/local/lib/csound/plugins64/libwidgets.so
(gdb) bt
#0  0x0000000807c39e53 in csoundModuleInit ()
    from /usr/local/lib/csound/plugins64/libwidgets.so
#1  0x0000000800b3e454 in csoundInitModule ()
    from /usr/local/lib/libcsound64.so.5
#2  0x0000000800b3e544 in csoundInitModules ()
    from /usr/local/lib/libcsound64.so.5
#3  0x0000000800b429e7 in csoundCompile () from 
/usr/local/lib/libcsound64.so.5
#4  0x0000000000432b67 in 
CsoundPerformanceSettingsPanel::querySoundDevices ()
#5  0x000000000043d83f in 
CsoundPerformanceSettingsPanel::CsoundPerformanceSettingsPanel ()
#6  0x0000000000412c21 in CsoundGUIMain::openPerformanceSettingsWindow ()
#7  0x0000000801c23c83 in Fl_Widget::do_callback ()
    from /usr/local/lib/libfltk.so.1.3
#8  0x0000000801bfe042 in Fl_Menu_::picked ()
    from /usr/local/lib/libfltk.so.1.3
#9  0x0000000801bfe32a in Fl_Menu_Button::popup ()
    from /usr/local/lib/libfltk.so.1.3
#10 0x0000000801bfe5ca in Fl_Menu_Button::handle ()
    from /usr/local/lib/libfltk.so.1.3
#11 0x0000000801beb0e9 in Fl_Group::handle ()
    from /usr/local/lib/libfltk.so.1.3
#12 0x0000000801beb0e9 in Fl_Group::handle ()
    from /usr/local/lib/libfltk.so.1.3
---Type <return> to continue, or q <return> to quit---
#13 0x0000000801bd6653 in send () from /usr/local/lib/libfltk.so.1.3
#14 0x0000000801bd7e11 in Fl::handle_ () from /usr/local/lib/libfltk.so.1.3
#15 0x0000000801c2a580 in fl_handle () from /usr/local/lib/libfltk.so.1.3
#16 0x0000000801c2bbe3 in do_queued_events ()
    from /usr/local/lib/libfltk.so.1.3
#17 0x0000000801c2c012 in fl_wait () from /usr/local/lib/libfltk.so.1.3
#18 0x0000000801bd6f66 in Fl::wait () from /usr/local/lib/libfltk.so.1.3
#19 0x0000000000416a2a in CsoundGUIMain::run ()
#20 0x00000000004264e7 in main ()
(gdb)


Maybe it's an amd64 only problem?

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 7 Guido Falsi freebsd_committer 2012-10-01 22:30:02 UTC
I finally found something.

There is a piece of code, which is what is causing problems, which can 
bee ifdeffed out. It is by default on Windows and MacOSX. I think we can 
also comment that out and avoid the problem.

Attached revised patch just adds code to disactivate that part of the code.

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 8 Chris Petrik 2012-10-02 02:18:51 UTC
Looks fine, two minds are better than one.
Comment 9 dfilter service freebsd_committer 2012-10-02 07:53:54 UTC
Author: madpilot
Date: Tue Oct  2 06:53:38 2012
New Revision: 305150
URL: http://svn.freebsd.org/changeset/ports/305150

Log:
  - Update to 5.18.02
  - Remove ABI version numbers from LIB_DEPENDS
  - Add patch to avoid a rare segfault
  - While here, trim Makefile headers
  
  PR:		ports/172109
  Submitted by:	Chris Petrik <c.petrik.sosa@gmail.com> (maintainer)

Added:
  head/audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp   (contents, props changed)
Modified:
  head/audio/csound/Makefile   (contents, props changed)
  head/audio/csound/distinfo   (contents, props changed)
  head/audio/csound/files/patch-H__sysdep.h   (contents, props changed)
  head/audio/csound/pkg-plist   (contents, props changed)

Modified: head/audio/csound/Makefile
==============================================================================
--- head/audio/csound/Makefile	Tue Oct  2 05:41:26 2012	(r305149)
+++ head/audio/csound/Makefile	Tue Oct  2 06:53:38 2012	(r305150)
@@ -1,14 +1,10 @@
-# New ports collection makefile for:	csound
-# Date created:				2000-10-11
-# Whom:					trevor
-#
+# Created by: Trevor Johnson <trevor@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	csound
-PORTVERSION=	5.17.11
+PORTVERSION=	5.18.02
 CATEGORIES=	audio lang
-MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION} \
+MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.18/ \
 		SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
 DISTNAME=	${PORTNAME:S/c/C/}${PORTVERSION}
 DISTFILES=	${DISTNAME}${EXTRACT_SUFX}
@@ -24,7 +20,7 @@ DIST_SUBDIR=	csound
 BUILD_DEPENDS=	${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13 \
 		${LOCALBASE}/include/gmm/gmm.h:${PORTSDIR}/math/gmm++ \
 		${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS=	sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS=	sndfile:${PORTSDIR}/audio/libsndfile
 
 OPTIONS_DEFINE=	ALSA DSSI FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO FLTK
 OPTIONS_DEFAULT=FLTK
@@ -58,7 +54,7 @@ SUB_FILES=	pkg-message
 .include <bsd.port.options.mk>
 
 .if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+=	asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+=	asound:${PORTSDIR}/audio/alsa-lib
 SCONS_ARGS+=	useALSA=1
 PLIST_SUB+=	ALSA=""
 ALSA_H=		alsa/asoundlib.h
@@ -79,7 +75,7 @@ PLIST_SUB+=	DSSI="@comment "
 .endif
 
 .if ${PORT_OPTIONS:MFLUIDSYNTH}
-LIB_DEPENDS+=	fluidsynth.1:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS+=	fluidsynth:${PORTSDIR}/audio/fluidsynth
 PLIST_SUB+=	FLUIDSYNTH=""
 FLUIDSYNTH_H=	fluidsynth.h
 .else
@@ -88,7 +84,7 @@ FLUIDSYNTH_H=	##fluidsynth.h##
 .endif
 
 .if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+=	jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+=	jack:${PORTSDIR}/audio/jack
 SCONS_ARGS+=	useJack=1
 PLIST_SUB+=	JACK=""
 .else
@@ -97,7 +93,7 @@ PLIST_SUB+=	JACK="@comment "
 .endif
 
 .if ${PORT_OPTIONS:MOSC}
-LIB_DEPENDS+=	lo.7:${PORTSDIR}/audio/liblo
+LIB_DEPENDS+=	lo:${PORTSDIR}/audio/liblo
 SCONS_ARGS+=	useOSC=1
 PLIST_SUB+=	OSC=""
 .else
@@ -120,7 +116,7 @@ PORTAUDIO_R=	# empty
 .endif
 
 .if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+=	pulse-simple.0:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS+=	pulse-simple:${PORTSDIR}/audio/pulseaudio
 PLIST_SUB+=	PULSEAUDIO=""
 PULSEAUDIO_H=	pulse/simple.h
 .else
@@ -129,7 +125,7 @@ PULSEAUDIO_H=	##pulse/simple.h##
 .endif
 
 .if ${PORT_OPTIONS:MFLTK}
-LIB_DEPENDS+=	fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS+=	fltk:${PORTSDIR}/x11-toolkits/fltk
 PLIST_SUB+=	FLTK=""
 SCONS_ARGS+=	buildCsound5GUI=1 buildCSEditor=1 buildWinsound=1 useFLTK=1
 .else
@@ -191,12 +187,13 @@ post-patch:
 		${WRKSRC}/InOut/rtpa.c
 	@${REINPLACE_CMD} -e "s|linux/if.h|sys/types.h|" \
 		${WRKSRC}/OOps/remote.c
-
+	@${REINPLACE_CMD} '1658,1659d' \
+		${WRKSRC}/SConstruct
 post-install:
 	@${LN} -sf libcsound64.so.5 ${PREFIX}/lib/libcsound64.so
 .if ${PORT_OPTIONS:MDOCS}
 	@${MKDIR} ${DOCSDIR}
-	@${ECHO_MSG} " Installing the manual."
+	@${ECHO_MSG} " Installing manual ${PORTVERSION}. "
 	@(cd ${WRKDIR}/html && ${COPYTREE_SHARE} . ${DOCSDIR})
 	@${ECHO_MSG} " Done."
 .endif

Modified: head/audio/csound/distinfo
==============================================================================
--- head/audio/csound/distinfo	Tue Oct  2 05:41:26 2012	(r305149)
+++ head/audio/csound/distinfo	Tue Oct  2 06:53:38 2012	(r305150)
@@ -1,4 +1,4 @@
-SHA256 (csound/Csound5.17.11.tar.gz) = a86595c4328b63e9b37205b40bf1441182a453451b0ea20558a7777dbc0380b7
-SIZE (csound/Csound5.17.11.tar.gz) = 9152189
-SHA256 (csound/Csound5.17_manual_html.zip) = cad3ee307c801c972d9d5f626a79c88dddda6872d8a4af64dd4f3edfe7c0f626
-SIZE (csound/Csound5.17_manual_html.zip) = 9621312
+SHA256 (csound/Csound5.18.02.tar.gz) = 4c461cf3bf60b83671224949dd33805379b7121bf2c0ad6af5e191e7f6f8adc8
+SIZE (csound/Csound5.18.02.tar.gz) = 9211491
+SHA256 (csound/Csound5.18_manual_html.zip) = a7347bb1a6b5af3497de95a2df36217a6a42219e2f36a3d6d505cd53b2719cd4
+SIZE (csound/Csound5.18_manual_html.zip) = 9773269

Modified: head/audio/csound/files/patch-H__sysdep.h
==============================================================================
--- head/audio/csound/files/patch-H__sysdep.h	Tue Oct  2 05:41:26 2012	(r305149)
+++ head/audio/csound/files/patch-H__sysdep.h	Tue Oct  2 06:53:38 2012	(r305150)
@@ -1,26 +1,26 @@
---- H/sysdep.h.orig	2012-05-29 02:41:30.000000000 +0900
-+++ H/sysdep.h	2012-05-31 11:19:28.000000000 +0900
-@@ -96,7 +96,11 @@
+--- H/sysdep.h.bak	2012-09-27 02:58:13.000000000 +0000
++++ H/sysdep.h	2012-09-27 03:02:06.000000000 +0000
+@@ -100,6 +100,11 @@
    #define EXP exp
    #define LOG log
    #define LOG10 log10
 +#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
 +  #define LOG2(x) (log(x) / log(2))
 +#else
-   #define LOG2 log2
++   #define LOG2 log2
 +#endif
+   /* #define LOG2 log2 */
    #define POWER pow
    #define SQRT sqrt
-   #define HYPOT hypot
-@@ -122,7 +126,11 @@
+@@ -126,6 +131,11 @@
    #define EXP expf
    #define LOG logf
    #define LOG10 log10f
 +#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
 +  #define LOG2(x) (logf(x) / logf(2))
 +#else
-   #define LOG2 log2f
++   #define LOG2 log2f
 +#endif
+   /* #define LOG2 log2f */
    #define POWER powf
    #define SQRT sqrtf
-   #define HYPOT hypotf

Added: head/audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp	Tue Oct  2 06:53:38 2012	(r305150)
@@ -0,0 +1,14 @@
+--- frontends/fltk_gui/CsoundPerformanceSettingsPanel.cpp.orig	2012-08-31 15:40:35.000000000 +0200
++++ frontends/fltk_gui/CsoundPerformanceSettingsPanel.cpp	2012-10-01 23:21:42.734591150 +0200
+@@ -4,9 +4,11 @@
+ #endif
+ 
+ //CS5GUI_EXPERIMENTAL device query section left out for Windows and Mac while the problem is found
++#ifndef __FreeBSD__
+ #ifdef LINUX
+ #define CS5GUI_EXPERIMENTAL
+ #endif
++#endif
+ 
+ 
+ #include "csound.hpp"

Modified: head/audio/csound/pkg-plist
==============================================================================
--- head/audio/csound/pkg-plist	Tue Oct  2 05:41:26 2012	(r305149)
+++ head/audio/csound/pkg-plist	Tue Oct  2 06:53:38 2012	(r305150)
@@ -48,6 +48,8 @@ include/csound/soundio.h
 include/csound/sysdep.h
 include/csound/text.h
 include/csound/version.h
+include/csound/interlocks.h
+lib/csound/plugins64/libplaterev.so
 lib/csound/plugins64/libampmidid.so
 lib/csound/plugins64/libcellular.so
 lib/csound/plugins64/libcontrol.so
@@ -2799,6 +2801,61 @@ lib/libcsound64.so.5
 %%PORTDOCS%%%%DOCSDIR%%/zkr.html
 %%PORTDOCS%%%%DOCSDIR%%/zkw.html
 %%PORTDOCS%%%%DOCSDIR%%/zkwm.html
+%%PORTDOCS%%%%DOCSDIR%%/platerev.html
+%%PORTDOCS%%%%DOCSDIR%%/cosseg.html
+%%PORTDOCS%%%%DOCSDIR%%/images/gen18_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gentanh_3.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_3.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gentanh_1.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_4.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/genexp_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen18_1.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen18_3.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gentanh_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_1.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen23.png
+%%PORTDOCS%%%%DOCSDIR%%/images/genexp_1.png
+%%PORTDOCS%%%%DOCSDIR%%/log2.html
+%%PORTDOCS%%%%DOCSDIR%%/vbapg.html
+%%PORTDOCS%%%%DOCSDIR%%/examples/logicOR.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/Mixer.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/genwave.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/cossegb.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/cossegr.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/spectrum.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/plate.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/log2.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/readf.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/readfi.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/pwd.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/maxaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/midipolyaftertouch.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/sym10.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/gen18.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/vbapg.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/cosseg.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/joystick.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/joystick-2.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/midiprogramchange.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/vbap.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/minabsaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/minaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/vbapmove.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/maxabsaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/gen23.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/mididefault.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/centroid.csd
+%%PORTDOCS%%%%DOCSDIR%%/vbapmove.html
+%%PORTDOCS%%%%DOCSDIR%%/pwd.html
+%%PORTDOCS%%%%DOCSDIR%%/vbap.html
+%%PORTDOCS%%%%DOCSDIR%%/GENwave.html
+%%PORTDOCS%%%%DOCSDIR%%/joystick.html
+%%PORTDOCS%%%%DOCSDIR%%/readf.html
+%%PORTDOCS%%%%DOCSDIR%%/cossegr.html
+%%PORTDOCS%%%%DOCSDIR%%/centroid.html
+%%PORTDOCS%%%%DOCSDIR%%/cossegb.html
+%%PORTDOCS%%%%DOCSDIR%%/readfi.html
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/images/callouts
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/images
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 10 Guido Falsi freebsd_committer 2012-10-02 07:53:58 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!