Bug 172339 - [PATCH] graphics/OpenEXR: update to 1.7.1, take maintainership, Makefile changed, OptionsNG
Summary: [PATCH] graphics/OpenEXR: update to 1.7.1, take maintainership, Makefile chan...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-04 23:40 UTC by nemysis
Modified: 2013-01-17 03:34 UTC (History)
0 users

See Also:


Attachments
OpenEXR-1.7.1.patch (11.26 KB, patch)
2012-10-04 23:40 UTC, nemysis
no flags Details | Diff
OpenEXR.shar (10.11 KB, application/x-shar)
2012-10-06 15:35 UTC, nemysis
no flags Details
OpenEXR.diff (614 bytes, patch)
2012-10-06 16:03 UTC, nemysis
no flags Details | Diff
OpenEXR.diff (11.37 KB, patch)
2012-10-06 21:41 UTC, nemysis
no flags Details | Diff
OpenEXR.diff (11.56 KB, patch)
2012-10-06 23:20 UTC, nemysis
no flags Details | Diff
OpenEXR.diff (11.58 KB, patch)
2012-10-11 21:32 UTC, nemysis
no flags Details | Diff
OpenEXR.diff (11.62 KB, patch)
2012-11-01 14:03 UTC, nemysis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description nemysis 2012-10-04 23:40:10 UTC
- Update to 1.7.1
- Take maintainership

Added file(s):
- files/patch-IlmImfExamples-Makefile.in

Removed file(s):
- files/patch-IlmImfExamples-Makeilfe.in


- Changed MASTER_SITES

+MASTER_SITES=	https://github.com/downloads/openexr/openexr/

- Changed COMMENT

+COMMENT=	High dynamic-range (HDR) image file format


- Added LICENSE

+LICENSE=	BSD


- Changed LIB_DEPENDS

+LIB_DEPENDS=	Imath:${PORTSDIR}/graphics/ilmbase


- Added OptionsNG

+.include <bsd.port.options.mk>


- Added post-install for PORTDOCS

+post-install:

- Rework

pkg-descr and pkg-plist

Generated and tested manually, tested with port test and with RedPorts (all RELEASES, CLANG), sent with FreeBSD Port Tools 0.99_6 (mode: update, diff: ports)

How-To-Repeat: 
portlint -A
WARN: /usr/local/ports/local/work/graphics/OpenEXR/pkg-plist:
Both ``%%PORTDOCS%%@dirrm %%DOCSDIR%%'' and ``%%PORTDOCS%%@unexec %D/%%DOCSDIR%% 2>/dev/null || true'' are missing.  At least one should be used.
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
WARN: Makefile: only one MASTER_SITE configured.  Consider adding additional mirrors.
0 fatal errors and 3 warnings found.

WARN: /usr/local/ports/local/work/graphics/OpenEXR/pkg-plist: because is used PORTDOCS and Port self install documentation

%%PORTDOCS%%@dirrmtry %%DOCSDIR%%


port test: clean


Build log RedPorts

https://redports.org/buildarchive/20121004171826-39854/
Comment 1 Baptiste Daroussin freebsd_committer 2012-10-06 15:19:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bapt

I'll take it.
Comment 2 nemysis 2012-10-06 15:35:41 UTC
Changed to

USE_PKGCONFIG=  build
Comment 3 nemysis 2012-10-06 16:03:21 UTC
Change to

+MASTER_SITES=  http://cloud.github.com/downloads/openexr/openexr/

+USE_GITHUB=  yes
Comment 4 nemysis 2012-10-06 23:20:56 UTC
All new looked and new pkg-plist, WRKSRC and deinstall is clean now.
Comment 5 Baptiste Daroussin freebsd_committer 2012-10-06 23:35:44 UTC
Responsible Changed
From-To: bapt->freebsd-ports-bugs

Back to the pool until I get time again to work in this, for 
informations NOPORTEXAMPLES and NOPORTDOCS are broken on the ports for 
now, submiter is working on a fix.
Comment 6 Steve Wills freebsd_committer 2012-10-07 17:26:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->swills

I'll take it.
Comment 7 nemysis 2012-11-01 14:03:48 UTC
Have changed to store all downloads in

DIST_SUBDIR=    OpenEXR
Comment 8 dfilter service freebsd_committer 2013-01-17 03:25:21 UTC
Author: swills
Date: Thu Jan 17 03:25:07 2013
New Revision: 310533
URL: http://svnweb.freebsd.org/changeset/ports/310533

Log:
  - Update to 1.7.1
  - Give maintainership to submitter
  
  PR:		ports/172339
  Submitted by:	nemysis <nemysis@gmx.ch>

Added:
  head/graphics/OpenEXR/files/patch-ImfAutoArray.h   (contents, props changed)
Deleted:
  head/graphics/OpenEXR/files/patch-IlmImfExamples-Makeilfe.in
  head/graphics/OpenEXR/files/patch-Makefile.in
  head/graphics/OpenEXR/files/patch-doc-Makefile.in
Modified:
  head/graphics/OpenEXR/Makefile
  head/graphics/OpenEXR/distinfo
  head/graphics/OpenEXR/files/patch-exrenvmap-main.cpp   (contents, props changed)
  head/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp   (contents, props changed)
  head/graphics/OpenEXR/pkg-descr   (contents, props changed)
  head/graphics/OpenEXR/pkg-plist

Modified: head/graphics/OpenEXR/Makefile
==============================================================================
--- head/graphics/OpenEXR/Makefile	Thu Jan 17 03:19:42 2013	(r310532)
+++ head/graphics/OpenEXR/Makefile	Thu Jan 17 03:25:07 2013	(r310533)
@@ -6,42 +6,65 @@
 #
 
 PORTNAME=	OpenEXR
-PORTVERSION=	1.7.0
-DISTNAME=	${PORTNAME:L}-${PORTVERSION}
+PORTVERSION=	1.7.1
 CATEGORIES=	graphics devel
-MASTER_SITES=	${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR=	${PORTNAME:L}
+MASTER_SITES=	http://cloud.github.com/downloads/openexr/openexr/
+DISTNAME=	${PORTNAME:L}-${DISTVERSION}
 
-MAINTAINER=	ports@FreeBSD.org
-COMMENT=	A high dynamic-range (HDR) image file format
+MAINTAINER=	nemysis@gmx.ch
+COMMENT=	High dynamic-range (HDR) image file format
 
-LIB_DEPENDS=	Half.6:${PORTSDIR}/graphics/ilmbase
+LICENSE=	BSD
+
+LIB_DEPENDS=	Imath:${PORTSDIR}/graphics/ilmbase
+
+WRKSRC=		${WRKDIR}/${DISTNAME}
 
 USE_GMAKE=	yes
-USE_GNOME=	pkgconfig
+USE_PKGCONFIG=	build
 USE_LDCONFIG=	yes
 USE_AUTOTOOLS=	libtool
 GNU_CONFIGURE=	YES
 
 CONFIGURE_ARGS+=--enable-imfexamples
 
-OPTIONS_DEFINE=	LARGE_STACK
+# must be explicitely linked with -l{thr|pthread}
+LDFLAGS+=	${PTHREAD_LIBS}
+
+DOCSRCDIR1=	${WRKSRC}
+DOC_FILES1=	AUTHORS ChangeLog NEWS README
+
+DOCSRCDIR2=	${WRKSRC}/doc
+DOC_FILES2=	MultiViewOpenEXR.pdf OpenEXRFileLayout.pdf \
+		ReadingAndWritingImageFiles.pdf TechnicalIntroduction.pdf
+
+OPTIONS_DEFINE=		LARGE_STACK
 LARGE_STACK_DESC=	Enable sys-dependant large stack optimizations
 
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
 
 .if ${PORT_OPTIONS:MLARGE_STACK}
 CONFIGURE_ARGS+=--enable-large-stack
 .endif
 
-# must be explicitely linked with -l{thr|pthread}
-LDFLAGS+=	${PTHREAD_LIBS}
-
-WRKSRC=		${WRKDIR}/${DISTNAME}
+post-patch:
+	@${REINPLACE_CMD} -e 's|examplesdir = $$(datadir)/doc/OpenEXR-@OPENEXR_VERSION@/examples|examplesdir = $$(prefix)/share/examples/OpenEXR|' \
+		${WRKSRC}/IlmImfExamples/Makefile.in
+	@${REINPLACE_CMD} -e 's|pkgconfigdir = $$(libdir)/pkgconfig|pkgconfigdir = $$(prefix)/libdata/pkgconfig|' \
+		${WRKSRC}/Makefile.in
+	@${REINPLACE_CMD} -e 's|docdir=$$(datadir)/doc/OpenEXR-@OPENEXR_VERSION@|docdir = $$(datadir)/doc/OpenEXR|' \
+	-e 's|doc_DATA = $$(EXTRA_DIST)|doc_DATA =|' ${WRKSRC}/doc/Makefile.am ${WRKSRC}/doc/Makefile.in
 
 regression-test regression test check:	build
 	@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
 
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+	${MKDIR} ${DOCSDIR}
+	${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+	${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR}
+.endif
+
 # IlmImfTest hangs indefinitely
 #
 #.if defined(PACKAGE_BUILDING)
@@ -52,4 +75,4 @@ regression-test regression test check:	b
 #.endif
 #.endif
 
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>

Modified: head/graphics/OpenEXR/distinfo
==============================================================================
--- head/graphics/OpenEXR/distinfo	Thu Jan 17 03:19:42 2013	(r310532)
+++ head/graphics/OpenEXR/distinfo	Thu Jan 17 03:25:07 2013	(r310533)
@@ -1,2 +1,2 @@
-SHA256 (openexr-1.7.0.tar.gz) = b68a2164d01bd028d15bd96af2704634a344e291dc7cc2019a662045d8c52ca4
-SIZE (openexr-1.7.0.tar.gz) = 13542910
+SHA256 (openexr-1.7.1.tar.gz) = 692ee6566d49939b2613e63b3afea2d38b871c0202cc829a7e32ced780af55c5
+SIZE (openexr-1.7.1.tar.gz) = 13554138

Added: head/graphics/OpenEXR/files/patch-ImfAutoArray.h
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/graphics/OpenEXR/files/patch-ImfAutoArray.h	Thu Jan 17 03:25:07 2013	(r310533)
@@ -0,0 +1,22 @@
+--- IlmImf/ImfAutoArray.h.orig	2012-07-17 19:27:26.000000000 -0400
++++ IlmImf/ImfAutoArray.h	2012-11-30 21:29:19.902497168 -0500
+@@ -46,6 +46,10 @@
+ 
+ #include "OpenEXRConfig.h"
+ 
++#if !defined (HAVE_LARGE_STACK)
++#include <cstring>
++#endif
++
+ namespace Imf {
+ 
+ 
+@@ -57,7 +61,7 @@
+     {
+       public:
+ 
+-	 AutoArray (): _data (new T [size]) { memset(_data, 0, size*sizeof(T)); }
++ 	 AutoArray (): _data (new T [size]) {::std::memset(_data, 0, size * sizeof(T));}
+ 	~AutoArray () {delete [] _data;}
+ 
+ 	operator T * ()			{return _data;}

Modified: head/graphics/OpenEXR/files/patch-exrenvmap-main.cpp
==============================================================================
--- head/graphics/OpenEXR/files/patch-exrenvmap-main.cpp	Thu Jan 17 03:19:42 2013	(r310532)
+++ head/graphics/OpenEXR/files/patch-exrenvmap-main.cpp	Thu Jan 17 03:25:07 2013	(r310533)
@@ -1,10 +1,10 @@
---- exrenvmap/main.cpp~
-+++ exrenvmap/main.cpp
-@@ -43,6 +43,7 @@
- #include <makeLatLongMap.h>
+--- exrenvmap/main.cpp.orig	2012-07-18 01:27:28.000000000 +0200
++++ exrenvmap/main.cpp	2012-10-04 10:44:12.000000000 +0200
+@@ -46,6 +46,7 @@
  #include <ImfEnvmap.h>
+ #include <ImfHeader.h>
  #include <iostream>
 +#include <cstring>
  #include <exception>
- #include <stdlib.h>
- 
+ #include <string>
+ #include <string.h>

Modified: head/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp
==============================================================================
--- head/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp	Thu Jan 17 03:19:42 2013	(r310532)
+++ head/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp	Thu Jan 17 03:25:07 2013	(r310533)
@@ -1,10 +1,10 @@
---- exrmaketiled/main.cpp~
-+++ exrmaketiled/main.cpp
+--- exrmaketiled/main.cpp.orig	2012-07-18 01:27:28.000000000 +0200
++++ exrmaketiled/main.cpp	2012-10-04 10:45:18.000000000 +0200
 @@ -44,6 +44,7 @@
  
  #include <iostream>
  #include <exception>
 +#include <cstring>
  #include <string>
+ #include <string.h>
  #include <stdlib.h>
- 

Modified: head/graphics/OpenEXR/pkg-descr
==============================================================================
--- head/graphics/OpenEXR/pkg-descr	Thu Jan 17 03:19:42 2013	(r310532)
+++ head/graphics/OpenEXR/pkg-descr	Thu Jan 17 03:25:07 2013	(r310533)
@@ -1,18 +1,24 @@
-Industrial Light & Magic(ILM), a division of Lucas Digital
-Ltd. LLC, implemented its own extended dynamic range file
-format in Summer 2000.  The existing 8-bit file format used
-at the time could not accurately reproduce images with
-extreme contrast between the darkest and brightest regions,
-or images with very subtle color gradations.
+OpenEXR is a high dynamic-range (HDR) image file format developed by
+Industrial Light & Magic for use in computer imaging applications.
 
-ILM's extended dynamic range file format has been employed
-successfully in the movies Harry Potter, Men in Black II,
-and Signs. Several shows currently in production at ILM are
-using the new format.
+OpenEXR is used by ILM on all motion pictures currently in production.
+The first movies to employ OpenEXR were Harry Potter and the Sorcerers Stone,
+Men in Black II, Gangs of New York, and Signs. Since then, OpenEXR has become
+ILM's main image file format.
 
-Realizing that various other parties are interested in an
-extended dynamic range file format, ILM decided to polish
-its new file format a bit, and to publish it.  OpenEXR is
-the result.
+OpenEXR's features include:
+* Higher dynamic range and color precision than existing 8- and 10-bit
+  image file formats.
+* Support for 16-bit floating-point, 32-bit floating-point, and 32-bit
+  integer pixels. The 16-bit floating-point format, called "half", is compatible
+  with the half data type in NVIDIA's Cg graphics language and is supported
+  natively on their new GeForce FX and Quadro FX 3D graphics solutions.
+* Multiple lossless image compression algorithms. Some of the included codecs
+  can achieve 2:1 lossless compression ratios on images with film grain.
+* Extensibility. New compression codecs and image types can easily be added
+  by extending the C++ classes included in the OpenEXR software distribution.
+  New image attributes (strings, vectors, integers, etc.) can be added to
+  OpenEXR image headers without affecting backward compatibility with existing
+  OpenEXR applications.
 
 WWW: http://www.openexr.org/

Modified: head/graphics/OpenEXR/pkg-plist
==============================================================================
--- head/graphics/OpenEXR/pkg-plist	Thu Jan 17 03:19:42 2013	(r310532)
+++ head/graphics/OpenEXR/pkg-plist	Thu Jan 17 03:25:07 2013	(r310533)
@@ -5,10 +5,6 @@ bin/exrmakepreview
 bin/exrmaketiled
 bin/exrmultiview
 bin/exrstdattr
-lib/libIlmImf.a
-lib/libIlmImf.la
-lib/libIlmImf.so
-lib/libIlmImf.so.6
 include/OpenEXR/ImfAcesFile.h
 include/OpenEXR/ImfArray.h
 include/OpenEXR/ImfAttribute.h
@@ -69,26 +65,36 @@ include/OpenEXR/ImfVersion.h
 include/OpenEXR/ImfWav.h
 include/OpenEXR/ImfXdr.h
 include/OpenEXR/OpenEXRConfig.h
+lib/libIlmImf.a
+lib/libIlmImf.la
+lib/libIlmImf.so
+lib/libIlmImf.so.7
 libdata/pkgconfig/OpenEXR.pc
 share/aclocal/openexr.m4
-%%DOCSDIR%%/MultiViewOpenEXR.pdf
-%%DOCSDIR%%/OpenEXRFileLayout.pdf
-%%DOCSDIR%%/ReadingAndWritingImageFiles.pdf
-%%DOCSDIR%%/TechnicalIntroduction.pdf
-%%EXAMPLESDIR%%/drawImage.cpp
-%%EXAMPLESDIR%%/drawImage.h
-%%EXAMPLESDIR%%/generalInterfaceExamples.cpp
-%%EXAMPLESDIR%%/generalInterfaceExamples.h
-%%EXAMPLESDIR%%/generalInterfaceTiledExamples.cpp
-%%EXAMPLESDIR%%/generalInterfaceTiledExamples.h
-%%EXAMPLESDIR%%/lowLevelIoExamples.cpp
-%%EXAMPLESDIR%%/lowLevelIoExamples.h
-%%EXAMPLESDIR%%/main.cpp
-%%EXAMPLESDIR%%/previewImageExamples.cpp
-%%EXAMPLESDIR%%/previewImageExamples.h
-%%EXAMPLESDIR%%/rgbaInterfaceExamples.cpp
-%%EXAMPLESDIR%%/rgbaInterfaceExamples.h
-%%EXAMPLESDIR%%/rgbaInterfaceTiledExamples.cpp
-%%EXAMPLESDIR%%/rgbaInterfaceTiledExamples.h
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/MultiViewOpenEXR.pdf
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/OpenEXRFileLayout.pdf
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ReadingAndWritingImageFiles.pdf
+%%PORTDOCS%%%%DOCSDIR%%/TechnicalIntroduction.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawImage.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawImage.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generalInterfaceExamples.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generalInterfaceExamples.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generalInterfaceTiledExamples.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generalInterfaceTiledExamples.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lowLevelIoExamples.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lowLevelIoExamples.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/main.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/previewImageExamples.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/previewImageExamples.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rgbaInterfaceExamples.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rgbaInterfaceExamples.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rgbaInterfaceTiledExamples.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rgbaInterfaceTiledExamples.h
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%-1.7.1
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry include/OpenEXR
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 9 Steve Wills freebsd_committer 2013-01-17 03:34:17 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks and thanks for your patience.