Bug 172839 - Update net-p2p/bitcoin to 0.7.1
Update net-p2p/bitcoin to 0.7.1
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Steve Wills
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 04:50 UTC by robbak
Modified: 2012-10-21 03:25 UTC (History)
0 users

See Also:


Attachments
bitcoin.diff (3.39 KB, patch)
2012-10-18 04:50 UTC, robbak
no flags Details | Diff
bitcoin.diff (3.45 KB, patch)
2012-10-21 02:11 UTC, robbak
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description robbak 2012-10-18 04:50:00 UTC
	Update bitcoin to recently released version 0.7.1

Fix: Patch below. While here:
		Update db version to 4.8, for compatability with current windows, linux and OSX client's data files
		convert to optionsng
		remove no-op sed commands. 
		pet portlint
	Input requested:
		Are any of the sed commands requred for other reasons? I have
		left the pthread one in, as that is converts -l pthread to 
		-pthread in the Makefile, but only the -l dl removal is needed
		to compile and use the port.
Comment 1 Edwin Groothuis freebsd_committer 2012-10-19 00:24:52 UTC
Responsible Changed
From-To: freebsd-ports-bugs->swills

swills@ wants his PRs (via the GNATS Auto Assign Tool)
Comment 2 steve 2012-10-20 19:11:59 UTC
Hi,

Nice work, this looks pretty good.

I did find that the port fails to build with the GUI option disabled. 
Perhaps this is an upstream issue?

Also, the test_bitcoin binary wasn't found for me, so I had to remove that.

Steve
Comment 3 robbak 2012-10-20 23:01:54 UTC
I'll retry the no-gui build. It was working with all my tests.

building the test-bitcoin binary - I build it and run the tests regularly.
Again, it always worked for me. I didn't include it in the files to
install. It only builds as part of the non-gui build.
Comment 4 robbak 2012-10-20 23:38:55 UTC
Yes, the build works for me. I am using 9.1 Prerelease from about a month ago.
Have I missed a dependency, maybe? I'm just setting up a VM to build
on a minimal system
Could I get some information on that build failure?

On 21 October 2012 08:01, Robert Backhaus <robbak@robbak.com> wrote:
> I'll retry the no-gui build. It was working with all my tests.
>
> building the test-bitcoin binary - I build it and run the tests regularly.
> Again, it always worked for me. I didn't include it in the files to install.
> It only builds as part of the non-gui build.
Comment 5 steve 2012-10-21 00:27:45 UTC
http://meatwad.mouf.net/tb/errors/9.0-RELEASE-i386-FreeBSD/bitcoin-0.7.1.log

Take a look at that log. I'll see f I can figure out the issue later.

Steve

On Oct 20, 2012, at 6:38 PM, Robert Backhaus <robbak@robbak.com> wrote:

> Yes, the build works for me. I am using 9.1 Prerelease from about a month ago.
> Have I missed a dependency, maybe? I'm just setting up a VM to build
> on a minimal system
> Could I get some information on that build failure?
> 
> On 21 October 2012 08:01, Robert Backhaus <robbak@robbak.com> wrote:
>> I'll retry the no-gui build. It was working with all my tests.
>> 
>> building the test-bitcoin binary - I build it and run the tests regularly.
>> Again, it always worked for me. I didn't include it in the files to install.
>> It only builds as part of the non-gui build.
Comment 6 robbak 2012-10-21 02:11:21 UTC
net.cpp:19:32: warning: miniupnpc/miniwget.h: No such file or directory

Looks like I am failing to remove the UPNP setting when it is not selected.

One of those sed commands unconditionally stripped a UPNP reference
from the Makefile, maybe it can go back in. Losing this line stops
USE_PNP being used, ever
-e 's|^USE_UPNP.*$$||' \

I can just put it back in, but I think we should edit it to reflect
our choice in the options.

-e 's|^USE_UPNP.*$$|USE_UPNP=$QMAKE_USE_UqPNP|' \

This seems to work, patch from original added.

On 21 October 2012 09:27, Steve Wills <steve@mouf.net> wrote:
> http://meatwad.mouf.net/tb/errors/9.0-RELEASE-i386-FreeBSD/bitcoin-0.7.1.log
>
> Take a look at that log. I'll see f I can figure out the issue later.
>
> Steve
>
> On Oct 20, 2012, at 6:38 PM, Robert Backhaus <robbak@robbak.com> wrote:
>
> Yes, the build works for me. I am using 9.1 Prerelease from about a month
> ago.
> Have I missed a dependency, maybe? I'm just setting up a VM to build
> on a minimal system
> Could I get some information on that build failure?
>
> On 21 October 2012 08:01, Robert Backhaus <robbak@robbak.com> wrote:
>
> I'll retry the no-gui build. It was working with all my tests.
>
>
> building the test-bitcoin binary - I build it and run the tests regularly.
>
> Again, it always worked for me. I didn't include it in the files to install.
>
> It only builds as part of the non-gui build.
Comment 7 Steve Wills freebsd_committer 2012-10-21 03:25:21 UTC
State Changed
From-To: open->closed

Committed. Thanks!