Bug 173031 - [build] [patch] pass through install as INSTALL when building PORTS_MODULES
Summary: [build] [patch] pass through install as INSTALL when building PORTS_MODULES
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-24 18:00 UTC by Enji Cooper
Modified: 2018-01-03 05:13 UTC (History)
0 users

See Also:


Attachments
file.diff (511 bytes, patch)
2012-10-24 18:00 UTC, Enji Cooper
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2012-10-24 18:00:01 UTC
Some third party software built upon autotools depends on install(1) to be an all singing and dancing version. This isn't the case when building PORTS_MODULES from the base system with some packages (fusefs-kmod, open-vm-tools, etc). The attached patch explicitly sets INSTALL to install (the default in ports) so some 3rd party packages can once again be built via PORTS_MODULES properly.

Fix: Patch attached with submission follows:
How-To-Repeat: 1. Install FreeBSD CURRENT on a VM.
2. cd /usr/src && make buildworld && make buildkernel PORTS_MODULES=emulators/open-vm-tools WITH_FUSE=y
Comment 1 Enji Cooper freebsd_committer 2012-10-24 18:15:06 UTC
Correction: when I said this:

"(the default in ports)"

I should have said this:

"(the default in the base system)"

Thanks!
-Garrett
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:18 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped