Bug 173037 - sysutils/salt to 0.10.4
Summary: sysutils/salt to 0.10.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-24 22:10 UTC by Denis Generalov
Modified: 2012-11-03 11:46 UTC (History)
0 users

See Also:


Attachments
file.txt (18.57 KB, text/plain)
2012-10-24 22:10 UTC, Denis Generalov
no flags Details
salt.diff (18.33 KB, patch)
2012-10-26 13:06 UTC, Guido Falsi
no flags Details | Diff
patch.txt (19.16 KB, text/plain)
2012-10-27 13:30 UTC, Denis Generalov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Generalov 2012-10-24 22:10:00 UTC
*) Update from 0.10.2 to 0.10.4
*) Remove indirect dependency. Salt does'nt directly depends on zmq.
*) Clean obsolete change setup.py at port-patch target.
*) trim Makefile header

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2012-10-24 22:10:31 UTC
Maintainer of sysutils/salt,

Please note that PR ports/173037 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/173037

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-10-24 22:10:32 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Christer Edwards 2012-10-25 16:34:31 UTC
looks good. approved.

On Wed, Oct 24, 2012 at 3:10 PM, Edwin Groothuis <edwin@freebsd.org> wrote:
> Maintainer of sysutils/salt,
>
> Please note that PR ports/173037 has just been submitted.
>
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
>
> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/173037
>
> --
> Edwin Groothuis via the GNATS Auto Assign Tool
> edwin@FreeBSD.org
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2012-10-25 23:45:31 UTC
State Changed
From-To: feedback->open

Maintainer approved.
Comment 5 Guido Falsi freebsd_committer 2012-10-26 10:11:50 UTC
Responsible Changed
From-To: freebsd-ports-bugs->madpilot

I'll take it.
Comment 6 Guido Falsi freebsd_committer 2012-10-26 13:06:27 UTC
Hi,

The PR description talks about removing direct dependency on zmq, but
the LIB_DEPENDS was still there.

I have tested removing it and the port seems to work fine(zmq is called
in by the RUN_DEPENDS on devel/py-pyzmq when installing).

Could you please test and approve the attached patch without
LIB_DEPENDS on zmq?

thanks!

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 7 Denis Generalov 2012-10-26 13:15:10 UTC
On Fri, 26 Oct 2012 14:06:27 +0200
Guido Falsi <madpilot@FreeBSD.org> wrote:

> Hi,
> 
> The PR description talks about removing direct dependency on zmq, but
> the LIB_DEPENDS was still there.
> 
> I have tested removing it and the port seems to work fine(zmq is called
> in by the RUN_DEPENDS on devel/py-pyzmq when installing).
> 
> Could you please test and approve the attached patch without
> LIB_DEPENDS on zmq?

Hi Guido,

You are absolutely right.
Thank you.

> 
> thanks!
> 
> -- 
> Guido Falsi <madpilot@FreeBSD.org>


-- 
Denis Generalov <gd@rambler-co.ru>
Comment 8 Guido Falsi freebsd_committer 2012-10-26 13:46:55 UTC
State Changed
From-To: open->feedback

Ask for maintainer approval.
Comment 9 Christer Edwards 2012-10-26 16:06:28 UTC
On Fri, Oct 26, 2012 at 6:46 AM,  <madpilot@freebsd.org> wrote:
> Synopsis: sysutils/salt to 0.10.4
>
> State-Changed-From-To: open->feedback
> State-Changed-By: madpilot
> State-Changed-When: Fri Oct 26 12:46:55 UTC 2012
> State-Changed-Why:
> Ask for maintainer approval.
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=173037

Looks good to me. approved.
Comment 10 Denis Generalov 2012-10-26 16:26:18 UTC
On Fri, 26 Oct 2012 14:06:27 +0200
Guido Falsi <madpilot@FreeBSD.org> wrote:

> Hi,
> 
> The PR description talks about removing direct dependency on zmq, but
> the LIB_DEPENDS was still there.
> 
> I have tested removing it and the port seems to work fine(zmq is called
> in by the RUN_DEPENDS on devel/py-pyzmq when installing).
> 
> Could you please test and approve the attached patch without
> LIB_DEPENDS on zmq?

Hi Guido,

Unfortunately I found tiny but serious problem.
May I ask you to hold this pr?
I will send new patch in a couple hours.

> 
> thanks!
> 
> -- 
> Guido Falsi <madpilot@FreeBSD.org>


-- 
Denis Generalov <gd@rambler-co.ru>
Comment 11 Guido Falsi freebsd_committer 2012-10-26 16:57:10 UTC
On Fri, Oct 26, 2012 at 07:26:18PM +0400, Denis Generalov wrote:
> 
> Hi Guido,
> 
> Unfortunately I found tiny but serious problem.
> May I ask you to hold this pr?
> I will send new patch in a couple hours.

Ok, no problem.

I must anyway to wait for maintainer's approval before committing.

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 12 Guido Falsi freebsd_committer 2012-10-26 17:08:17 UTC
BTW, could you please explain what the problem is?

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 13 Denis Generalov 2012-10-27 13:30:57 UTC
On Fri, 26 Oct 2012 17:57:10 +0200
Guido Falsi <madpilot@FreeBSD.org> wrote:

> On Fri, Oct 26, 2012 at 07:26:18PM +0400, Denis Generalov wrote:
> > 
> > Hi Guido,
> > 
> > Unfortunately I found tiny but serious problem.
> > May I ask you to hold this pr?
> > I will send new patch in a couple hours.
> 
> Ok, no problem.
> 
> I must anyway to wait for maintainer's approval before committing.
> 
> -- 
> Guido Falsi <madpilot@FreeBSD.org>

Hello Guido and Christer.

Sorry for delay. Unexpectedly Halloween happend.

I found 2 new places where path to config dir (/etc/salt) had been hardcoded.
So I made new patch. You can find this it attachment.

-- 
Denis Generalov <gd@rambler-co.ru>
Comment 14 Christer Edwards 2012-11-01 15:05:28 UTC
This looks good; approved. Thanks for the help Denis.

- Christer


On Thu, Nov 1, 2012 at 2:43 AM, Denis Generalov <gd@rambler-co.ru> wrote:

> On Wed, 31 Oct 2012 19:19:25 -0600
> Christer Edwards <christer.edwards@gmail.com> wrote:
>
> > Is it still pending approval? I don't think I saw an email for the latest
> > patch.
>
> Hi Christer,
>
> I sent new patch.
> You can find it in http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/173037
> Could you revise it?
>
> >
> >
> > On Sat, Oct 27, 2012 at 6:40 AM, Denis Generalov <gd@rambler-co.ru>
> wrote:
> >
> > > On Fri, 26 Oct 2012 09:41:09 -0600
> > > Christer Edwards <christer.edwards@gmail.com> wrote:
> > >
> > > > Denis -
> > > >
> > > > I'm curious what you ran into. Are you in #salt? btw, thanks for
> > > > handling some of the patches recently.
> > >
> > > I found hardcoded /etc/salt path in salt/cli/key.py
> salt/utils/parsers.py.
> > > I already sent new patch. Hope it's clear now.
> > >
> > > >
> > > > Christer
> > > >
> > > > On Fri, Oct 26, 2012 at 9:26 AM, Denis Generalov <gd@rambler-co.ru>
> > > wrote:
> > > > > On Fri, 26 Oct 2012 14:06:27 +0200
> > > > > Guido Falsi <madpilot@FreeBSD.org> wrote:
> > > > >
> > > > >> Hi,
> > > > >>
> > > > >> The PR description talks about removing direct dependency on zmq,
> but
> > > > >> the LIB_DEPENDS was still there.
> > > > >>
> > > > >> I have tested removing it and the port seems to work fine(zmq is
> > > called
> > > > >> in by the RUN_DEPENDS on devel/py-pyzmq when installing).
> > > > >>
> > > > >> Could you please test and approve the attached patch without
> > > > >> LIB_DEPENDS on zmq?
> > > > >
> > > > > Hi Guido,
> > > > >
> > > > > Unfortunately I found tiny but serious problem.
> > > > > May I ask you to hold this pr?
> > > > > I will send new patch in a couple hours.
> > > > >
> > > > >>
> > > > >> thanks!
> > > > >>
> > > > >> --
> > > > >> Guido Falsi <madpilot@FreeBSD.org>
> > > > >
> > > > >
> > > > > --
> > > > > Denis Generalov <gd@rambler-co.ru>
> > >
> > >
> > > --
> > > Denis Generalov <gd@rambler-co.ru>
> > >
>
>
> --
> Denis Generalov <gd@rambler-co.ru>
>
Comment 15 Guido Falsi freebsd_committer 2012-11-03 11:46:38 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!