Bug 173080 - [MAINTAINER] dns/ldns: update to 1.6.15
[MAINTAINER] dns/ldns: update to 1.6.15
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Alex Kozlov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 20:40 UTC by jaap
Modified: 2012-10-31 12:22 UTC (History)
0 users

See Also:


Attachments
ldns-1.6.15.patch (859 bytes, patch)
2012-10-25 20:40 UTC, jaap
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jaap 2012-10-25 20:40:00 UTC
- Update to 1.6.15

The original announcement says it all:

There is a binary incompatibility in ldns 1.6.14 which is fixed with an
emergency release of ldns 1.6.15.

Warning!
If you have compiled ldns using software with ldns-1.6.14, then this new
version will be binary incompatible with your installed version. You
will have to recompile the software together with ldns-1.6.15.

Was the software compiled with ldns-1.6.13 or earlier, then you will not
have this problem and can safely install ldns-1.6.15.

Best regards,

Willem

Changelog:
==========
* Remove LDNS_STATUS_EXISTS_ERR from ldns/error.h to make ldns
  binary compatible with earlier releases again.


Generated with FreeBSD Port Tools 0.99_6 (mode: update, diff: suffix)
Comment 1 Alex Kozlov freebsd_committer 2012-10-29 10:10:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ak

I'll take it.
Comment 2 Alex Kozlov freebsd_committer 2012-10-31 12:22:26 UTC
State Changed
From-To: open->closed

Committed. Thanks!