Bug 173575 - Fix devel/boost-python-libs with python-3.2
Summary: Fix devel/boost-python-libs with python-3.2
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-office mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 12:10 UTC by Dmitry Sivachenko
Modified: 2014-08-27 05:59 UTC (History)
0 users

See Also:


Attachments
file.diff (782 bytes, patch)
2012-11-12 12:10 UTC, Dmitry Sivachenko
no flags Details | Diff
boost-python3-libs.shar.txt (3.61 KB, text/plain; charset=UTF-8)
2013-02-07 03:03 UTC, Shane
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Sivachenko freebsd_committer 2012-11-12 12:10:00 UTC
devel/boost-python-libs fails to build with python version 3.2.
This patch fixes that.
Comment 1 Edwin Groothuis freebsd_committer 2012-11-12 12:10:07 UTC
Maintainer of devel/boost-python-libs,

Please note that PR ports/173575 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/173575

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-11-12 12:10:08 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Baptiste Daroussin freebsd_committer 2013-02-02 17:43:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-office

Over to new maintainer, can you check with new boost?
Comment 4 Shane 2013-02-07 03:03:26 UTC
While manually building devel/boost-python-libs against python 3.x can 
be done there are two things to consider. First is that when 
boost-python-libs is built against py3.x more lib files are generated 
that aren't taken into account, they are libboost_python3 with .a .so 
and .so.%%BOOST_SHARED_LIB_VER%% suffixes.

The second issue is that when another port brings in boost-python-libs 
as a dependency I don't see a way to make it build against python 3.x. 
The only way I have found to make this work is to create another port 
that only builds against python 3.x

While blender did start using this for a while they have dropped it but 
I thought I would still send this in.

The attached patch is a duplicate of boost-python-libs v1.52 that is 
adjusted to handle libboost_python3
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2013-03-10 02:05:41 UTC
Responsible Changed
From-To: freebsd-office->office

Canonicalize assignment.
Comment 6 Baptiste Daroussin freebsd_committer 2014-08-26 06:34:35 UTC
Sorry for long delay here, but can you check on newer boost?
Comment 7 Dmitry Sivachenko freebsd_committer 2014-08-26 13:14:13 UTC
(In reply to Baptiste Daroussin from comment #6)
> Sorry for long delay here, but can you check on newer boost?

It looks fine now.