Bug 173710 - Added section "MTP storage" to handbook
Summary: Added section "MTP storage" to handbook
Status: Open
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Nikolai Lifanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-19 03:10 UTC by yuri
Modified: 2018-05-28 20:36 UTC (History)
4 users (show)

See Also:


Attachments
file.diff (2.44 KB, patch)
2012-11-19 03:10 UTC, yuri
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yuri 2012-11-19 03:10:00 UTC
Adding section for MTP protocol: http://en.wikipedia.org/wiki/Media_Transfer_Protocol

It is widely used today in place of umass USB interface in smartphones, digital cameras and music players and deserves its own section in handbook. This will automatically answer some user questions when they want to use such devices with FreeBSD.

Fix: Patch attached with submission follows:
Comment 1 Miroslav Lachman 2015-10-19 08:51:50 UTC
What is the reason to not commit this helpful information in to Handbook?
I tried to find some information how to connect my Android device as MTP and I found this PR instead of some useful handbook page.

No I found that we have 3 choices in ports:

graphics/fusefs-gphotofs
sysutils/mtpfs
sysutils/fusefs-simple-mtpfs

I didn't tried them yet.
Comment 2 Yuri Victorovich freebsd_committer 2015-10-19 09:03:14 UTC
Yes, the commit process is excruciatingly slow.
Comment 3 Benedict Reuschling freebsd_committer 2015-10-19 10:53:53 UTC
I had a look at the patch. It does not apply cleanly to the latest version of the disks chapter. Can you send us an updated patch?
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2015-10-19 14:48:09 UTC
I apologize for the slowness.  The fact is that we have many more PRs than we have committers.
Comment 5 Miroslav Lachman 2017-02-20 09:18:20 UTC
If it takes 5 years to commit patch then why anybody should contribute? Everything done becomes obsolete and cannot be committed anyway.
Comment 6 Nikolai Lifanov freebsd_committer 2017-02-20 18:01:05 UTC
Hi Miroslav,

Thank you for your patience. I'm working on landing this right now.
The FreeBSD project is run by volunteers and sometimes these slip through the cracks. If you feel that your PRs are being neglected, feel free to post to the appropriate mailing list or get someone on IRC or CC me to the PR directly and I will try to move it along.
Comment 7 Miroslav Lachman 2017-05-15 12:16:43 UTC
Just asking - what's the status of this PR? 
I tried to connect phone to FreeBSD desktop without any luck. I found much more ports stating "MTP / PTP" file transfer but still no Handbook chapter.
Comment 8 Yuri Victorovich freebsd_committer 2017-05-15 15:20:05 UTC
@Miroslav

When I tried MTP at the time, in 2012, it worked. This is why I submitted the original PR. I never tried again, because I happen to use other apps to sync cellphones.

Are you getting errors?

Yuri
Comment 9 Miroslav Lachman 2017-05-15 16:31:08 UTC
(In reply to Yuri Victorovich from comment #8)
The problem was with phone - it must be manually configured to allow MTP over USB so now it works with simple-mtpfs.
I also tried gmtp but it doesn't work. It freezes on each try.

Thank you for your interest! 

PS: Arch Linux wiki was very helpful. It would be nice to have this in FreeBSD Handbook
https://wiki.archlinux.org/index.php/MTP
Comment 10 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:49:22 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 11 Miroslav Lachman 2018-05-28 20:34:55 UTC
It seems this will remain unresolved 'til infinity, so just for the record if anybody find this PR on the internet search - I am using sysutils/fusefs-simple-mtpfs for mounting my Xiaomi Redmi 4X.
Comment 12 Yuri Victorovich freebsd_committer 2018-05-28 20:36:36 UTC
(In reply to Miroslav Lachman from comment #11)

I could have committed it, but my bit is only good for ports. -)