Bug 173834 - [PATCH] devel/py-urwid: update to 1.1.1, Add OPTIONSFILE, regression-test target
Summary: [PATCH] devel/py-urwid: update to 1.1.1, Add OPTIONSFILE, regression-test target
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-22 09:40 UTC by koobs
Modified: 2012-12-02 10:19 UTC (History)
1 user (show)

See Also:


Attachments
py27-urwid-1.1.1.patch (1.66 KB, patch)
2012-11-22 09:40 UTC, koobs
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description koobs 2012-11-22 09:40:00 UTC
- Update to 1.1.1
- Add OPTIONSFILE to save OPTIONS properly
- Fix source directory for installing EXAMPLES
- Add regression-test target for unit tests
- Trim Makefile header
- Silence @cd calls
- Whitespace alignment

====[QA]====
portlint: WARN: Makefile: only one MASTER_SITE configured
porttest: OK (GCC & CLANG 9.0-RELEASE amd64)
unittest: Ran 283 tests in 0.490s - FAILED (failures=5, errors=4)

Note:

The same tests fail for previous version (1.0.2). Failures
are for doctests, are due to missing gobject import and fail on:

evl = GLibEventLoop()

============

Port maintainer (python@FreeBSD.org) is cc'd.

Generated with FreeBSD Port Tools 0.99_6 (mode: update, diff: ports)
Comment 1 Edwin Groothuis freebsd_committer 2012-11-22 09:40:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2012-12-02 10:15:29 UTC
Responsible Changed
From-To: freebsd-python->rm

I will take it.
Comment 3 Ruslan Makhmatkhanov freebsd_committer 2012-12-02 10:19:50 UTC
State Changed
From-To: open->closed

Committed, thank you!