Bug 173915 - mergemaster(8) painful due to old ident tags
Summary: mergemaster(8) painful due to old ident tags
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 9.1-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-25 21:40 UTC by Thierry Thomas
Modified: 2014-09-05 01:10 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Thomas freebsd_committer 2012-11-25 21:40:00 UTC
	When upgrading a machine to 9.1-PRERELEASE, mergemaster is
	painfull, because many quiete recent files are replaced with
	files with old ident.

	E.g.:

$ ident /etc/hosts /etc/shells /etc/csh.cshrc
/etc/hosts:
     $FreeBSD: stable/9/etc/hosts 109997 2003-01-28 21:29:23Z dbaker $

/etc/shells:
     $FreeBSD: stable/9/etc/shells 59717 2000-04-27 21:58:46Z ache $

/etc/csh.cshrc:
     $FreeBSD: stable/9/etc/csh.cshrc 50472 1999-08-27 23:37:10Z peter $

Fix: 

Force commit of these oldies.
How-To-Repeat: 	Check ident of many files under /etc.
Comment 1 Glen Barber freebsd_committer 2014-09-05 01:10:20 UTC
Disregarding the age of the PR, closing since '-F' should be used if the RCSID is the only change, according to the manual page:

     -F          If the files differ only by VCS Id ($FreeBSD) install the new
                 file.

If this is indeed still an issue, please open a new PR, but this is not RE territory IMHO.