Bug 174504 - [acpi] [suspend/resume] Suspend/resume broken on Lenovo x220
Summary: [acpi] [suspend/resume] Suspend/resume broken on Lenovo x220
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-acpi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-17 07:50 UTC by Ganael LAPLANCHE
Modified: 2014-09-22 18:58 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ganael LAPLANCHE freebsd_committer 2012-12-17 07:50:00 UTC
Hi,

See this thread :

http://lists.freebsd.org/pipermail/freebsd-current/2012-December/038530.html

and this one :

http://lists.freebsd.org/pipermail/freebsd-current/2012-March/032519.html

Suspend/resume is broken on my Lenovo x220 (amd64) since revision 231797.

To find this regression, I used a kernel patched with KMS patch "all.13.7.patch", as well as the new Xorg and the intel+KMS driver. Suspend/resume breaks at revision 231797 while it works fine until 231796.

To be more precise, suspend does not seem to terminate ; resume make the computer hang.
Comment 1 Ganael LAPLANCHE freebsd_committer 2012-12-26 07:29:12 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-acpi

Over to ACPI team
Comment 2 Ganael LAPLANCHE freebsd_committer 2013-09-05 07:35:39 UTC
Hi,

Following this message :

http://lists.freebsd.org/pipermail/freebsd-acpi/2013-August/008335.html

I can confirm that removing the VESA option from the kernel enables
suspend/resume again. I don't know how the change introduced by rev.
231797 is related to VESA, but it might give a hint.

As removing VESA is only a workaround, I'll leave this PR opened for the
moment. Feel free to close it if you think it can be.

Best regards,

--
Ganael LAPLANCHE <ganael.laplanche@martymac.org>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <martymac@FreeBSD.org>, http://www.FreeBSD.org
Comment 3 John Baldwin freebsd_committer 2014-09-22 18:58:00 UTC
I suspect no one is going to dig into the VESA breakage at this point.  Suspend and resume works fine with KMS and vt(4) however on the x220.