Bug 174574 - [ERROR] cannot build editors/libreoffice with icu_50
Summary: [ERROR] cannot build editors/libreoffice with icu_50
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-19 13:30 UTC by Andrei Lavreniyuk
Modified: 2013-03-20 17:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Lavreniyuk 2012-12-19 13:30:00 UTC
=============
(62/113) Building module i18npool
=============
Entering /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/i18npool/prj

[ build PKG ] i18npool_inc
[ build CXX ] i18npool/source/breakiterator/gendict
[ build CXX ] CustomTarget/basegfx/source/pixel/bpixel
[ build LNK ] Executable/gendict
[ build MAK ] i18npool/source/breakiterator
[ build CXX ] CustomTarget/basegfx/source/matrix/b2dhommatrixtools
genbrk: tool completed successfully.
generating C code for dict_word.brk
genbrk: tool completed successfully.
generating C code for edit_word_he.brk
genbrk: tool completed successfully.
generating C code for sent.brk
[ build CXX ] CustomTarget/basegfx/source/matrix/b3dhommatrix
genbrk: tool completed successfully.
generating C code for dict_word_fi.brk
genbrk: tool completed successfully.
generating C code for dict_word_prepostdash.brk
genbrk: tool completed successfully.
generating C code for char.brk
genbrk: tool completed successfully.
generating C code for char_in.brk
genbrk: tool completed successfully.
generating C code for edit_word.brk
[ build CXX ] CustomTarget/basegfx/source/matrix/b2dhommatrix
genbrk: tool completed successfully.
generating C code for dict_word_hu.brk
genbrk: tool completed successfully.
generating C code for count_word_fi.brk
genbrk: tool completed successfully.
generating C code for dict_word_he.brk
genbrk: tool completed successfully.
generating C code for dict_word_ca.brk
[ build CXX ] CustomTarget/basegfx/source/point/b3ipoint
genbrk: tool completed successfully.
generating C code for dict_word_nodash.brk
genbrk: tool completed successfully.
generating C code for count_word.brk
genbrk: tool completed successfully.
generating C code for line.brk
[ build CXX ] CustomTarget/basegfx/source/point/b2dpoint
genbrk: tool completed successfully.
generating C code for edit_word_hu.brk
[ build CXX ] CustomTarget/basegfx/source/point/b3dpoint
[ build CXX ] i18npool/source/collator/gencoll_rule
[ build CXX ] CustomTarget/basegfx/source/point/b2dhompoint
[ build LNK ] Executable/gencoll_rule
[ build CXX ] CustomTarget/basegfx/source/point/b2ipoint
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/workdir/unxfbsd.pro/CxxObject/i18npool/source/collator/gencoll_rule.o: In function `main':
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/i18npool/source/collator/gencoll_rule.cxx:(.text+0x3c9): undefined reference to `icu_50::UnicodeString::UnicodeString(unsigned short const*)'
clang++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[2]: *** [/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/workdir/unxfbsd.pro/LinkTarget/Executable/gencoll_rule] Ошибка 1
dmake:  Error code 2, while making 'all'
Comment 1 Edwin Groothuis freebsd_committer 2012-12-19 13:30:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Baptiste Daroussin freebsd_committer 2012-12-19 13:52:05 UTC
Are you sure that
1/ you ports tree is up to date?
2/ you followed UPDATING?

regards,
Bapt
Comment 3 Baptiste Daroussin freebsd_committer 2012-12-19 23:20:35 UTC
Ok I manage to reproduce this, it apparently happens when built on 9.1
and CURRENT probably a problem with clang, can you try to build
WITH_GCC.

Bapt
Comment 4 spry 2012-12-20 07:17:28 UTC
I'm having this problem as well.

On 9.X, the port defaults to clang (if present in the base), or will
use/install clang-devel, if not installed.

Before the last commits to this port, it built fine, however, running
it, I get:

Dec 20 15:08:28 cajon kernel: pid 1573 (soffice.bin), uid 1000: exited
on signal 6 (core dumped)

Running it from the shell:

mars@cajon:~> soffice
terminate called after throwing an instance of
'com::sun::star::ucb::InteractiveAugmentedIOException'
mars@cajon:~>

Which is supposedly addressed already in the port's Makefile. But I'm on
9.1-RELEASE already.

So I tried USE_GCC. And the build fails. Also try GCC 4.7 and 4.8, same
thing :-(

I can test patches, and I've a jailed build setup at my disposal atm.

Thanks.



-- 
Do students of Zen Buddhism do Om-work?
Comment 5 Baptiste Daroussin freebsd_committer 2012-12-20 10:40:43 UTC
did you try WITH_GCC or USE_GCC, if you tried USE_GCC it is wrong, you
should try WITH_GCC.

I just performed the build successfully with WITH_GCC on 9.1-RELEASE
amd64, 10-CURRENT (as of 2 weeks ago) 9.0-RELEASE i386.
Build was succesfull and running is just as expected

regards,
Bapt
Comment 6 spry 2012-12-20 15:57:42 UTC
Did it again now (WITH_GCC), it still fails

......
[ build CHK ] editeng
[ build CHK ] loaded modules: editeng

editeng deliver
Module 'editeng' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
         Oh dear - something failed during the build - sorry !
   For more help with debugging build errors, please see the section in:
             http://wiki.documentfoundation.org/Development

   internal build errors:

ERROR: error 65280 occurred while making 
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/ucb/source/ucp/gio

  it seems that the error is inside 'ucb', please re-run build
  inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd 
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2
source ./Env.Host.sh
cd ucb
rm -Rf 
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/ucb/unxfbsd.pro 
# optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the 
top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory 
`/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.



......


-- 
You have all the characteristics of a popular politician:
a horrible voice, bad breeding, and a vulgar manner.
		-- Aristophanes
Comment 7 spry 2012-12-28 09:40:19 UTC
Update to this:

 I built another jail again, then built all my ports. Also note that I
didn't build clang in the base ( WITHOUT_CLANG="YES" in /etc/src.conf)
as that takes buildworld too long. It bombs at

++++++++++
2 warnings generated.
[ build CXX ] basebmp/test/tools
In file included from
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/basebmp/test/tools.cxx:34:
In file included from
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/basebmp/inc/basebmp/color.hxx:33:
In file included from
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/solver/unxfbsd.pro/inc/rtl/math.hxx:32:
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/solver/unxfbsd.pro/inc/rtl/math.h:128:6:
warning: all elements of 'rtl_math_DecimalP
laces' are initialized with literals to value 134217727 [-Wunique-enum]
enum rtl_math_DecimalPlaces
~~~~~^~~~~~~~~~~~~~~~~~~~~~
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/solver/unxfbsd.pro/inc/rtl/math.h:138:5:
note: initialize the last element with the previous element to silence
this warning
    rtl_math_DecimalPlaces_DefaultSignificance = 0x7ffffff
    ^                                            ~~~~~~~~~
                                                 rtl_math_DecimalPlaces_Max
In file included from
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/basebmp/test/tools.cxx:35:
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/basebmp/inc/basebmp/bitmapdevice.hxx:66:1:
warning: 'IBitmapDeviceDamageTracker' defined as a struct here but
previously declared as a class [-Wmismatched-tags]
struct IBitmapDeviceDamageTracker
^
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/basebmp/inc/basebmp/bitmapdevice.hxx:59:28:
note: did you mean struct here?
typedef boost::shared_ptr< class IBitmapDeviceDamageTracker >
IBitmapDeviceDamageTrackerSharedPtr;
                           ^~~~~
                           struct
2 warnings generated.
[ build LNK ] CppunitTest/libtest_basebmp_test.so
[ build CUT ] basebmp_test
[ build CHK ] basebmp
[ build CHK ] loaded modules: basebmp

basebmp deliver
Module 'basebmp' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making
/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/i18npool/prj

 it seems that the error is inside 'i18npool', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2
source ./Env.Host.sh
cd i18npool
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory
`/home/tmp_ports/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [install] Error code 1

Stop in /usr/ports/editors/libreoffice.

Script done on Fri Dec 28 02:56:29 2012
+++++++++++

It's probably a clang-related (port) build error.

So I rebuilt it WITH_GCC, and it built fine. Running it seems fine
also, was able to work w/ some documents.

This is on FreeBSD 9.1-RELEASE/amd64.




-- 
cheers
mars
-----
Comment 8 Andrei Lavreniyuk 2013-03-20 10:46:01 UTC
Please close PR.
Comment 9 Jung-uk Kim freebsd_committer 2013-03-20 17:29:42 UTC
State Changed
From-To: open->closed

We have LibreOffice 4 in ports tree now and it builds fine with ICU 50. 
Closing per OP's request.