Bug 174722 - [wlan] can't use channel 12 and 13 (14) with my wifi interface
Summary: [wlan] can't use channel 12 and 13 (14) with my wifi interface
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: 9.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-26 18:30 UTC by Carsten Wiedmann
Modified: 2018-05-29 08:25 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Wiedmann 2012-12-26 18:30:00 UTC
Hello,

I can't 
I have this network card:
iwi0: <Intel(R) PRO/Wireless 2200BG> mem 0xe0204000-0xe0204fff irq 11 at device 6.0 on pci2

Interface setup in "/etc/rc.conf" is:
wlans_iwi0="wlan0"
ifconfig_wlan0="DHCP WPA country DE"


Output of "ifconfig wlan0" is:
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:0e:35:a8:2e:f1
        inet 192.168.0.30 netmask 0xffffff00 broadcast 192.168.0.255
        nd6 options=23<PERFORMNUD,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet OFDM/54Mbps mode 11g
        status: associated
        ssid WLAN channel 9 (2452 MHz 11g) bssid 0c:0c:0b:14:cd:98
        regdomain ETSI country DE authmode WPA2/802.11i privacy ON
        deftxkey UNDEF AES-CCM 2:128-bit txpower 30 bmiss 24 scanvalid 60
        protmode CTS wme roaming MANUAL


But even I'm in regdomain ETSI, "ifconfig wlan0 list regdomain":
:regdomain ETSI country DE anywhere -ecm

A "ifconfig wlan0 list channels" only shows me channel 1 to 11. Looking
in "/etc/regdomain.xml", channel 12-13 should be possible in ETSI.

BTW: This also happens if I use ndis, instead of the iwi driver.

Of course, booting the notebook with Windows or Debian (squeeze), I can
use channel 12-13 (14).
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-12-28 03:25:08 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-wireless

Over to maintainer(s).
Comment 2 Adrian Chadd freebsd_committer 2012-12-28 03:57:55 UTC
Hi,

This may be the problem:

:regdomain ETSI country DE anywhere -ecm

Please try:

ifconfig wlan0 down
ifconfig wlan0 ecm
ifconfig wlan0 up

If ECM isn't enabled then you won't see channels > 11 in 11bg mode.



Adrian
Comment 3 Carsten Wiedmann 2012-12-28 12:43:25 UTC
Hmmm, doesn't work:

freebsd# ifconfig wlan0 list regdomain
:regdomain ETSI country DE anywhere ecm
Channel   1 : 2412      MHz 11b          Channel   6 : 2437      MHz 11g
Channel   1 : 2412      MHz 11g          Channel   7 : 2442      MHz 11b
Channel   2 : 2417      MHz 11b          Channel   7 : 2442      MHz 11g
Channel   2 : 2417      MHz 11g          Channel   8 : 2447      MHz 11b
Channel   3 : 2422      MHz 11b          Channel   8 : 2447      MHz 11g
Channel   3 : 2422      MHz 11g          Channel   9 : 2452      MHz 11b
Channel   4 : 2427      MHz 11b          Channel   9 : 2452      MHz 11g
Channel   4 : 2427      MHz 11g          Channel  10 : 2457      MHz 11b
Channel   5 : 2432      MHz 11b          Channel  10 : 2457      MHz 11g
Channel   5 : 2432      MHz 11g          Channel  11 : 2462      MHz 11b
Channel   6 : 2437      MHz 11b          Channel  11 : 2462      MHz 11g

BTW:
Even "ifconfig wlan0 ecm" is changing this setting, I can't find "ecm" in "man ifconfig"?
Comment 4 Carsten Wiedmann 2012-12-28 12:47:59 UTC
Hmmm, doesn't work:

freebsd# ifconfig wlan0 list regdomain
:regdomain ETSI country DE anywhere ecm
Channel   1 : 2412      MHz 11b          Channel   6 : 2437      MHz 11g
Channel   1 : 2412      MHz 11g          Channel   7 : 2442      MHz 11b
Channel   2 : 2417      MHz 11b          Channel   7 : 2442      MHz 11g
Channel   2 : 2417      MHz 11g          Channel   8 : 2447      MHz 11b
Channel   3 : 2422      MHz 11b          Channel   8 : 2447      MHz 11g
Channel   3 : 2422      MHz 11g          Channel   9 : 2452      MHz 11b
Channel   4 : 2427      MHz 11b          Channel   9 : 2452      MHz 11g
Channel   4 : 2427      MHz 11g          Channel  10 : 2457      MHz 11b
Channel   5 : 2432      MHz 11b          Channel  10 : 2457      MHz 11g
Channel   5 : 2432      MHz 11g          Channel  11 : 2462      MHz 11b
Channel   6 : 2437      MHz 11b          Channel  11 : 2462      MHz 11g

BTW:
Even "ifconfig wlan0 ecm" is changing this setting, I can't find "ecm" in "man ifconfig"?
Comment 5 takacsk2004 2016-07-26 08:58:36 UTC
I have had this bug right now. We received a new router from ISP and it has not been detected at all. Simply setting the channel from 13 to 11 has solved it. 
FreeBSD 10.3; run0 driver (TP-LINK WN727N stick), default settings, only SSID and password added.
Comment 6 Andriy Voskoboinyk freebsd_committer 2016-07-26 17:24:37 UTC
Hi!

This problem was resolved in 11-CURRENT (r300748) (and there are no plans to merge it into previous releases).
Comment 7 Taras Korenko 2017-02-08 19:01:18 UTC
Well, FreeBSD 11.0-STABLE (r313440), the problem is not fixed yet: bug 216923.
Comment 8 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:48:52 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 9 Andriy Voskoboinyk freebsd_committer 2018-05-29 08:25:08 UTC
Fixed in r313694