Bug 174846 - java/eclipse: libxul 10 does not work for Eclipse SWT plugin browser functions
Summary: java/eclipse: libxul 10 does not work for Eclipse SWT plugin browser functions
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-eclipse mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-31 01:20 UTC by Jimmy Kelley
Modified: 2013-03-03 03:00 UTC (History)
0 users

See Also:


Attachments
file.diff (2.37 KB, patch)
2012-12-31 01:20 UTC, Jimmy Kelley
no flags Details | Diff
eclipse-patch.txt (2.39 KB, text/plain; charset=US-ASCII)
2013-02-03 22:17 UTC, Jimmy Kelley
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy Kelley 2012-12-31 01:20:00 UTC
The SWT plugin libraries for browser support in the eclipse port will
not compile using libxul version 10.

Fix: Use the webkit-gtk2 library to provide the SWT browser functions instead
of libxul.

Patch attached with submission follows:
How-To-Repeat: With the libxul port installed (replacing libxul 1.9 with libxul 10),
build the eclipse port:
    cd /usr/ports/java/eclipse
    make
The port build will succeed, but a check of the build logs in the
work/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92 directory
will show errors in the building of the SWT native libraries.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-12-31 07:25:06 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-eclipse

reclassify.
Comment 2 dfilter service freebsd_committer 2013-03-03 02:51:38 UTC
Author: glewis
Date: Sun Mar  3 02:51:25 2013
New Revision: 313322
URL: http://svnweb.freebsd.org/changeset/ports/313322

Log:
  . Use the webkit-gtk2 library to provide the SWT browser functions instead
    of libxul since the SWT plugin libraries in the eclipse-devel port will
    not compile using libxul version 10.
  
  PR:		174846
  Submitted by:	Jimmy Kelley <ljboiler@gmail.com>

Modified:
  head/java/eclipse/Makefile   (contents, props changed)
  head/java/eclipse/files/freebsd-support.patch   (contents, props changed)

Modified: head/java/eclipse/Makefile
==============================================================================
--- head/java/eclipse/Makefile	Sun Mar  3 02:09:06 2013	(r313321)
+++ head/java/eclipse/Makefile	Sun Mar  3 02:51:25 2013	(r313322)
@@ -2,7 +2,7 @@
 
 PORTNAME=	eclipse
 PORTVERSION=	3.7.1
-PORTREVISION=	3
+PORTREVISION=	4
 CATEGORIES=	java devel
 MASTER_SITES=	http://download.eclipse.org/technology/linuxtools/eclipse-build/3.7.x_Indigo/:1 \
 		http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/:2 \
@@ -32,7 +32,8 @@ BUILD_DEPENDS=	gpatch:${PORTSDIR}/devel/
 		rsync:${PORTSDIR}/net/rsync \
 		unzip:${PORTSDIR}/archivers/unzip \
 		zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS=	cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS=	cairo.2:${PORTSDIR}/graphics/cairo \
+		webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
 
 OPTIONS_DEFINE=	TESTS
 TESTS_DESC=	Build SDK test suite
@@ -40,7 +41,6 @@ TESTS_DESC=	Build SDK test suite
 ONLY_FOR_ARCHS=	i386 amd64
 
 USE_ANT=	yes
-USE_GECKO=	libxul19
 USE_GL=		glu
 USE_GMAKE=	yes
 USE_GNOME=	desktopfileutils gconf2 gtk20 gnomevfs2 libgnome libgnomeui

Modified: head/java/eclipse/files/freebsd-support.patch
==============================================================================
--- head/java/eclipse/files/freebsd-support.patch	Sun Mar  3 02:09:06 2013	(r313321)
+++ head/java/eclipse/files/freebsd-support.patch	Sun Mar  3 02:51:25 2013	(r313322)
@@ -7459,3 +7459,24 @@ $FreeBSD$
  	else
  		echo "None of the following libraries were found:  Mozilla/XPCOM, Firefox/XPCOM, or XULRunner/XPCOM"
  		echo "    *** Mozilla embedding support will not be compiled."
+--- build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh.orig	2012-12-25 21:01:56.000000000 -0600
++++ build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh	2012-12-25 21:28:35.000000000 -0600
+@@ -491,7 +491,7 @@
+ 		export MOZILLA_INCLUDES
+ 		export MOZILLA_LIBS
+ 		MAKE_MOZILLA=make_mozilla
+-	elif [ x`pkg-config --exists libxul && echo YES` = "xYES" ]; then
++	elif [ x`pkg-config --exists "libxul < 2" && echo YES` = "xYES" ]; then
+ 		XULRUNNER_INCLUDES=`pkg-config --cflags libxul`
+ 		XULRUNNER_LIBS=`pkg-config --libs libxul`
+		XULRUNNER_LIBS=`echo ${XULRUNNER_LIBS} -lxpcomglue`
+--- build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_freebsd.mak.orig	2012-12-29 13:05:23.000000000 -0600
++++ build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_freebsd.mak	2012-12-29 13:06:37.000000000 -0600
+@@ -27,6 +27,7 @@
+ MOZILLA_PREFIX = swt-mozilla$(GCC_VERSION)
+ XULRUNNER_PREFIX = swt-xulrunner
+ XPCOMINIT_PREFIX = swt-xpcominit
++WEBKIT_PREFIX = swt-webkit
+ GLX_PREFIX = swt-glx
+ 
+ SWT_LIB = lib$(SWT_PREFIX)-$(WS_PREFIX)-$(SWT_VERSION).so
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Greg Lewis freebsd_committer 2013-03-03 02:51:53 UTC
State Changed
From-To: open->closed

Committed. Thanks!