Bug 175064 - editors/libreoffice fails to compile
Summary: editors/libreoffice fails to compile
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-06 16:20 UTC by O. Hartmann
Modified: 2014-08-26 05:53 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2013-01-06 16:20:00 UTC
The port editors/libreoffice is broken on both FreeBSD 10.0 and 9.1. It
doesn't compile with the base system's compiler on FreeBSD 10.0 (its
clang 3.2), nor does it compile with the port's lang/gcc47.

On FreeBSD 9.1-STABLE the same situation, clang 3.1 (base system compiler)
as well as  gcc46 are not willing to compile the port.

On FreeBSD 10.0-CURRENT r245075 with most recent lang/gcc47 installed and
with clang 3.2 from the base system, the following error occurs while compiling.

The issue is serious, since an installed LibreOffice 3.5.7 quits while
starting with a SIGBUS error since LLVM/CLANG 3.2 had been introduced
to FreeBSD 10.0-CURRENT and something triggers the same on most recent
freeBSD 9.1-STABLE.


OK (3)
Entering /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/sal/qa/ByteSequence

Compiling: sal/unxfbsd.pro/misc/rtl_ByteSequence_version.c
Compiling: sal/qa/ByteSequence/ByteSequence.cxx
Making:    qa_osl_condition.lib
Making:    libosl_Condition.so
----------------------------------------------------------
: &&     LD_LIBRARY_PATH=/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/sal/unxfbsd.pro/lib:/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/solver/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}   ../../../unxfbsd.pro/bin/cppunittester ../../../unxfbsd.pro/lib/libosl_Condition.so
- start unit test #1 on library ../../../unxfbsd.pro/lib/libosl_Condition.so
----------------------------------------------------------
Making:    qa_ByteSequence.lib
Making:    librtl_ByteSequence.so
----------------------------------------------------------
: &&     LD_LIBRARY_PATH=/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/sal/unxfbsd.pro/lib:/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/solver/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}   ../../unxfbsd.pro/bin/cppunittester ../../unxfbsd.pro/lib/librtl_ByteSequence.so
- start unit test #1 on library ../../unxfbsd.pro/lib/librtl_ByteSequence.so
----------------------------------------------------------
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct null not valid
/usr/local/bin/bash: line 1: 46381 Abort trap              (core dumped) LD_LIBRARY_PATH=/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/sal/unxfbsd.pro/lib:/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/solver/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}} ../../unxfbsd.pro/bin/cppunittester ../../unxfbsd.pro/lib/librtl_ByteSequence.so
dmake:  Error code 134, while making 'test1'
OK (10)

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/sal/qa/ByteSequence

 it seems that the error is inside 'sal', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2
source ./Env.Host.sh
cd sal
rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/sal/unxfbsd.pro # optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.

===>>> make failed for editors/libreoffice
===>>> Aborting update

===>>> Update for editors/libreoffice failed
===>>> Aborting update

Terminated

===>>> You can restart from the point of failure with this command line:
       portmaster <flags> editors/libreoffice

How-To-Repeat: Try to rebuild LibreOffice on FreeBSD 10 and 9.1
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-01-07 03:58:16 UTC
Responsible Changed
From-To: freebsd-bugs->openoffice

ports PR.
Comment 2 Baptiste Daroussin freebsd_committer 2013-01-07 07:53:27 UTC
Responsible Changed
From-To: openoffice->freebsd-office

Over to maintainer.
Comment 3 Boris Samorodov 2013-01-07 08:44:21 UTC
Libreoffice builds fine for me if libgcc is build by gcc.
If libgcc is build by clang (3.2-RELEASE) then cppunittester
segfaults (check /var/log/messages).

The system:
-----
% uname -a
FreeBSD BB051.wart.ru 10.0-CURRENT FreeBSD 10.0-CURRENT #0 r245047: Sat
Jan  5 03:19:00 SAMT 2013
bsam@BB051.wart.ru:/usr/obj/usr/src/sys/BB64X  amd64
% clang -v
FreeBSD clang version 3.2 (tags/RELEASE_32/final 170710) 20121221
Target: x86_64-unknown-freebsd10.0
Thread model: posix
-----

-- 
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 4 Boris Samorodov 2013-01-08 15:31:05 UTC
Dimitry Andric provided a patch to fix a clang at FreeBSD-amd64
(at freebsd-current@). The patch fixed libreoffice building for
me.

-- 
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2013-03-10 02:05:41 UTC
Responsible Changed
From-To: freebsd-office->office

Canonicalize assignment.
Comment 6 Baptiste Daroussin freebsd_committer 2014-08-26 05:53:01 UTC
This has been fixed in the meantime