Bug 175076 - x11/xorg-apps not installing apps
Summary: x11/xorg-apps not installing apps
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-06 21:10 UTC by Harry Matthiesen Jensen
Modified: 2013-01-07 13:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harry Matthiesen Jensen 2013-01-06 21:10:00 UTC
Several apps missing, for example xinit, xcalc, startx is some of the "first use" I discovered, all part of the port xorg-apps Makefile revision 309972

Fix: 

Tried with Makefile revision 300897, and it is actually working.
How-To-Repeat: Tried deinstall and then install, did not fix.
Comment 1 vsjcfm 2013-01-06 21:19:41 UTC
Just run "make config" and select what you need.
Comment 2 Edwin Groothuis freebsd_committer 2013-01-07 03:42:50 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-x11

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 dfilter service freebsd_committer 2013-01-07 13:14:53 UTC
Author: kwm
Date: Mon Jan  7 13:14:45 2013
New Revision: 310043
URL: http://svnweb.freebsd.org/changeset/ports/310043

Log:
  Fix run_depend to actualy include apps
  
  PR:		ports/175076
  Submitted by:	Harry Matthiesen Jensen <hmj@elgert.dk>

Modified:
  head/x11/xorg-apps/Makefile

Modified: head/x11/xorg-apps/Makefile
==============================================================================
--- head/x11/xorg-apps/Makefile	Mon Jan  7 12:33:59 2013	(r310042)
+++ head/x11/xorg-apps/Makefile	Mon Jan  7 13:14:45 2013	(r310043)
@@ -38,7 +38,7 @@ ${comp:C/:.*//:C/.*\///:U}_DESC=	Install
 .include <bsd.port.options.mk>
 
 .for comp in ${COMPONENTS}
-. if ! ${PORT_OPTIONS:M${comp:C/:.*//:C/.*\///:U}}
+. if ${PORT_OPTIONS:M${comp:C/:.*//:C/.*\///:U}}
 .  if ${comp:M:}==""
 port=${comp}
 check=${comp:C/.*\///} # doesn't work
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Koop Mast freebsd_committer 2013-01-07 13:14:59 UTC
State Changed
From-To: open->closed

Fix committed, thanks for reporting!