Bug 175394 - [termcap] [patch] Suggested addition to termcap database
Summary: [termcap] [patch] Suggested addition to termcap database
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: Bryan Drewery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-18 03:20 UTC by Scott Robison
Modified: 2018-05-28 19:45 UTC (History)
1 user (show)

See Also:


Attachments
termcap diff for putty-256color (537 bytes, patch)
2016-08-13 22:28 UTC, adam.twardowski
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Robison 2013-01-18 03:20:00 UTC
I hope I got the class right, and this is not a bug so much as a request for enhancement.

The termcap database includes a definition for PuTTY that looks like this:

putty|vt220-color|vt220-co|vt220 emulator with ANSI colors:\
        :pa#64:Co#8:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m\E[m:tc=vt220:

This is good and works nicely, but does not support the full 256 color palette that PuTTY supports.

Fix: 

I've added the following two lines to my termcap:

putty-256color:\
        :pa#32767:Co#256:tc=putty:

It seems to work acceptably. Ultimately of course, I don't care if my suggestion is the official definition, I'd just like one that works. :^)

Thanks!
How-To-Repeat: Not really a problem. Just a suggestion for a new termcap entry.
Comment 1 Bryan Drewery freebsd_committer 2014-02-19 01:32:39 UTC
Responsible Changed
From-To: freebsd-bugs->bdrewery

I'll take it.
Comment 2 adam.twardowski 2016-08-13 22:28:19 UTC
Created attachment 173642 [details]
termcap diff for putty-256color

Simple termcap update to allow 256 colors in putty.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:45:10 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.