Bug 175711 - When the server has more than 3 days, rising interrupt (serving Pppoe.) Traffic and pppoe session has not changed.
Summary: When the server has more than 3 days, rising interrupt (serving Pppoe.) Traff...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-30 20:10 UTC by Artem Goncharenko
Modified: 2018-05-20 23:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Goncharenko 2013-01-30 20:10:00 UTC
Good afternoon. I'm using freebsd + mpd5.6 for router. PPPoE client for 1500-2000. On the server, network cards are

igb0@pci0:10:0:0:	class=0x020000 card=0xa03c8086 chip=0x10c98086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82576 Gigabit Network Connection'
    class      = network
    subclass   = ethernet
igb1@pci0:10:0:1:	class=0x020000 card=0xa03c8086 chip=0x10c98086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82576 Gigabit Network Connection'
    class      = network
    subclass   = ethernet

bge0@pci0:3:4:0:	class=0x020000 card=0x703e103c chip=0x167814e4 rev=0xa3 hdr=0x00
    vendor     = 'Broadcom Corporation'
    device     = 'NetXtreme BCM5715 Gigabit Ethernet'
    class      = network
    subclass   = ethernet
bge1@pci0:3:4:1:	class=0x020000 card=0x703e103c chip=0x167814e4 rev=0xa3 hdr=0x00
    vendor     = 'Broadcom Corporation'
    device     = 'NetXtreme BCM5715 Gigabit Ethernet'
    class      = network
    subclass   = ethernet

igb0 + igb1 = lagg0, bge0 + bge1 = lagg1. On lagg1 100 vlan, hears all, mpd (PPPoE).
Queues nailed to each core. igb0 = cpu0 igb1 = cpu1 bge0 = cpu2 bge1 = cpu3. Next problem. When the server is live one day, the same interrupt.
Uptime one day
CPU 0:  3.2% user,  0.0% nice,  1.3% system, 25.0% interrupt, 70.5% idle
CPU 1:  1.3% user,  0.0% nice,  0.6% system, 30.8% interrupt, 67.3% idle
CPU 2:  1.3% user,  0.0% nice,  1% system,  35.5% interrupt, 62.2% idle
CPU 3:  1.9% user,  0.0% nice,  1% system,  40.0% interrupt, 57.1% idle

 When uptime > 3 days interrupt bge0 and bge1 begin to grow. Traffic is not changed and pps too. 1500-1800 the number of clients

Server uptime 9 days

last pid:  7979;  load averages:  1.05,  1.16,  1.29                                             up 9+13:35:15  23:42:36
152 processes: 5 running, 118 sleeping, 29 waiting
CPU 0:  4.9% user,  0.0% nice,  1.2% system, 14.8% interrupt, 79.0% idle
CPU 1:  1.2% user,  0.0% nice,  8.6% system,  7.4% interrupt, 82.7% idle
CPU 2:  1.2% user,  0.0% nice,  0.0% system, 49.4% interrupt, 49.4% idle
CPU 3:  0.0% user,  0.0% nice,  2.5% system, 38.3% interrupt, 59.3% idle
Mem: 62M Active, 462M Inact, 759M Wired, 622M Buf, 4645M Free
Swap: 4096M Total, 4096M Free

  PID USERNAME   PRI NICE   SIZE    RES STATE   C   TIME   WCPU COMMAND
   11 root       155 ki31     0K    64K CPU0    0 190.9H 94.38% idle{idle: cpu0}
   11 root       155 ki31     0K    64K RUN     1 192.5H 91.16% idle{idle: cpu1}
   11 root       155 ki31     0K    64K CPU3    3 140.1H 65.67% idle{idle: cpu3}
   11 root       155 ki31     0K    64K CPU2    2 144.4H 56.49% idle{idle: cpu2}
   12 root       -92    -     0K   464K WAIT    2  82.5H 45.26% intr{irq266: bge0}
   12 root       -92    -     0K   464K WAIT    3  86.1H 33.89% intr{irq267: bge1}
   12 root       -92    -     0K   464K WAIT    0 533:30  4.30% intr{irq256: igb0:que}
   12 root       -92    -     0K   464K WAIT    0 459:38  2.20% intr{irq257: igb0:que}
   12 root       -92    -     0K   464K WAIT    1 494:31  1.86% intr{irq264: igb1:que}
   12 root       -92    -     0K   464K WAIT    0 503:23  1.76% intr{irq259: igb0:que}
   12 root       -92    -     0K   464K WAIT    0 493:21  1.46% intr{irq258: igb0:que}
   12 root       -92    -     0K   464K WAIT    1 484:58  1.37% intr{irq263: igb1:que}
10520 root        21    0 37596K 10164K select  0 493:54  1.27% snmpd
   12 root       -92    -     0K   464K WAIT    1 456:25  1.27% intr{irq262: igb1:que}
   12 root       -92    -     0K   464K WAIT    1 450:34  0.78% intr{irq261: igb1:que}
99079 root        22    2   128M 62820K select  1  17:52  0.29% mpd5{mpd5}
 7978 nagios      25    0 20472K  1728K pause   1   0:00  0.00% netstat



pppoe2# procstat -at | grep bge
   12 100069 intr             irq266: bge0       2    8 wait    -         
   12 100070 intr             irq267: bge1       3    8 run     -         


pppoe2# procstat -at | grep ": igb"
   12 100032 intr             irq256: igb0:que   0    8 wait    -         
   12 100034 intr             irq257: igb0:que   0    8 wait    -         
   12 100036 intr             irq258: igb0:que   0    8 wait    -         
   12 100038 intr             irq259: igb0:que   0    8 wait    -         
   12 100040 intr             irq260: igb0:lin   1    8 wait    -         
   12 100041 intr             irq261: igb1:que   1    8 wait    -         
   12 100043 intr             irq262: igb1:que   1    8 wait    -         
   12 100045 intr             irq263: igb1:que   1    8 wait    -         
   12 100047 intr             irq264: igb1:que   1    8 wait    -         
   12 100049 intr             irq265: igb1:lin   3    8 wait    -         


pppoe2# ifconfig lagg0
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=401bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO>
	ether 90:e2:ba:00:a7:7a
	inet 172.30.0.2 netmask 0xffff0000 broadcast 172.30.255.255
	media: Ethernet autoselect
	status: active
	laggproto lacp
	laggport: igb1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
	laggport: igb0 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>


lagg1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8009b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,LINKSTATE>
	ether 10:1f:74:3b:eb:ec
	media: Ethernet autoselect
	status: active
	laggproto lacp
	laggport: bge1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
	laggport: bge0 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>

lagg1 and 100 vlan's


MPD5.6 Listen 100 vlan for PPPoE.

What other parameters of the system to send?

How-To-Repeat: When the server has more than 3 days, begins to rise interrupt. After reboot interrupt again smooth and the server can produce more than 1100 Mbps at 2000 clients. Why can grow interrupt, if the traffic is not changed and the number of pppoe sessions too. In my problem only helps reboot.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2018-05-20 23:50:17 UTC
For bugs matching the following conditions:
- Status == In Progress
- Assignee == "bugs@FreeBSD.org"
- Last Modified Year <= 2017

Do
- Set Status to "Open"