Bug 175960 - [PATCH] graphics/leptonica: update to 1.69
Summary: [PATCH] graphics/leptonica: update to 1.69
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Brendan Fabeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 16:20 UTC by Brendan Fabeny
Modified: 2013-03-06 00:40 UTC (History)
0 users

See Also:


Attachments
file.diff (3.99 KB, patch)
2013-02-08 16:20 UTC, Brendan Fabeny
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brendan Fabeny freebsd_committer 2013-02-08 16:20:00 UTC
update to 1.69; add a note about optional dependencies when using gplot; run non-interactive tests on tinderboxes and the build cluster; trim header.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-02-08 16:20:07 UTC
Maintainer of graphics/leptonica,

Please note that PR ports/175960 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/175960

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2013-02-08 16:20:08 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Brendan Fabeny freebsd_committer 2013-02-15 18:55:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bf

I'll take it.
Comment 4 dfilter service freebsd_committer 2013-03-06 00:30:52 UTC
Author: bf
Date: Wed Mar  6 00:30:39 2013
New Revision: 313487
URL: http://svnweb.freebsd.org/changeset/ports/313487

Log:
  update to 1.69 and adjust dependent ports
  
  PR:		175960
  Approved by:	maintainer timeout (25 days)

Added:
  head/graphics/leptonica/pkg-message   (contents, props changed)
Modified:
  head/graphics/leptonica/Makefile   (contents, props changed)
  head/graphics/leptonica/distinfo   (contents, props changed)
  head/graphics/leptonica/pkg-plist   (contents, props changed)
  head/graphics/tesseract/Makefile

Modified: head/graphics/leptonica/Makefile
==============================================================================
--- head/graphics/leptonica/Makefile	Wed Mar  6 00:28:55 2013	(r313486)
+++ head/graphics/leptonica/Makefile	Wed Mar  6 00:30:39 2013	(r313487)
@@ -1,24 +1,19 @@
-# New ports collection makefile for:	leptonlib
-# Date created:		2009-05-20
-# Whom:			Hiroto Kagotani <hiroto.kagotani@gmail.com>
-#
+# Created by: Hiroto Kagotani <hiroto.kagotani@gmail.com>
 # $FreeBSD$
-#
 
 PORTNAME=	leptonica
-PORTVERSION=	1.68
-PORTREVISION=	1
+PORTVERSION=	1.69
 CATEGORIES=	graphics
 MASTER_SITES=	GOOGLE_CODE
 
 MAINTAINER=	hiroto.kagotani@gmail.com
 COMMENT=	C library for efficient image processing and image analysis operations
 
-LIB_DEPENDS=	gif.5:${PORTSDIR}/graphics/giflib \
-		jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS=	gif:${PORTSDIR}/graphics/giflib \
+		jpeg:${PORTSDIR}/graphics/jpeg \
 		png15:${PORTSDIR}/graphics/png \
-		tiff.4:${PORTSDIR}/graphics/tiff \
-		webp.2:${PORTSDIR}/graphics/webp
+		tiff:${PORTSDIR}/graphics/tiff \
+		webp:${PORTSDIR}/graphics/webp
 
 CONFLICTS=	leptonlib-[0-9]*
 
@@ -28,15 +23,26 @@ USE_LDCONFIG=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
 
+.include <bsd.port.pre.mk>
+
+TESTS?=	generate compare
+.if defined(MAINTAINER_MODE) || defined(PACKAGE_BUILDING)
+BUILD_DEPENDS+=	${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+.endif
+#the display portion of the regression tests is interactive,
+#and requires the use of xv, xli or xzgv as an image viewer
 .if defined(MAINTAINER_MODE) && !defined(BATCH)
+TESTS+=	display
+.endif
+
 check regression-test test: build
-#"display" requires the installation of graphics/xzgv
-.for c in generate compare display
-	@${SETENV} \
+.for c in ${TESTS}
+	@cd ${WRKSRC}/prog; ${SETENV} \
 	LD_LIBRARY_PATH="${WRKSRC}/src/.libs:${LOCALBASE}/lib" \
-	PATH="${PATH}:${WRKSRC}/prog" \
 	${WRKSRC}/prog/alltests_reg ${c}
 .endfor
 
-.endif
-.include <bsd.port.mk>
+post-install:
+	${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>

Modified: head/graphics/leptonica/distinfo
==============================================================================
--- head/graphics/leptonica/distinfo	Wed Mar  6 00:28:55 2013	(r313486)
+++ head/graphics/leptonica/distinfo	Wed Mar  6 00:30:39 2013	(r313487)
@@ -1,2 +1,2 @@
-SHA256 (leptonica-1.68.tar.gz) = acefb6c50db2913f117afdbb19a549f7409cf8fa5d9a435692cb10ff89a81f8f
-SIZE (leptonica-1.68.tar.gz) = 6695020
+SHA256 (leptonica-1.69.tar.gz) = 178021f2bff504cc0e30bd91a0347a82bf726eca2778b68db4b44aaee3020b11
+SIZE (leptonica-1.69.tar.gz) = 7618131

Added: head/graphics/leptonica/pkg-message
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/graphics/leptonica/pkg-message	Wed Mar  6 00:30:39 2013	(r313487)
@@ -0,0 +1,2 @@
+To use gplot (the optional programmatic interface to gnuplot),
+the math/gnuplot port must be installed.

Modified: head/graphics/leptonica/pkg-plist
==============================================================================
--- head/graphics/leptonica/pkg-plist	Wed Mar  6 00:28:55 2013	(r313486)
+++ head/graphics/leptonica/pkg-plist	Wed Mar  6 00:30:39 2013	(r313487)
@@ -2,7 +2,7 @@ bin/adaptmaptest
 bin/adaptnorm_reg
 bin/affine_reg
 bin/alltests_reg
-bin/alphaclean_reg
+bin/alphaops_reg
 bin/alphaxform_reg
 bin/arithtest
 bin/barcodetest
@@ -26,12 +26,14 @@ bin/cctest1
 bin/ccthin1_reg
 bin/ccthin2_reg
 bin/cmapquant_reg
+bin/coloring_reg
 bin/colormask_reg
 bin/colormorphtest
 bin/colorquant_reg
 bin/colorseg_reg
 bin/colorsegtest
 bin/colorspacetest
+bin/compare_reg
 bin/comparepages
 bin/comparetest
 bin/compfilter_reg
@@ -50,10 +52,13 @@ bin/convolvetest
 bin/cornertest
 bin/croptext
 bin/dewarp_reg
-bin/dewarptest
+bin/dewarptest1
+bin/dewarptest2
+bin/dewarptest3
 bin/digitprep1
 bin/distance_reg
 bin/dithertest
+bin/dna_reg
 bin/dwalineargen
 bin/dwamorph1_reg
 bin/dwamorph2_reg
@@ -76,6 +81,7 @@ bin/flipselgen
 bin/fmorphauto_reg
 bin/fmorphautogen
 bin/fpix_reg
+bin/fpixcontours
 bin/gammatest
 bin/genfonts
 bin/gifio_reg
@@ -163,7 +169,6 @@ bin/rotatefastalt
 bin/rotateorth_reg
 bin/rotateorthtest1
 bin/rotatetest1
-bin/rotatetest2
 bin/runlengthtest
 bin/scale_reg
 bin/scaleandtile
@@ -218,7 +223,6 @@ include/leptonica/gplot.h
 include/leptonica/heap.h
 include/leptonica/imageio.h
 include/leptonica/jbclass.h
-include/leptonica/leptprotos.h
 include/leptonica/leptwin.h
 include/leptonica/list.h
 include/leptonica/morph.h
@@ -233,5 +237,5 @@ include/leptonica/watershed.h
 lib/liblept.a
 lib/liblept.la
 lib/liblept.so
-lib/liblept.so.2
+lib/liblept.so.3
 @dirrm include/leptonica

Modified: head/graphics/tesseract/Makefile
==============================================================================
--- head/graphics/tesseract/Makefile	Wed Mar  6 00:28:55 2013	(r313486)
+++ head/graphics/tesseract/Makefile	Wed Mar  6 00:30:39 2013	(r313487)
@@ -1,12 +1,9 @@
-# New ports collection makefile for:	tesseract
-# Date created:		18 July 2007
-# Whom:			Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	tesseract
 PORTVERSION=	3.02.02
+PORTREVISION=	1
 CATEGORIES=	graphics
 MASTER_SITES=	${MASTER_SITE_GOOGLE_CODE}
 DISTFILES=	tesseract-ocr-${PORTVERSION}${EXTRACT_SUFX}
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Brendan Fabeny freebsd_committer 2013-03-06 00:33:45 UTC
State Changed
From-To: feedback->closed

Committed, with minor changes. Thanks!