Bug 176073 - Update from 9.0-RELEASE-p3 to 9.1-RELEASE-p0 "breaks" network interface [regression]
Summary: Update from 9.0-RELEASE-p3 to 9.1-RELEASE-p0 "breaks" network interface [regr...
Status: Closed Not Accepted
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: Eric Joyner
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2013-02-12 16:20 UTC by yvan+freebsd
Modified: 2017-08-24 21:56 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yvan+freebsd 2013-02-12 16:20:00 UTC
I discovered this problem while performing a routine binary upgrade from 9.0-RELEASE-p3 to 9.1-RELEASE-p0. I checked UPDATING and there were no warnings about known issues relating to my NIC.

freebsd-update -r 9.1-RELEASE upgrade
freebsd-update install (reboot)
freebsd-update install

After the reboot my primary network interface em0 reported "no carrier". To make a long story short, the interface previously known as em1 was now em0 and the interface previously known as em0 was no longer enumerated.

Scrolling back through the console messages showed:

em0: Setup of Shared code failed
device_attach: em0 attach returned 6

pciconf -vl showed that the interface previously enumeraed as em0 was now none0

I have read about other similar issues by other people in the forums, but not necessarily with my NIC (Intel Pro/1000). I think the common denominator may be the chipset. As this is a leased server in a datacentre I don't have much to go on except that it is a SuperMicro PDSBM which appears to use the Intel 946GZ
(Lakeport-G). Perhaps something to do with a pci-related driver has changed.

The following is the console log from the first boot after upgrading.

Feb  5 16:54:11 henry reboot: rebooted by yvan
Feb  5 16:54:11 henry syslogd: exiting on signal 15
Feb  5 16:55:37 henry syslogd: kernel boot file is /boot/kernel/kernel
Feb  5 16:55:37 henry kernel: Copyright (c) 1992-2012 The FreeBSD Project.
Feb  5 16:55:37 henry kernel: Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
Feb  5 16:55:37 henry kernel: The Regents of the University of California. All rights reserved.
Feb  5 16:55:37 henry kernel: FreeBSD is a registered trademark of The FreeBSD Foundation.
Feb  5 16:55:37 henry kernel: FreeBSD 9.1-RELEASE #0 r243826: Tue Dec  4 06:55:39 UTC 2012
Feb  5 16:55:37 henry kernel: root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Feb  5 16:55:37 henry kernel: CPU: Intel(R) Celeron(R) CPU        E1400  @ 2.00GHz (1995.05-MHz 686-class CPU)
Feb  5 16:55:37 henry kernel: Origin = "GenuineIntel"  Id = 0x6fd  Family = 6  Model = f  Stepping = 13
Feb  5 16:55:37 henry kernel: Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
Feb  5 16:55:37 henry kernel: Features2=0xe39d<SSE3,DTES64,MON,DS_CPL,EST,TM2,SSSE3,CX16,xTPR,PDCM>
Feb  5 16:55:37 henry kernel: AMD Features=0x20100000<NX,LM>
Feb  5 16:55:37 henry kernel: AMD Features2=0x1<LAHF>
Feb  5 16:55:37 henry kernel: TSC: P-state invariant, performance statistics
Feb  5 16:55:37 henry kernel: real memory  = 4294967296 (4096 MB)
Feb  5 16:55:37 henry kernel: avail memory = 3131387904 (2986 MB)
Feb  5 16:55:37 henry kernel: Event timer "LAPIC" quality 400
Feb  5 16:55:37 henry kernel: ACPI APIC Table: <PTLTD    APIC  >
Feb  5 16:55:37 henry kernel: FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
Feb  5 16:55:37 henry kernel: FreeBSD/SMP: 1 package(s) x 2 core(s)
Feb  5 16:55:37 henry kernel: cpu0 (BSP): APIC ID:  0
Feb  5 16:55:37 henry kernel: cpu1 (AP): APIC ID:  1
Feb  5 16:55:37 henry kernel: ioapic0 <Version 2.0> irqs 0-23 on motherboard
Feb  5 16:55:37 henry kernel: kbd1 at kbdmux0
Feb  5 16:55:37 henry kernel: ctl: CAM Target Layer loaded
Feb  5 16:55:37 henry kernel: acpi0: <PTLTD   RSDT> on motherboard
Feb  5 16:55:37 henry kernel: acpi0: Power Button (fixed)
Feb  5 16:55:37 henry kernel: cpu0: <ACPI CPU> on acpi0
Feb  5 16:55:37 henry kernel: cpu1: <ACPI CPU> on acpi0
Feb  5 16:55:37 henry kernel: atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Feb  5 16:55:37 henry kernel: Event timer "RTC" frequency 32768 Hz quality 0
Feb  5 16:55:37 henry kernel: attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
Feb  5 16:55:37 henry kernel: Timecounter "i8254" frequency 1193182 Hz quality 0
Feb  5 16:55:37 henry kernel: Event timer "i8254" frequency 1193182 Hz quality 100
Feb  5 16:55:37 henry kernel: Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
Feb  5 16:55:37 henry kernel: acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
Feb  5 16:55:37 henry kernel: pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
Feb  5 16:55:37 henry kernel: pci0: <ACPI PCI bus> on pcib0
Feb  5 16:55:37 henry kernel: vgapci0: <VGA-compatible display> port 0x30c0-0x30c7 mem 0xd0000000-0xd00fffff,0xc0000000-0xcfffffff irq 16 at device 2.0 on pci0
Feb  5 16:55:37 henry kernel: agp0: <Intel 946GZ SVGA controller> on vgapci0
Feb  5 16:55:37 henry kernel: agp0: aperture size is 256M, detected 7676k stolen memory
Feb  5 16:55:37 henry kernel: pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
Feb  5 16:55:37 henry kernel: pci1: <ACPI PCI bus> on pcib1
Feb  5 16:55:37 henry kernel: pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.4 on pci0
Feb  5 16:55:37 henry kernel: pcib2: failed to allocate initial memory window: 0xd0100000-0xd01fffff
Feb  5 16:55:37 henry kernel: pci2: <ACPI PCI bus> on pcib2
Feb  5 16:55:37 henry kernel: em0: <Intel(R) PRO/1000 Network Connection 7.3.2> port 0x4000-0x401f irq 16 at device 0.0 on pci2
Feb  5 16:55:37 henry kernel: em0: Using an MSI interrupt
Feb  5 16:55:37 henry kernel: em0: Setup of Shared code failed
Feb  5 16:55:37 henry kernel: device_attach: em0 attach returned 6
Feb  5 16:55:37 henry kernel: pcib3: <ACPI PCI-PCI bridge> irq 17 at device 28.5 on pci0
Feb  5 16:55:37 henry kernel: pcib3: failed to allocate initial memory window: 0xd0200000-0xd02fffff
Feb  5 16:55:37 henry kernel: pci3: <ACPI PCI bus> on pcib3
Feb  5 16:55:37 henry kernel: em0: <Intel(R) PRO/1000 Network Connection 7.3.2> port 0x5000-0x501f irq 17 at device 0.0 on pci3
Feb  5 16:55:37 henry kernel: em0: Using an MSI interrupt
Feb  5 16:55:37 henry kernel: em0: Ethernet address: 00:30:48:b0:ce:29
Feb  5 16:55:37 henry kernel: uhci0: <Intel 82801G (ICH7) USB controller USB-A> port 0x3000-0x301f irq 16 at device 29.0 on pci0
Feb  5 16:55:37 henry kernel: usbus0 on uhci0
Feb  5 16:55:37 henry kernel: uhci1: <Intel 82801G (ICH7) USB controller USB-B> port 0x3020-0x303f irq 17 at device 29.1 on pci0
Feb  5 16:55:37 henry kernel: usbus1 on uhci1
Feb  5 16:55:37 henry kernel: uhci2: <Intel 82801G (ICH7) USB controller USB-C> port 0x3040-0x305f irq 18 at device 29.2 on pci0
Feb  5 16:55:37 henry kernel: usbus2 on uhci2
Feb  5 16:55:37 henry kernel: uhci3: <Intel 82801G (ICH7) USB controller USB-D> port 0x3060-0x307f irq 19 at device 29.3 on pci0
Feb  5 16:55:37 henry kernel: usbus3 on uhci3
Feb  5 16:55:37 henry kernel: ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xd0500000-0xd05003ff irq 16 at device 29.7 on pci0
Feb  5 16:55:37 henry kernel: usbus4: EHCI version 1.0
Feb  5 16:55:37 henry kernel: usbus4 on ehci0
Feb  5 16:55:37 henry kernel: pcib4: <ACPI PCI-PCI bridge> at device 30.0 on pci0
Feb  5 16:55:37 henry kernel: pci4: <ACPI PCI bus> on pcib4
Feb  5 16:55:37 henry kernel: isab0: <PCI-ISA bridge> at device 31.0 on pci0
Feb  5 16:55:37 henry kernel: isa0: <ISA bus> on isab0
Feb  5 16:55:37 henry kernel: atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x30a0-0x30af at device 31.1 on pci0
Feb  5 16:55:37 henry kernel: ata0: <ATA channel> at channel 0 on atapci0
Feb  5 16:55:37 henry kernel: ahci0: <Intel ICH7 AHCI SATA controller> port 0x30f0-0x30f7,0x30e4-0x30e7,0x30e8-0x30ef,0x30e0-0x30e3,0x30b0-0x30bf mem 0xd0500400-0xd05007ff irq$
Feb  5 16:55:37 henry kernel: ahci0: AHCI v1.10 with 4 3Gbps ports, Port Multiplier not supported
Feb  5 16:55:37 henry kernel: ahcich0: <AHCI channel> at channel 0 on ahci0
Feb  5 16:55:37 henry kernel: ahcich1: <AHCI channel> at channel 1 on ahci0
Feb  5 16:55:37 henry kernel: ahcich2: <AHCI channel> at channel 2 on ahci0
Feb  5 16:55:37 henry kernel: ahcich3: <AHCI channel> at channel 3 on ahci0
Feb  5 16:55:37 henry kernel: pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
Feb  5 16:55:37 henry kernel: acpi_button0: <Power Button> on acpi0
Feb  5 16:55:37 henry kernel: atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
Feb  5 16:55:37 henry kernel: atkbd0: <AT Keyboard> irq 1 on atkbdc0
Feb  5 16:55:37 henry kernel: kbd0 at atkbd0
Feb  5 16:55:37 henry kernel: atkbd0: [GIANT-LOCKED]
Feb  5 16:55:37 henry kernel: uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
Feb  5 16:55:37 henry kernel: uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
Feb  5 16:55:37 henry kernel: pmtimer0 on isa0
Feb  5 16:55:37 henry kernel: orm0: <ISA Option ROMs> at iomem 0xc0000-0xcafff,0xcb000-0xcbfff pnpid ORM0000 on isa0
Feb  5 16:55:37 henry kernel: sc0: <System console> at flags 0x100 on isa0
Feb  5 16:55:37 henry kernel: sc0: VGA <16 virtual consoles, flags=0x300>
Feb  5 16:55:37 henry kernel: vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Feb  5 16:55:37 henry kernel: ppc0: parallel port not found.
Feb  5 16:55:37 henry kernel: est0: <Enhanced SpeedStep Frequency Control> on cpu0
Feb  5 16:55:37 henry kernel: p4tcc0: <CPU Frequency Thermal Control> on cpu0
Feb  5 16:55:37 henry kernel: est1: <Enhanced SpeedStep Frequency Control> on cpu1
Feb  5 16:55:37 henry kernel: p4tcc1: <CPU Frequency Thermal Control> on cpu1
Feb  5 16:55:37 henry kernel: Timecounters tick every 1.000 msec
Feb  5 16:55:37 henry kernel: usbus0: 12Mbps Full Speed USB v1.0
Feb  5 16:55:37 henry kernel: usbus1: 12Mbps Full Speed USB v1.0
Feb  5 16:55:37 henry kernel: usbus2: 12Mbps Full Speed USB v1.0
Feb  5 16:55:37 henry kernel: usbus3: 12Mbps Full Speed USB v1.0
Feb  5 16:55:37 henry kernel: usbus4: 480Mbps High Speed USB v2.0
Feb  5 16:55:37 henry kernel: ugen0.1: <Intel> at usbus0
Feb  5 16:55:37 henry kernel: ata0: DMA limited to UDMA33, controller found non-ATA66 cable
Feb  5 16:55:37 henry kernel: uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
Feb  5 16:55:37 henry kernel: ugen1.1: <Intel> at usbus1
Feb  5 16:55:37 henry kernel: uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
Feb  5 16:55:37 henry kernel: ugen2.1: <Intel> at usbus2
Feb  5 16:55:37 henry kernel: uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
Feb  5 16:55:37 henry kernel: ugen3.1: <Intel> at usbus3
Feb  5 16:55:37 henry kernel: uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
Feb  5 16:55:37 henry kernel: ugen4.1: <Intel> at usbus4
Feb  5 16:55:37 henry kernel: uhub4: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus4
Feb  5 16:55:37 henry kernel: uhub0: 2 ports with 2 removable, self powered
Feb  5 16:55:37 henry kernel: uhub1: 2 ports with 2 removable, self powered
Feb  5 16:55:37 henry kernel: uhub2: 2 ports with 2 removable, self powered
Feb  5 16:55:37 henry kernel: uhub3: 2 ports with 2 removable, self powered
Feb  5 16:55:37 henry kernel: uhub4: 8 ports with 8 removable, self powered
Feb  5 16:55:37 henry kernel: ada0 at ata0 bus 0 scbus0 target 0 lun 0
Feb  5 16:55:37 henry kernel: ada0: <WDC WD1600AAJB-56WRA0 58.01H58> ATA-8 device
Feb  5 16:55:37 henry kernel: ada0: 33.300MB/s transfers (UDMA2, PIO 8192bytes)
Feb  5 16:55:37 henry kernel: ada0: 152627MB (312581808 512 byte sectors: 16H 63S/T 16383C)
Feb  5 16:55:37 henry kernel: ada0: Previously was known as ad0
Feb  5 16:55:37 henry kernel: ada1 at ata0 bus 0 scbus0 target 1 lun 0
Feb  5 16:55:37 henry kernel: ada1: <WDC WD1600AAJB-00WRA0 58.01H58> ATA-8 device
Feb  5 16:55:37 henry kernel: ada1: 100.000MB/s transfers (UDMA5, PIO 8192bytes)
Feb  5 16:55:37 henry kernel: ada1: 152627MB (312581808 512 byte sectors: 16H 63S/T 16383C)
Feb  5 16:55:37 henry kernel: ada1: Previously was known as ad1
Feb  5 16:55:37 henry kernel: SMP: AP CPU #1 Launched!
Feb  5 16:55:37 henry kernel: Timecounter "TSC-low" frequency 15586297 Hz quality 1000
Feb  5 16:55:37 henry kernel: GEOM_MIRROR: Device mirror/gm0 launched (2/2).
Feb  5 16:55:37 henry kernel: GEOM_PART: integrity check failed (mirror/gm0, MBR)
Feb  5 16:55:37 henry kernel: GEOM: mirror/gm0s1: geometry does not match label (16h,63s != 255h,63s).
Feb  5 16:55:37 henry kernel: Trying to mount root from ufs:/dev/mirror/gm0s1a [rw]...
Feb  5 16:55:38 henry named[1106]: starting BIND 9.8.1-P1 -t /var/named -u bind
Feb  5 16:55:38 henry named[1106]: built with '--prefix=/usr' '--infodir=/usr/share/info' '--mandir=/usr/share/man' '--enable-threads' '--enable-getifaddrs' '--disable-linux-c$
Feb  5 16:55:38 henry named[1106]: command channel listening on 127.0.0.1#953
Feb  5 16:55:39 henry named[1106]: running
Feb  5 16:55:39 henry kernel: .
Feb  5 16:55:39 henry ntpd[1271]: ntpd 4.2.4p5-a (1)
Feb  5 16:55:40 henry root: /etc/rc: WARNING: /usr/local/etc/smartd.conf is not readable.
Feb  5 16:55:40 henry root: /etc/rc: WARNING: failed precmd routine for smartd
Feb  5 16:55:40 henry kernel: cannot start jail "tomato":
Feb  5 16:55:41 henry kernel: .
Feb  5 16:55:47 henry ntpd_initres[1709]: host name not found: 0.CA.pool.ntp.org
Feb  5 16:55:47 henry ntpd_initres[1709]: host name not found: 1.CA.pool.ntp.org
Feb  5 16:55:47 henry ntpd_initres[1709]: host name not found: 2.CA.pool.ntp.org
Feb  5 16:57:16 henry ntpd_initres[1709]: host name not found: 0.CA.pool.ntp.org
Feb  5 16:57:16 henry ntpd_initres[1709]: host name not found: 1.CA.pool.ntp.org
Feb  5 16:57:16 henry ntpd_initres[1709]: host name not found: 2.CA.pool.ntp.org
Feb  5 16:59:45 henry ntpd_initres[1709]: host name not found: 0.CA.pool.ntp.org
Feb  5 16:59:45 henry ntpd_initres[1709]: host name not found: 1.CA.pool.ntp.org
Feb  5 16:59:45 henry ntpd_initres[1709]: host name not found: 2.CA.pool.ntp.org

Fix: 

Only known workaround: "freebsd-update rollback" will successfully restore the old kernel.
How-To-Repeat: On a system with a SuperMicro PDSBM motherboard and a working and connected em0 interface, upgrade from 9.0-RELEASE-p3 to 9.1-RELEASE-p0.

After rebooting and loading the new kernel, em0 will report "no carrier" because it is actually em1. Only one network interface will be enumerated.
Comment 1 Remko Lodder freebsd_committer 2013-02-13 06:27:32 UTC
Responsible Changed
From-To: freebsd-i386->jfv

Hi Jack, 

This might be something for you to have a look at?
Comment 2 bmcnally 2013-03-12 16:51:55 UTC
I have a similar issue, discussed here:

http://forums.freebsd.org/showthread.php?t=37528

Both re0 and em0 fail to get set up after an upgrade from
9.0-RELEASE-p3 to 9.1-RELEASE. I'm not able to use 9.1 at this point
until I find a fix.

Below is my dmesg output:

===
Copyright (c) 1992-2012 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.1-RELEASE #0 r243825: Tue Dec  4 09:23:10 UTC 2012
    root@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC amd64
CPU: Intel(R) Atom(TM) CPU D510   @ 1.66GHz (1662.72-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x106ca  Family = 6  Model = 1c  Stepping = 10
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x40e31d<SSE3,DTES64,MON,DS_CPL,TM2,SSSE3,CX16,xTPR,PDCM,MOVBE>
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant, performance statistics
real memory  = 2147483648 (2048 MB)
avail memory = 2026500096 (1932 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table: <INTEL  MOPNV10J>
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s) x 2 HTT threads
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP/HT): APIC ID:  1
 cpu2 (AP): APIC ID:  2
 cpu3 (AP/HT): APIC ID:  3
ioapic0: Changing APIC ID to 8
ioapic0 <Version 2.0> irqs 0-23 on motherboard
lapic0: Forcing LINT1 to edge trigger
kbd1 at kbdmux0
ctl: CAM Target Layer loaded
acpi0: <INTEL MOPNV10J> on motherboard
acpi0: Power Button (fixed)
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71,0x74-0x77 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed03fff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 450
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
acpi_button0: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0x30c0-0x30c7 mem
0xe0300000-0xe037ffff,0xd0000000-0xdfffffff,0xe0200000-0xe02fffff irq
16 at device 2.0 on pci0
agp0: <Intel Pineview SVGA controller> on vgapci0
agp0: aperture size is 256M, detected 8188k stolen memory
hdac0: <Intel 82801G HDA Controller> mem 0xe0380000-0xe0383fff irq 22
at device 27.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pcib1: failed to allocate initial prefetch window: 0xe0000000-0xe00fffff
pci1: <ACPI PCI bus> on pcib1
re0: <RealTek 8168/8111 B/C/CP/D/DP/E/F PCIe Gigabit Ethernet> port
0x2000-0x20ff irq 16 at device 0.0 on pci1
re0: Using 1 MSI-X message
re0: Chip rev. 0x28000000
re0: MAC rev. 0x00000000
re0: PHY read failed
re0: attaching PHYs failed
device_attach: re0 attach returned 6
pcib2: <ACPI PCI-PCI bridge> at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 28.2 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 28.3 on pci0
pci4: <ACPI PCI bus> on pcib4
uhci0: <Intel 82801G (ICH7) USB controller USB-A> port 0x3080-0x309f
irq 23 at device 29.0 on pci0
uhci0: LegSup = 0x2f00
usbus0 on uhci0
uhci1: <Intel 82801G (ICH7) USB controller USB-B> port 0x3060-0x307f
irq 19 at device 29.1 on pci0
uhci1: LegSup = 0x2f00
usbus1 on uhci1
uhci2: <Intel 82801G (ICH7) USB controller USB-C> port 0x3040-0x305f
irq 18 at device 29.2 on pci0
uhci2: LegSup = 0x2f00
usbus2 on uhci2
uhci3: <Intel 82801G (ICH7) USB controller USB-D> port 0x3020-0x303f
irq 16 at device 29.3 on pci0
uhci3: LegSup = 0x2f00
usbus3 on uhci3
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem
0xe0384400-0xe03847ff irq 23 at device 29.7 on pci0
usbus4: EHCI version 1.0
usbus4 on ehci0
pcib5: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pcib5: failed to allocate initial memory window: 0xe0100000-0xe01fffff
pci5: <ACPI PCI bus> on pcib5
em0: <Intel(R) PRO/1000 Legacy Network Connection 1.0.4> port
0x1000-0x103f irq 21 at device 0.0 on pci5
em0: Setup of Shared code failed
device_attach: em0 attach returned 6
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 SATA300 controller> port
0x30b8-0x30bf,0x30cc-0x30cf,0x30b0-0x30b7,0x30c8-0x30cb,0x30a0-0x30af
mem 0xe0384000-0xe03843ff irq 19 at device 31.2 on pci0
ata2: <ATA channel> at channel 0 on atapci0
ata3: <ATA channel> at channel 1 on atapci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
ppc0: <Parallel port> port 0x378-0x37f irq 7 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
orm0: <ISA Option ROM> at iomem 0xce000-0xcefff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
p4tcc1: <CPU Frequency Thermal Control> on cpu1
p4tcc2: <CPU Frequency Thermal Control> on cpu2
p4tcc3: <CPU Frequency Thermal Control> on cpu3
ZFS NOTICE: Prefetch is disabled by default if less than 4GB of RAM is present;
            to enable, add "vfs.zfs.prefetch_disable=0" to /boot/loader.conf.
ZFS filesystem version 5
ZFS storage pool version 28
Timecounters tick every 1.000 msec
hdacc0: <Realtek ALC662 HDA CODEC> at cad 2 on hdac0
hdaa0: <Realtek ALC662 Audio Function Group> at nid 1 on hdacc0
pcm0: <Realtek ALC662 (Analog)> at nid 20 and 24,25,26 on hdaa0
pcm1: <Realtek ALC662 (Front Analog Headphones)> at nid 27 on hdaa0
pcm2: <Realtek ALC662 (Onboard Digital)> at nid 30 on hdaa0
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
usbus3: 12Mbps Full Speed USB v1.0
usbus4: 480Mbps High Speed USB v2.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <Intel> at usbus2
uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
ugen3.1: <Intel> at usbus3
uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
ugen4.1: <Intel> at usbus4
uhub4: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus4
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
ada0 at ata2 bus 0 scbus0 target 0 lun 0
ada0: <ST31000528AS CC38> ATA-8 SATA 2.x device
ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada0: 953869MB (1953525168 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4
ada1 at ata3 bus 0 scbus1 target 0 lun 0
ada1: <ST31000528AS CC38> ATA-8 SATA 2.x device
ada1: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada1: 953869MB (1953525168 512 byte sectors: 16H 63S/T 16383C)
ada1: Previously was known as ad6
lapic1: Forcing LINT1 to edge trigger
SMP: AP CPU #1 Launched!
lapic2: Forcing LINT1 to edge trigger
SMP: AP CPU #2 Launched!
lapic3: Forcing LINT1 to edge trigger
SMP: AP CPU #3 Launched!
Timecounter "TSC-low" frequency 12990011 Hz quality 1000
GEOM_MIRROR: Device mirror/swap launched (2/2).
Root mount waiting for: usbus4
uhub4: 8 ports with 8 removable, self powered
Trying to mount root from zfs:zroot []...
===
Comment 3 ruslanas 2013-08-19 16:48:47 UTC
> Aug 19 13:28:15 bsd newsyslog[1131]: logfile first created
> Aug 19 13:28:15 bsd syslogd: kernel boot file is /boot/kernel/kernel
> Aug 19 13:28:15 bsd kernel: Copyright (c) 1992-2012 The FreeBSD Project.
> Aug 19 13:28:15 bsd kernel: Copyright (c) 1979, 1980, 1983, 1986, 1988,
1989, 1991, 1992, 1993, 1994
> Aug 19 13:28:15 bsd kernel: The Regents of the University of California.
All rights reserved.
> Aug 19 13:28:15 bsd kernel: FreeBSD is a registered trademark of The
FreeBSD Foundation.
> Aug 19 13:28:15 bsd kernel: FreeBSD 9.1-RELEASE #0 r243825: Tue Dec  4
09:23:10 UTC 2012
> Aug 19 13:28:15 bsd kernel: root@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
amd64
> Aug 19 13:28:15 bsd kernel: CPU: AMD Athlon(tm) II X4 645 Processor
(3114.05-MHz K8-class CPU)
> Aug 19 13:28:15 bsd kernel: Origin = "AuthenticAMD"  Id = 0x100f53
 Family = 10  Model = 5  Stepping = 3
> Aug 19 13:28:15 bsd kernel:
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
> Aug 19 13:28:15 bsd kernel: Features2=0x802009<SSE3,MON,CX16,POPCNT>
> Aug 19 13:28:15 bsd kernel: AMD
Features=0xee500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM,3DNow!+,3DNow!>
> Aug 19 13:28:15 bsd kernel: AMD
Features2=0x837ff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,SKINIT,WDT,NodeId>
> Aug 19 13:28:15 bsd kernel: TSC: P-state invariant
> Aug 19 13:28:15 bsd kernel: real memory  = 17179869184 (16384 MB)
> Aug 19 13:28:15 bsd kernel: avail memory = 16529145856 (15763 MB)
> Aug 19 13:28:15 bsd kernel: Event timer "LAPIC" quality 400
> Aug 19 13:28:15 bsd kernel: ACPI APIC Table: <113011 APIC1510>
> Aug 19 13:28:15 bsd kernel: FreeBSD/SMP: Multiprocessor System Detected:
4 CPUs
> Aug 19 13:28:15 bsd kernel: FreeBSD/SMP: 1 package(s) x 4 core(s)
> Aug 19 13:28:15 bsd kernel: cpu0 (BSP): APIC ID:  0
> Aug 19 13:28:15 bsd kernel: cpu1 (AP): APIC ID:  1
> Aug 19 13:28:15 bsd kernel: cpu2 (AP): APIC ID:  2
> Aug 19 13:28:15 bsd kernel: cpu3 (AP): APIC ID:  3
> Aug 19 13:28:15 bsd kernel: ACPI Warning: Optional field Pm2ControlBlock
has zero address or length: 0x0000000000000000/0x1 (20110527/tbfadt-586)
> Aug 19 13:28:15 bsd kernel: ioapic0 <Version 2.1> irqs 0-23 on motherboard
> Aug 19 13:28:15 bsd kernel: kbd1 at kbdmux0
> Aug 19 13:28:15 bsd kernel: acpi0: <113011 XSDT1510> on motherboard
> Aug 19 13:28:15 bsd kernel: acpi0: Power Button (fixed)
> Aug 19 13:28:15 bsd kernel: acpi0: reservation of fee00000, 1000 (3)
failed
> Aug 19 13:28:15 bsd kernel: acpi0: reservation of ffb80000, 80000 (3)
failed
> Aug 19 13:28:15 bsd kernel: acpi0: reservation of fec10000, 20 (3) failed
> Aug 19 13:28:15 bsd kernel: acpi0: reservation of fed40000, 5000 (3)
failed
> Aug 19 13:28:15 bsd kernel: acpi0: reservation of 0, a0000 (3) failed
> Aug 19 13:28:15 bsd kernel: acpi0: reservation of 100000, dfe00000 (3)
failed
> Aug 19 13:28:15 bsd kernel: cpu0: <ACPI CPU> on acpi0
> Aug 19 13:28:15 bsd kernel: cpu1: <ACPI CPU> on acpi0
> Aug 19 13:28:15 bsd kernel: cpu2: <ACPI CPU> on acpi0
> Aug 19 13:28:15 bsd kernel: cpu3: <ACPI CPU> on acpi0
> Aug 19 13:28:15 bsd kernel: attimer0: <AT timer> port 0x40-0x43 irq 0 on
acpi0
> Aug 19 13:28:15 bsd kernel: Timecounter "i8254" frequency 1193182 Hz
quality 0
> Aug 19 13:28:15 bsd kernel: Event timer "i8254" frequency 1193182 Hz
quality 100
> Aug 19 13:28:15 bsd kernel: atrtc0: <AT realtime clock> port 0x70-0x71
irq 8 on acpi0
> Aug 19 13:28:15 bsd kernel: Event timer "RTC" frequency 32768 Hz quality 0
> Aug 19 13:28:15 bsd kernel: hpet0: <High Precision Event Timer> iomem
0xfed00000-0xfed003ff on acpi0
> Aug 19 13:28:15 bsd kernel: Timecounter "HPET" frequency 14318180 Hz
quality 950
> Aug 19 13:28:15 bsd kernel: Event timer "HPET" frequency 14318180 Hz
quality 450
> Aug 19 13:28:15 bsd kernel: Event timer "HPET1" frequency 14318180 Hz
quality 450
> Aug 19 13:28:15 bsd kernel: Event timer "HPET2" frequency 14318180 Hz
quality 450
> Aug 19 13:28:15 bsd kernel: Timecounter "ACPI-fast" frequency 3579545 Hz
quality 900
> Aug 19 13:28:15 bsd kernel: acpi_timer0: <32-bit timer at 3.579545MHz>
port 0x808-0x80b on acpi0
> Aug 19 13:28:15 bsd kernel: pcib0: <ACPI Host-PCI bridge> port
0xcf8-0xcff on acpi0
> Aug 19 13:28:15 bsd kernel: pci0: <ACPI PCI bus> on pcib0
> Aug 19 13:28:15 bsd kernel: pcib1: <ACPI PCI-PCI bridge> irq 16 at device
4.0 on pci0
> Aug 19 13:28:15 bsd kernel: pci1: <ACPI PCI bus> on pcib1
> Aug 19 13:28:15 bsd kernel: re0: <RealTek 8168/8111 B/C/CP/D/DP/E/F PCIe
Gigabit Ethernet> port 0xd800-0xd8ff mem
0xf6fff000-0xf6ffffff,0xf6ff8000-0xf6ffbfff irq 16 at device 0.0 on pci1
> Aug 19 13:28:15 bsd kernel: re0: Using 1 MSI-X message
> Aug 19 13:28:15 bsd kernel: re0: ASPM disabled
> Aug 19 13:28:15 bsd kernel: re0: Chip rev. 0x2c800000
> Aug 19 13:28:15 bsd kernel: re0: MAC rev. 0x00000000
> Aug 19 13:28:15 bsd kernel: miibus0: <MII bus> on re0
> Aug 19 13:28:15 bsd kernel: rgephy0: <RTL8169S/8110S/8211 1000BASE-T
media interface> PHY 1 on miibus0
> Aug 19 13:28:15 bsd kernel: rgephy0:  none, 10baseT, 10baseT-FDX,
10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT,
1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow,
1000baseT-FDX-flow-master, auto, auto-flow
> Aug 19 13:28:15 bsd kernel: re0: Ethernet address: c8:60:00:06:d8:be
> Aug 19 13:28:15 bsd kernel: pcib2: <ACPI PCI-PCI bridge> irq 17 at device
9.0 on pci0
> Aug 19 13:28:15 bsd kernel: pci2: <ACPI PCI bus> on pcib2
> Aug 19 13:28:15 bsd kernel: pci2: <network> at device 0.0 (no driver
attached)
> Aug 19 13:28:15 bsd kernel: ahci0: <ATI IXP700 AHCI SATA controller> port
0xc000-0xc007,0xb000-0xb003,0xa000-0xa007,0x9000-0x9003,0x8000-0x800f mem
0xf7efbc00-0xf7efbfff irq 22 at device 17.0 on pci0
> Aug 19 13:28:15 bsd kernel: ahci0: AHCI v1.10 with 6 3Gbps ports, Port
Multiplier supported
> Aug 19 13:28:15 bsd kernel: ahcich0: <AHCI channel> at channel 0 on ahci0
> Aug 19 13:28:15 bsd kernel: ahcich1: <AHCI channel> at channel 1 on ahci0
> Aug 19 13:28:15 bsd kernel: ahcich2: <AHCI channel> at channel 2 on ahci0
> Aug 19 13:28:15 bsd kernel: ahcich3: <AHCI channel> at channel 3 on ahci0
> Aug 19 13:28:15 bsd kernel: ahcich4: <AHCI channel> at channel 4 on ahci0
> Aug 19 13:28:15 bsd kernel: ahcich5: <AHCI channel> at channel 5 on ahci0
> Aug 19 13:28:15 bsd kernel: ohci0: <AMD SB7x0/SB8x0/SB9x0 USB controller>
mem 0xf7efa000-0xf7efafff irq 16 at device 18.0 on pci0
> Aug 19 13:28:15 bsd kernel: usbus0 on ohci0
> Aug 19 13:28:15 bsd kernel: ohci1: <OHCI (generic) USB controller> mem
0xf7ef9000-0xf7ef9fff irq 16 at device 18.1 on pci0
> Aug 19 13:28:15 bsd kernel: usbus1 on ohci1
> Aug 19 13:28:15 bsd kernel: ehci0: <AMD SB7x0/SB8x0/SB9x0 USB 2.0
controller> mem 0xf7efb800-0xf7efb8ff irq 17 at device 18.2 on pci0
> Aug 19 13:28:15 bsd kernel: usbus2: EHCI version 1.0
> Aug 19 13:28:15 bsd kernel: usbus2 on ehci0
> Aug 19 13:28:15 bsd kernel: ohci2: <AMD SB7x0/SB8x0/SB9x0 USB controller>
mem 0xf7ef8000-0xf7ef8fff irq 18 at device 19.0 on pci0
> Aug 19 13:28:15 bsd kernel: usbus3 on ohci2
> Aug 19 13:28:15 bsd kernel: ohci3: <OHCI (generic) USB controller> mem
0xf7ef7000-0xf7ef7fff irq 18 at device 19.1 on pci0
> Aug 19 13:28:15 bsd kernel: usbus4 on ohci3
> Aug 19 13:28:15 bsd kernel: ehci1: <AMD SB7x0/SB8x0/SB9x0 USB 2.0
controller> mem 0xf7efb400-0xf7efb4ff irq 19 at device 19.2 on pci0
> Aug 19 13:28:15 bsd kernel: usbus5: EHCI version 1.0
> Aug 19 13:28:15 bsd kernel: usbus5 on ehci1
> Aug 19 13:28:15 bsd kernel: pci0: <serial bus, SMBus> at device 20.0 (no
driver attached)
> Aug 19 13:28:15 bsd kernel: atapci0: <ATI IXP700/800 UDMA133 controller>
port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xff00-0xff0f at device 20.1 on
pci0
> Aug 19 13:28:15 bsd kernel: ata0: <ATA channel> at channel 0 on atapci0
> Aug 19 13:28:15 bsd kernel: isab0: <PCI-ISA bridge> at device 20.3 on pci0
> Aug 19 13:28:15 bsd kernel: isa0: <ISA bus> on isab0
> Aug 19 13:28:15 bsd kernel: pcib3: <ACPI PCI-PCI bridge> at device 20.4
on pci0
> Aug 19 13:28:15 bsd kernel: pci3: <ACPI PCI bus> on pcib3
> Aug 19 13:28:15 bsd kernel: vgapci0: <VGA-compatible display> mem
0xf8000000-0xfbffffff irq 21 at device 6.0 on pci3
> Aug 19 13:28:15 bsd kernel: em0: <Intel(R) PRO/1000 Legacy Network
Connection 1.0.4> port 0xec00-0xec3f mem
0xfeb80000-0xfebbffff,0xfeb40000-0xfeb7ffff irq 22 at device 7.0 on pci3
> Aug 19 13:28:15 bsd kernel: em0: Setup of Shared code failed
> Aug 19 13:28:15 bsd kernel: device_attach: em0 attach returned 6
> Aug 19 13:28:15 bsd kernel: ohci4: <AMD SB7x0/SB8x0/SB9x0 USB controller>
mem 0xf7ef6000-0xf7ef6fff irq 18 at device 20.5 on pci0
> Aug 19 13:28:15 bsd kernel: usbus6 on ohci4
> Aug 19 13:28:15 bsd kernel: acpi_button0: <Power Button> on acpi0
> Aug 19 13:28:15 bsd kernel: atkbdc0: <Keyboard controller (i8042)> port
0x60,0x64 irq 1 on acpi0
> Aug 19 13:28:15 bsd kernel: atkbd0: <AT Keyboard> irq 1 on atkbdc0
> Aug 19 13:28:15 bsd kernel: kbd0 at atkbd0
> Aug 19 13:28:15 bsd kernel: atkbd0: [GIANT-LOCKED]
> Aug 19 13:28:15 bsd kernel: uart0: <16550 or compatible> port 0x3f8-0x3ff
irq 4 flags 0x10 on acpi0
> Aug 19 13:28:15 bsd kernel: orm0: <ISA Option ROM> at iomem
0xc0000-0xc7fff on isa0
> Aug 19 13:28:15 bsd kernel: sc0: <System console> at flags 0x100 on isa0
> Aug 19 13:28:15 bsd kernel: sc0: VGA <16 virtual consoles, flags=0x300>
> Aug 19 13:28:15 bsd kernel: vga0: <Generic ISA VGA> at port 0x3c0-0x3df
iomem 0xa0000-0xbffff on isa0
> Aug 19 13:28:15 bsd kernel: ppc0: cannot reserve I/O port range
> Aug 19 13:28:15 bsd kernel: ctl: CAM Target Layer loaded
> Aug 19 13:28:15 bsd kernel: acpi_throttle0: <ACPI CPU Throttling> on cpu0
> Aug 19 13:28:15 bsd kernel: hwpstate0: <Cool`n'Quiet 2.0> on cpu0
> Aug 19 13:28:15 bsd kernel: ZFS filesystem version 5
> Aug 19 13:28:15 bsd kernel: ZFS storage pool version 28
> Aug 19 13:28:15 bsd kernel: Timecounters tick every 1.000 msec
> Aug 19 13:28:15 bsd kernel: usbus0: 12Mbps Full Speed USB v1.0
> Aug 19 13:28:15 bsd kernel: usbus1: 12Mbps Full Speed USB v1.0
> Aug 19 13:28:15 bsd kernel: usbus2: 480Mbps High Speed USB v2.0
> Aug 19 13:28:15 bsd kernel: usbus3: 12Mbps Full Speed USB v1.0
> Aug 19 13:28:15 bsd kernel: usbus4: 12Mbps Full Speed USB v1.0
> Aug 19 13:28:15 bsd kernel: usbus5: 480Mbps High Speed USB v2.0
> Aug 19 13:28:15 bsd kernel: usbus6: 12Mbps Full Speed USB v1.0
> Aug 19 13:28:15 bsd kernel: ugen0.1: <ATI> at usbus0
> Aug 19 13:28:15 bsd kernel: uhub0: <ATI OHCI root HUB, class 9/0, rev
1.00/1.00, addr 1> on usbus0
> Aug 19 13:28:15 bsd kernel: ugen1.1: <ATI> at usbus1
> Aug 19 13:28:15 bsd kernel: uhub1: <ATI OHCI root HUB, class 9/0, rev
1.00/1.00, addr 1> on usbus1
> Aug 19 13:28:15 bsd kernel: ugen2.1: <ATI> at usbus2
> Aug 19 13:28:15 bsd kernel: uhub2: <ATI EHCI root HUB, class 9/0, rev
2.00/1.00, addr 1> on usbus2
> Aug 19 13:28:15 bsd kernel: ugen3.1: <ATI> at usbus3
> Aug 19 13:28:15 bsd kernel: uhub3: <ATI OHCI root HUB, class 9/0, rev
1.00/1.00, addr 1> on usbus3
> Aug 19 13:28:15 bsd kernel: ugen4.1: <ATI> at usbus4
> Aug 19 13:28:15 bsd kernel: uhub4: <ATI OHCI root HUB, class 9/0, rev
1.00/1.00, addr 1> on usbus4
> Aug 19 13:28:15 bsd kernel: ugen5.1: <ATI> at usbus5
> Aug 19 13:28:15 bsd kernel: uhub5: <ATI EHCI root HUB, class 9/0, rev
2.00/1.00, addr 1> on usbus5
> Aug 19 13:28:15 bsd kernel: ugen6.1: <ATI> at usbus6
> Aug 19 13:28:15 bsd kernel: uhub6: <ATI OHCI root HUB, class 9/0, rev
1.00/1.00, addr 1> on usbus6
> Aug 19 13:28:15 bsd kernel: uhub6: 2 ports with 2 removable, self powered
> Aug 19 13:28:15 bsd kernel: uhub0: 3 ports with 3 removable, self powered
> Aug 19 13:28:15 bsd kernel: uhub1: 3 ports with 3 removable, self powered
> Aug 19 13:28:15 bsd kernel: uhub3: 3 ports with 3 removable, self powered
> Aug 19 13:28:15 bsd kernel: uhub4: 3 ports with 3 removable, self powered
> Aug 19 13:28:15 bsd kernel: uhub2: 6 ports with 6 removable, self powered
> Aug 19 13:28:15 bsd kernel: uhub5: 6 ports with 6 removable, self powered
> Aug 19 13:28:15 bsd kernel: ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
> Aug 19 13:28:15 bsd kernel: ada0: <OCZ-VECTOR 1.03.1> ATA-8 SATA 3.x
device
> Aug 19 13:28:15 bsd kernel: ada0: 300.000MB/s transfers (SATA 2.x, UDMA6,
PIO 512bytes)
> Aug 19 13:28:15 bsd kernel: ada0: Command Queueing enabled
> Aug 19 13:28:15 bsd kernel: ada0: 122104MB (250069680 512 byte sectors:
16H 63S/T 16383C)
> Aug 19 13:28:15 bsd kernel: ada0: Previously was known as ad4
> Aug 19 13:28:15 bsd kernel: ada1 at ahcich1 bus 0 scbus1 target 0 lun 0
> Aug 19 13:28:15 bsd kernel: ada1: <ST2000DM001-1CH164 CC27> ATA-9 SATA
3.x device
> Aug 19 13:28:15 bsd kernel: ada1: 300.000MB/s transfers (SATA 2.x, UDMA6,
PIO 8192bytes)
> Aug 19 13:28:15 bsd kernel: ada1: Command Queueing enabled
> Aug 19 13:28:15 bsd kernel: ada1: 1907729MB (3907029168 512 byte sectors:
16H 63S/T 16383C)
> Aug 19 13:28:15 bsd kernel: ada1: Previously was known as ad6
> Aug 19 13:28:15 bsd kernel: ada2 at ahcich2 bus 0 scbus2 target 0 lun 0
> Aug 19 13:28:15 bsd kernel: ada2: <ST2000DM001-1CH164 CC27> ATA-9 SATA
3.x device
> Aug 19 13:28:15 bsd kernel: ada2: 300.000MB/s transfers (SATA 2.x, UDMA6,
PIO 8192bytes)
> Aug 19 13:28:15 bsd kernel: ada2: Command Queueing enabled
> Aug 19 13:28:15 bsd kernel: ada2: 1907729MB (3907029168 512 byte sectors:
16H 63S/T 16383C)
> Aug 19 13:28:15 bsd kernel: ada2: Previously was known as ad8
> Aug 19 13:28:15 bsd kernel: ada3 at ahcich3 bus 0 scbus3 target 0 lun 0
> Aug 19 13:28:15 bsd kernel: ada3: <ST2000DL003-9VT166 CC3C> ATA-8 SATA
3.x device
> Aug 19 13:28:15 bsd kernel: ada3: 300.000MB/s transfers (SATA 2.x, UDMA6,
PIO 8192bytes)
> Aug 19 13:28:15 bsd kernel: ada3: Command Queueing enabled
> Aug 19 13:28:15 bsd kernel: ada3: 1907729MB (3907029168 512 byte sectors:
16H 63S/T 16383C)
> Aug 19 13:28:15 bsd kernel: ada3: Previously was known as ad10
> Aug 19 13:28:15 bsd kernel: ada4 at ahcich4 bus 0 scbus4 target 0 lun 0
> Aug 19 13:28:15 bsd kernel: ada4: <WDC WD20EARS-14MVWB0 51.0AB51> ATA-8
SATA 2.x device
> Aug 19 13:28:15 bsd kernel: ada4: 300.000MB/s transfers (SATA 2.x, UDMA6,
PIO 8192bytes)
> Aug 19 13:28:15 bsd kernel: ada4: Command Queueing enabled
> Aug 19 13:28:15 bsd kernel: ada4: 1907729MB (3907029168 512 byte sectors:
16H 63S/T 16383C)
> Aug 19 13:28:15 bsd kernel: ada4: Previously was known as ad12
> Aug 19 13:28:15 bsd kernel: SMP: AP CPU #2 Launched!
> Aug 19 13:28:15 bsd kernel: SMP: AP CPU #3 Launched!
> Aug 19 13:28:15 bsd kernel: SMP: AP CPU #1 Launched!
> Aug 19 13:28:15 bsd kernel: Timecounter "TSC-low" frequency 12164250 Hz
quality 800
> Aug 19 13:28:15 bsd kernel: ugen5.2: <Kingston> at usbus5
> Aug 19 13:28:15 bsd kernel: umass0: <Kingston DataTraveler 410, class
0/0, rev 2.00/1.00, addr 2> on usbus5
> Aug 19 13:28:15 bsd kernel: umass0:  SCSI over Bulk-Only; quirks = 0x0100
> Aug 19 13:28:15 bsd kernel: umass0:8:0:-1: Attached to scbus8
> Aug 19 13:28:15 bsd kernel: da0 at umass-sim0 bus 0 scbus8 target 0 lun 0
> Aug 19 13:28:15 bsd kernel: da0: <Kingston DataTraveler 410 PMAP>
Removable Direct Access SCSI-0 device
> Aug 19 13:28:15 bsd kernel: da0: 40.000MB/s transfers
> Aug 19 13:28:15 bsd kernel: da0: 3816MB (7815168 512 byte sectors: 255H
63S/T 486C)
> Aug 19 13:28:15 bsd kernel: GEOM: da0: geometry does not match label
(64h,33s != 255h,63s).
> Aug 19 13:28:15 bsd kernel: GEOM: da0: media size does not match label.
> Aug 19 13:28:15 bsd kernel: Trying to mount root from zfs:zopa []...
> Aug 19 13:59:55 bsd login: 2 LOGIN FAILURES ON ttyv0
> Aug 19 14:00:52 bsd su: BAD SU natka to root on /dev/ttyv0
> Aug 19 14:01:03 bsd last message repeated 2 times
> Aug 19 14:01:13 bsd login: ROOT LOGIN (root) ON ttyv1
> Aug 19 14:03:54 bsd su: natka to root on /dev/ttyv0
Comment 4 bmcnally 2013-10-08 04:46:09 UTC
This is still a problem on FreeBSD 9.2-RELEASE. After rebuilding to 
9.2-RELEASE neither of my network interfaces show up in ifconfig. The 
behavior is exactly what Yvan originally reported too:

===
em0: Setup of Shared code failed
device_attach: em0 attach returned 6
===

Also, now my Realtek device won't show up either:

===
re0: PHY read failed
re0: attaching PHYs failed
device_attach: re0 attach returned 6
===
Comment 5 shumadk 2013-10-23 10:06:50 UTC
Have the same problem with SuperMicro C2SBC-Q board (9.1-RELEASE-p5):

kernel: em1: <Intel(R) PRO/1000 Network Connection 7.3.2> port
0x2000-0x201f irq 16 at device 0.0 on pci13
kernel: em1: Using an MSI interrupt
kernel: em1: Setup of Shared code failed
kernel: device_attach: em1 attach returned 6

And rarely, on cold start only:
kernel: em1: <Intel(R) PRO/1000 Network Connection 7.3.2> port
0x2000-0x201f irq 16 at device 0.0 on pci13
kernel: em1: Using an MSI interrupt
kernel: em1: The EEPROM Checksum Is Not Valid
kernel: device_attach: em1 attach returned 5

em0 works OK:
kernel: em0: <Intel(R) PRO/1000 Network Connection 7.3.2> port
0x1820-0x183f mem 0xd0580000-0xd059ffff,0xd05a4000-0xd05a4fff irq 16 at
device 25.0 on pci0
kernel: em0: Using an MSI interrupt
kernel: em0: Ethernet address: 00:30:48:xx:xx:xx
(MAC changed)

Found some info on this issue on Lenovo support website:
http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-67166

Tried to reset config with Intel PREBOOT tool - didn't help.


--
Dmitry Shumilin

e-mail: shumadk@gmail.com
Comment 6 Mark Linimon freebsd_committer freebsd_triage 2015-11-12 07:45:35 UTC
Reassign to erj@ for triage.  To submitter: is this issue still relevant?
Comment 7 yvan+freebsd 2015-11-12 15:10:19 UTC
It is no longer relevant to *me*, as I have recently migrated this server to other hardware; however I did encounter many people with the same issue on similar hardware for whom the problem persists.
Comment 8 Eric Joyner freebsd_committer 2017-08-24 21:56:06 UTC
I don't think em(4) stable/9 is going to get any more network driver updates.