Bug 176191 - databases/firebird25-server:bug with fbintl.conf path
Summary: databases/firebird25-server:bug with fbintl.conf path
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-16 12:40 UTC by jjachuf
Modified: 2013-09-09 16:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jjachuf 2013-02-16 12:40:00 UTC
when installed FB25-server fbintl.conf is copied to /usr/local/etc/firebird/fbintl.conf. This causes errors to occur in situations when you want to work with some encodings. For example:

gbak -r o -v -fix_fss_m ISO8859_1 -user SYSDBA -password masterkey /home/fb_data/sgm.fbk /home/fb_data/sgm.fdb

I get

gbak: ERROR: CHARACTER SET ISO8859_1 is not defined

Fix: 

# cp /usr/local/etc/firebird/fbintl.conf /usr/local/libexec/firebird/intl/

They should change the port to copy fbintl.conf to

/usr/local/libexec/firebird/intl/
Comment 1 Edwin Groothuis freebsd_committer 2013-02-16 12:40:26 UTC
Responsible Changed
From-To: freebsd-ports-bugs->acm

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-03-24 04:35:43 UTC
Author: acm
Date: Sun Mar 24 04:35:29 2013
New Revision: 315093
URL: http://svnweb.freebsd.org/changeset/ports/315093

Log:
  - Update to 2.0.7
  - Move files/pkg-install.in to pkg-install
  - Add new warning message when it is building as root
  - Remove obsolete patch files
  - Fix installation of fbintl.conf to ${PREFIX}/etc/firebird [1].
  
  PR:	176191		[1]
  Submitted by:	Jose Jachuf <jjachuf __ __gmail.com>

Added:
  head/databases/firebird25-server/files/patch-builds-posix_empty.vers   (contents, props changed)
  head/databases/firebird25-server/pkg-install
     - copied, changed from r315090, head/databases/firebird25-server/files/pkg-install.in
Deleted:
  head/databases/firebird25-server/files/pkg-install.in
Modified:
  head/databases/firebird25-server/Makefile
  head/databases/firebird25-server/distinfo

Modified: head/databases/firebird25-server/Makefile
==============================================================================
--- head/databases/firebird25-server/Makefile	Sun Mar 24 04:30:30 2013	(r315092)
+++ head/databases/firebird25-server/Makefile	Sun Mar 24 04:35:29 2013	(r315093)
@@ -2,12 +2,12 @@
 # $FreeBSD$
 
 PORTNAME=	firebird
-PORTVERSION=	2.5.1
-PORTREVISION?=	2
+PORTVERSION=	2.5.2
+PORTREVISION?=	0
 CATEGORIES?=	databases
 MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/.0//}-Release/
 PKGNAMESUFFIX?=	-server
-DISTNAME=	${PORTNAME:S/f/F/}-${PORTVERSION}.26351-0
+DISTNAME=	${PORTNAME:S/f/F/}-${PORTVERSION}.26539-0
 DIST_SUBDIR=	${PORTNAME}
 
 MAINTAINER=	acm@FreeBSD.org
@@ -30,7 +30,7 @@ CONFIGURE_ARGS=	--with-system-editline \
 		--with-fbconf=${CONFDIR} \
 		--with-fbglock=${LOCALSTATEDIR} \
 		--with-fbhelp=${LOCALSTATEDIR}/help \
-		--with-fbintl=${LIBEXECDIR}/intl \
+		--with-fbintl=${CONFDIR}/intl \
 		--with-fblog=${LOCALSTATEDIR} \
 		--with-fbmsg=${DATADIR} \
 		--with-fbplugins=${LIBEXECDIR}/plugins \
@@ -75,7 +75,7 @@ LIB_DEPENDS+=	fbembed.2:${PORTSDIR}/data
 ALL_TARGET=	firebird_embedded
 
 USE_RC_SUBR=	firebird
-SUB_FILES=	pkg-install pkg-message
+SUB_FILES=	pkg-message
 
 UTIL_SBIN=	fb_inet_server fb_lock_print fb_smp_server
 UTIL_BIN=	fbguard fbsplit fbstat fbsvcmgr fbtracemgr gbak gdef gfix gsec \
@@ -129,9 +129,9 @@ post-install:
 .ifndef WITHOUT_IPC_CLEANUP
 pre-build:
 .ifndef PACKAGE_BUILDING
-	@if [ `${ID} -u` -eq 0 ]; then \
-	${ECHO_MSG} "==> Please do not build ${PORTNAME} as 'root' because this may cause conflicts with SysV semaphores of running services."; exit 1; fi
+	@${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
 .endif
+
 	${MAKE} -C ${WRKSRC}/extern/btyacc
 	[ -f ${WRKDIR}/ipcs.pre.build ] || ${IPCS_CMD} -s | ${TAIL} -n +3 | \
 		${GREP} -F `${ID} -un` | ${CAT} > ${WRKDIR}/ipcs.pre.build

Modified: head/databases/firebird25-server/distinfo
==============================================================================
--- head/databases/firebird25-server/distinfo	Sun Mar 24 04:30:30 2013	(r315092)
+++ head/databases/firebird25-server/distinfo	Sun Mar 24 04:35:29 2013	(r315093)
@@ -1,2 +1,2 @@
-SHA256 (firebird/Firebird-2.5.1.26351-0.tar.bz2) = c4d236e7a9ab3ca00df3faca80f55175d11052637369c877b3e22cd377edb813
-SIZE (firebird/Firebird-2.5.1.26351-0.tar.bz2) = 13665242
+SHA256 (firebird/Firebird-2.5.2.26539-0.tar.bz2) = 6b90e5579f9dc3f527b7cf84ac869682aa9582a61f81c6288926c332a863abc8
+SIZE (firebird/Firebird-2.5.2.26539-0.tar.bz2) = 13708119

Added: head/databases/firebird25-server/files/patch-builds-posix_empty.vers
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/databases/firebird25-server/files/patch-builds-posix_empty.vers	Sun Mar 24 04:35:29 2013	(r315093)
@@ -0,0 +1,11 @@
+--- builds/posix/empty.vers	2013-03-23 02:37:17.000000000 -0500
++++ builds/posix/empty.vers	2013-03-23 02:37:33.000000000 -0500
+@@ -27,6 +27,8 @@
+ {
+ global:
+ 	main;
++	__progname;
++	environ;
+ 
+ local:
+ 	*;

Copied and modified: head/databases/firebird25-server/pkg-install (from r315090, head/databases/firebird25-server/files/pkg-install.in)
==============================================================================
--- head/databases/firebird25-server/files/pkg-install.in	Sun Mar 24 03:08:36 2013	(r315090, copy source)
+++ head/databases/firebird25-server/pkg-install	Sun Mar 24 04:35:29 2013	(r315093)
@@ -4,7 +4,27 @@
 
 PATH=/bin:/usr/bin:/usr/sbin
 
+buildwarning() {
+cat <<EOF
+###############################################################################
+
+                             ** IMPORTANT **
+
+Keep in mind that if you build firebird server as 'root', this may cause
+conflicts with SysV semaphores of running services.
+
+If you want to cancel it, press ctrl-C now if you need check some things
+before of build it.
+
+###############################################################################
+EOF
+        sleep 5
+}
+
 case $2 in
+PRE-INSTALL)
+	buildwarning
+;;
 POST-INSTALL)
 cd /var/db/firebird
 
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Jose Alonso Cardenas Marquez freebsd_committer 2013-03-24 04:40:03 UTC
State Changed
From-To: open->closed

- Now it could be fixed. Please test it
Comment 4 Sascha Klauder 2013-09-09 13:02:45 UTC
 I can confirm that this problem is still present in both
firebird21-server and firebird25-server ports.  Setting
with-fbintl=${CONFDIR}/intl does not resolve this; the
fbintl.conf file needs to be installed in the same directory
as the fbintl shared library file, i.e. ${LIBEXECDIR}/intl.

 I'd propose installing a symlink ${LIBEXECDIR}/intl/fbintl.conf
pointing to ${CONFDIR}/intl/fbintl.conf.

Cheers,
-sascha
Comment 5 jjachuf 2013-09-09 16:38:23 UTC
2013/9/9 Sascha Klauder <sklauder@trimind.de>

>  I can confirm that this problem is still present in both
> firebird21-server and firebird25-server ports.  Setting
> with-fbintl=${CONFDIR}/intl does not resolve this; the
> fbintl.conf file needs to be installed in the same directory
> as the fbintl shared library file, i.e. ${LIBEXECDIR}/intl.
>
>  I'd propose installing a symlink ${LIBEXECDIR}/intl/fbintl.conf
> pointing to ${CONFDIR}/intl/fbintl.conf.
>
> Cheers,
> -sascha
>


The problem is not in the port, is in fdb. If you want to install with pip
gives the same error. The error occurs with 9.1-i386. With ADM64 and 8.0
work well

Jose