Bug 176236 - Rename devel/py-flakes to devel/py-pyflakes, update to 0.6.1, and more
Summary: Rename devel/py-flakes to devel/py-pyflakes, update to 0.6.1, and more
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-python (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 12:20 UTC by Kubilay Kocak
Modified: 2013-03-09 05:55 UTC (History)
0 users

See Also:


Attachments
file.diff (12.65 KB, patch)
2013-02-18 12:20 UTC, Kubilay Kocak
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kubilay Kocak freebsd_committer freebsd_triage 2013-02-18 12:20:01 UTC
Changes:

- Rename py-flakes to py-pyflakes (according to upstream package name)
- Add devel/py-flakes entry to MOVED
- Add py-pyflakes SUBDIR to devel/Makefile

While I'm here:

- Update to 0.6.1
- DISTNAME and PYDISTUTILS_PKGNAME overrides not required after rename
- Switch to setuptools, and update pkg-plist accordingly
- Add LICENSE
- Patch setup.py, adding zip_safe=False
- Add TESTS option and regression-test: target
- Update COMMENT to match upstream and conventions
- Trim Makefile header

<QA>
portlint: looks fine.
porttest: OK
unittest: Ran 221 tests in 0.134s - OK (skipped=12)
testport: OK (All versions, archs)

Additional (MOVED):

- make checksubdirs - OK
- Run MOVEDlint.awk - OK
- MOVED: YYYY-MM-DD format - OK
- Dependents: There are no ports dependent upon this port
<QA>

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-02-18 17:17:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

freebsd-python@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2013-02-18 17:17:13 UTC
Maintainer of devel/py-flakes,

Please note that PR ports/176236 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/176236

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2013-02-18 17:17:14 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 dfilter service freebsd_committer 2013-03-09 05:44:17 UTC
Author: koobs
Date: Sat Mar  9 05:44:02 2013
New Revision: 313689
URL: http://svnweb.freebsd.org/changeset/ports/313689

Log:
  - Rename py-flakes to py-pyflakes
  - Add devel/py-flakes entry to MOVED
  - Add py-pyflakes SUBDIR to devel/Makefile
  
  While I'm here:
  
  - Update to 0.6.1
  - Take maintainership (multiple timeouts since 2009)
  - Switch to setuptools, and update pkg-plist accordingly
  - Remove unecessary DISTNAME & PYDISTUTILS_PKGNAME after rename
  - Patch setup.py, adding zip_safe=False
  - Add LICENSE
  - Add TESTS option and regression-test: target
  - Update COMMENT to match upstream and conventions
  - Trim Makefile header
  
  Approved by:	maintainer timeout (2 weeks)
  Approved by:	rm (mentor)
  PR:		ports/176236

Added:
  head/devel/py-pyflakes/
     - copied from r312485, head/devel/py-flakes/
  head/devel/py-pyflakes/files/
  head/devel/py-pyflakes/files/patch-setup.py   (contents, props changed)
Deleted:
  head/devel/py-flakes/
Modified:
  head/MOVED
  head/devel/Makefile
  head/devel/py-pyflakes/Makefile
  head/devel/py-pyflakes/distinfo
  head/devel/py-pyflakes/pkg-plist

Modified: head/MOVED
==============================================================================
--- head/MOVED	Sat Mar  9 04:06:57 2013	(r313688)
+++ head/MOVED	Sat Mar  9 05:44:02 2013	(r313689)
@@ -4061,6 +4061,7 @@ x11-toolkits/gtkglarea||2013-02-14|Has e
 graphics/solang||2013-02-14|Has expired: BROKEN for more than 6 month
 math/octave-devel||2013-02-14|Has expired: BROKEN for more than 6 month
 net/spnetkit||2013-02-14|Has expired: BROKEN for more than 6 month
+devel/py-flakes|devel/py-pyflakes|2013-02-18|Renamed to correct upstream name
 net/samba4-devel|net/samba4|2013-02-18|Renamed to reflect maturity of upstream version
 net/libnet-devel|net/libnet|2013-02-18|Renamed to stable branch
 x11-fm/tkdesk||2013-02-19|Obsolete and unmaintained, doesn't run

Modified: head/devel/Makefile
==============================================================================
--- head/devel/Makefile	Sat Mar  9 04:06:57 2013	(r313688)
+++ head/devel/Makefile	Sat Mar  9 05:44:02 2013	(r313689)
@@ -3455,7 +3455,7 @@
     SUBDIR += py-five.globalrequest
     SUBDIR += py-five.localsitemanager
     SUBDIR += py-flake8
-    SUBDIR += py-flakes
+    SUBDIR += py-pyflakes
     SUBDIR += py-flask-babel
     SUBDIR += py-flexmock
     SUBDIR += py-foolscap

Modified: head/devel/py-pyflakes/Makefile
==============================================================================
--- head/devel/py-flakes/Makefile	Mon Feb 18 07:38:33 2013	(r312485)
+++ head/devel/py-pyflakes/Makefile	Sat Mar  9 05:44:02 2013	(r313689)
@@ -1,23 +1,32 @@
-# New ports collection makefile for:	py-flakes
-# Date created:				13 Apr 2006
-# Whom:					Alexander Botero-Lowry <alex@foxybanana.com>
-#
+# Created by: Alexander Botero-Lowry <alex@foxybanana.com>
 # $FreeBSD$
-#
 
-PORTNAME=	flakes
-PORTVERSION=	0.5.0
+PORTNAME=	pyflakes
+PORTVERSION=	0.6.1
 CATEGORIES=	devel python
 MASTER_SITES=	CHEESESHOP \
 		http://launchpadlibrarian.net/79102431/
 PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
-DISTNAME=	pyflakes-${PORTVERSION}
 
-MAINTAINER=	ayu@commun.jp
-COMMENT=	Pyflakes is a program that analyzes Python programs for errors
+MAINTAINER=	koobs@FreeBSD.org
+COMMENT=	Program to analyze Python programs and detect various errors
 
-USE_PYTHON=	yes
-USE_PYDISTUTILS=	yes
-PYDISTUTILS_PKGNAME=	pyflakes
+LICENSE=	MIT
+
+OPTIONS_DEFINE=	TESTS
+TESTS_DESC=	Include tools for unit tests
+OPTIONSFILE?=	${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTESTS}
+BUILD_DEPENDS+=	${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
+.endif
+
+USE_PYTHON=		yes
+USE_PYDISTUTILS=	easy_install
+
+regression-test: build
+	@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
 
 .include <bsd.port.mk>

Modified: head/devel/py-pyflakes/distinfo
==============================================================================
--- head/devel/py-flakes/distinfo	Mon Feb 18 07:38:33 2013	(r312485)
+++ head/devel/py-pyflakes/distinfo	Sat Mar  9 05:44:02 2013	(r313689)
@@ -1,2 +1,2 @@
-SHA256 (pyflakes-0.5.0.tar.gz) = 53f9794aa13b99cca04259b4a1fe4bd207dc3b2d7dd85ba715814fdeae2ef8cd
-SIZE (pyflakes-0.5.0.tar.gz) = 17635
+SHA256 (pyflakes-0.6.1.tar.gz) = 8dd31411ded531cca5ed27fdee96f5176db367d5cc91e39e87c1bae47d54dec6
+SIZE (pyflakes-0.6.1.tar.gz) = 26081

Added: head/devel/py-pyflakes/files/patch-setup.py
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-pyflakes/files/patch-setup.py	Sat Mar  9 05:44:02 2013	(r313689)
@@ -0,0 +1,8 @@
+--- ./setup.py.orig	2013-02-18 20:32:09.721700908 +1100
++++ ./setup.py	2013-02-18 20:32:47.127424592 +1100
+@@ -44,4 +44,5 @@
+         "Topic :: Software Development",
+         "Topic :: Utilities",
+     ],
++    zip_safe=False,
+     **extra)

Modified: head/devel/py-pyflakes/pkg-plist
==============================================================================
--- head/devel/py-flakes/pkg-plist	Mon Feb 18 07:38:33 2013	(r312485)
+++ head/devel/py-pyflakes/pkg-plist	Sat Mar  9 05:44:02 2013	(r313689)
@@ -1,37 +1,51 @@
-%%PYTHON_SITELIBDIR%%/pyflakes/__init__.py
-%%PYTHON_SITELIBDIR%%/pyflakes/__init__.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/__init__.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/checker.py
-%%PYTHON_SITELIBDIR%%/pyflakes/checker.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/checker.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/messages.py
-%%PYTHON_SITELIBDIR%%/pyflakes/messages.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/messages.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/scripts/__init__.py
-%%PYTHON_SITELIBDIR%%/pyflakes/scripts/__init__.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/scripts/__init__.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/scripts/pyflakes.py
-%%PYTHON_SITELIBDIR%%/pyflakes/scripts/pyflakes.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/scripts/pyflakes.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/test/__init__.py
-%%PYTHON_SITELIBDIR%%/pyflakes/test/__init__.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/test/__init__.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/test/harness.py
-%%PYTHON_SITELIBDIR%%/pyflakes/test/harness.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/test/harness.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_imports.py
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_imports.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_imports.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_other.py
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_other.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_other.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_script.py
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_script.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_script.pyo
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_undefined_names.py
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_undefined_names.pyc
-%%PYTHON_SITELIBDIR%%/pyflakes/test/test_undefined_names.pyo
 bin/pyflakes
-@dirrm %%PYTHON_SITELIBDIR%%/pyflakes/test
-@dirrm %%PYTHON_SITELIBDIR%%/pyflakes/scripts
-@dirrm %%PYTHON_SITELIBDIR%%/pyflakes
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/api.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/api.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/api.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/checker.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/checker.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/checker.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/messages.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/messages.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/messages.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/reporter.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/reporter.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/reporter.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts/pyflakes.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts/pyflakes.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts/pyflakes.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/harness.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/harness.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/harness.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_api.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_api.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_api.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_imports.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_imports.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_imports.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_other.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_other.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_other.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_undefined_names.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_undefined_names.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test/test_undefined_names.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/test
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes/scripts
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pyflakes
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2013-03-09 05:55:15 UTC
State Changed
From-To: feedback->closed

Committed with minor changes in r313689. Thanks!