Bug 176750 - accessibility/at-spi does not record a CONFLICTS for at-spi2-atk
Summary: accessibility/at-spi does not record a CONFLICTS for at-spi2-atk
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-08 16:50 UTC by Matthias Andree
Modified: 2013-03-09 17:20 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Andree freebsd_committer 2013-03-08 16:50:00 UTC
at-spi2-atk has this line:
CONFLICTS=      at-spi-1.[0-9]*

but at-spi has no corresponding line.

The file these two fight over is:
$ pkg_info -W /usr/local/lib/gtk-2.0/modules/libatk-bridge.so
pkg_info: both at-spi-1.32.0_1 and at-spi2-atk-2.6.2 claim to have installed /usr/local/lib/gtk-2.0/modules/libatk-bridge.so

To see the failure, remove at-spi-1*, install at-spi2-atk, then install
at-spi.

Fix: 

Add a proper CONFLICTS=	at-spi2-atk-[0-9]* line to at-spi's Makefile.
Comment 1 Edwin Groothuis freebsd_committer 2013-03-08 16:50:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-03-09 17:10:55 UTC
Author: kwm
Date: Sat Mar  9 17:10:48 2013
New Revision: 313732
URL: http://svnweb.freebsd.org/changeset/ports/313732

Log:
  Don't build the libatk-bridge.so gtk module, depend on at-spi2-atk for that.
  This resolves conflict between at-spi2-atk and at-spi.
  
  PR:		ports/176750 [1]
  PR:		ports/176775 [2]
  Sumbitted by:	mandree@ [1], rm@ [2]

Modified:
  head/accessibility/at-spi/Makefile
  head/accessibility/at-spi/pkg-plist

Modified: head/accessibility/at-spi/Makefile
==============================================================================
--- head/accessibility/at-spi/Makefile	Sat Mar  9 16:56:58 2013	(r313731)
+++ head/accessibility/at-spi/Makefile	Sat Mar  9 17:10:48 2013	(r313732)
@@ -4,7 +4,7 @@
 
 PORTNAME=	at-spi
 PORTVERSION=	1.32.0
-PORTREVISION?=	1
+PORTREVISION?=	2
 CATEGORIES=	accessibility x11-toolkits
 MASTER_SITES=	GNOME
 DIST_SUBDIR=	gnome2
@@ -16,6 +16,8 @@ USE_BZIP2=	yes
 
 .if !defined(REFERENCE_PORT)
 
+RUN_DEPENDS=	at-spi2-atk>2.6.0:${PORTSDIRS}/accessibility/at-spi2-atk
+
 USE_GETTEXT=	yes
 USE_GMAKE=	yes
 USE_GNOME=	gnomehack gnomehier intlhack gtk20 gconf2 libbonobo
@@ -35,6 +37,7 @@ post-extract:
 post-patch:
 	@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" ${WRKSRC}/Makefile.in
 	@${REINPLACE_CMD} -e "/^SUBDIRS =/s/docs//" ${WRKSRC}/Makefile.in
+	@${REINPLACE_CMD} -e "/^SUBDIRS =/s/atk-bridge//" ${WRKSRC}/Makefile.in
 
 .include <bsd.port.mk>
 

Modified: head/accessibility/at-spi/pkg-plist
==============================================================================
--- head/accessibility/at-spi/pkg-plist	Sat Mar  9 16:56:58 2013	(r313731)
+++ head/accessibility/at-spi/pkg-plist	Sat Mar  9 17:10:48 2013	(r313732)
@@ -33,9 +33,6 @@ include/at-spi-1.0/libspi/text.h
 include/at-spi-1.0/libspi/value.h
 include/at-spi-1.0/login-helper/Accessibility_LoginHelper.h
 include/at-spi-1.0/login-helper/login-helper.h
-lib/gtk-2.0/modules/libatk-bridge.a
-lib/gtk-2.0/modules/libatk-bridge.la
-lib/gtk-2.0/modules/libatk-bridge.so
 lib/libcspi.a
 lib/libcspi.la
 lib/libcspi.so
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Koop Mast freebsd_committer 2013-03-09 17:11:41 UTC
State Changed
From-To: open->closed

Fix by removing the conflict, thanks for reporting!