Bug 176776 - [PATCH] editors/libreoffice needs USE_OPENLDAP
Summary: [PATCH] editors/libreoffice needs USE_OPENLDAP
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-09 06:20 UTC by John Marshall
Modified: 2013-03-11 18:20 UTC (History)
0 users

See Also:


Attachments
libreoffice_4.0.1.diff (675 bytes, patch)
2013-03-09 06:20 UTC, John Marshall
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Marshall 2013-03-09 06:20:00 UTC
The 4.0.1 port includes the following LIBDEPENDS dependency instead of
USE_OPENLDAP.

		ldap-2.4:${PORTSDIR}/net/openldap24-client

Apart from the fact that the port should use USE_OPENLDAP anyway, the
presence of net/openldap24-client in the list makes portmaster try to
install net/openldap24-client - even although I already have
net/openldap24-sasl-client installed (which meets the LIBDEPENDS
requirement).  Changing to USE_OPENLDAP resolves the portmaster
confusion.
Comment 1 Edwin Groothuis freebsd_committer 2013-03-09 06:20:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Jung-uk Kim freebsd_committer 2013-03-11 18:16:36 UTC
State Changed
From-To: open->closed

Committed, thanks!
Comment 3 dfilter service freebsd_committer 2013-03-11 18:16:38 UTC
Author: jkim
Date: Mon Mar 11 18:16:26 2013
New Revision: 313924
URL: http://svnweb.freebsd.org/changeset/ports/313924

Log:
  Fix OpenLDAP dependency.
  
  PR:	ports/176776

Modified:
  head/editors/libreoffice/Makefile

Modified: head/editors/libreoffice/Makefile
==============================================================================
--- head/editors/libreoffice/Makefile	Mon Mar 11 18:01:08 2013	(r313923)
+++ head/editors/libreoffice/Makefile	Mon Mar 11 18:16:26 2013	(r313924)
@@ -37,7 +37,6 @@ LIB_DEPENDS=	icutu:${PORTSDIR}/devel/icu
 		poppler:${PORTSDIR}/graphics/poppler \
 		lpsolve55:${PORTSDIR}/math/lp_solve \
 		cmis-0.3:${PORTSDIR}/net/libcmis \
-		ldap-2.4:${PORTSDIR}/net/openldap24-client \
 		mspub-0.0:${PORTSDIR}/print/libmspub \
 		nss3.1:${PORTSDIR}/security/nss \
 		clucene-core:${PORTSDIR}/textproc/clucene \
@@ -65,6 +64,7 @@ MAKE_JOBS_UNSAFE=	yes
 USE_AUTOTOOLS=	autoconf aclocal
 USE_GL=		gl glu
 USE_GMAKE=	yes
+USE_OPENLDAP=	yes
 USE_PERL5_BUILD=	yes
 USE_PKGCONFIG=	build
 USE_PYTHON=	yes
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"