Bug 176827 - editors/libreoffice: Build failure on 10.0-CURRENT
Summary: editors/libreoffice: Build failure on 10.0-CURRENT
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-11 01:40 UTC by Glen Barber
Modified: 2013-03-13 21:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glen Barber freebsd_committer 2013-03-11 01:40:00 UTC
editors/libreoffice fails to compile on 10.0-CURRENT.

Fix: 

Unknown.
How-To-Repeat: Script started on Sun Mar 10 21:32:42 2013
root@nucleus:/usr/ports # make -C editors/libreoffice showconfig
===> The following configuration options are available for libreoffice-4.0.1:
     CUPS=off: CUPS printing system
     DEBUG=off: Install debug symbols
     GNOME=off: GNOME desktop environment
     GTK2=off: GTK+ 2 GUI toolkit
     GTK3=off: GTK+ 3 GUI toolkit
     JAVA=off: Add java support (XML Filters, macros)
     KDE4=on: KDE 4 desktop environment
     MERGELIBS=on: Enable linking of big merged library
     MMEDIA=off: Enable multimedia backend for impress
     PGSQL=off: Build with PostgreSQL-SDBC driver
     SDK=off: Build with SDK
     SYSTRAY=off: Enable systemtray quickstarter
     TEST=off: Run all regression tests
     WEBDAV=off: Enable webdav protocol
===> Use 'make config' to modify these settings
root@nucleus:/usr/ports # make -C editors/libreoffice
===>   libreoffice-4.0.1 depends on package: p5-Archive-Zip>=0 - found
===>   libreoffice-4.0.1 depends on executable: unzip - found
===>   libreoffice-4.0.1 depends on executable: zip - found
===>   libreoffice-4.0.1 depends on file: /usr/local/lib/libboost_regex.a - found
===>   libreoffice-4.0.1 depends on file: /usr/local/lib/libcppunit.so - found
===>   libreoffice-4.0.1 depends on executable: dmake - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/gperf - found
===>   libreoffice-4.0.1 depends on file: /usr/local/include/mdds/global.hpp - found
===>   libreoffice-4.0.1 depends on executable: gpatch - found
===>   libreoffice-4.0.1 depends on executable: ucpp - found
===>   libreoffice-4.0.1 depends on executable: vigra-config - found
===>   libreoffice-4.0.1 depends on executable: bash - found
===>   libreoffice-4.0.1 depends on executable: gsed - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/python2.7 - found
===>   libreoffice-4.0.1 depends on executable: bison - found
===>   libreoffice-4.0.1 depends on executable: gmake - found
===>   libreoffice-4.0.1 depends on executable: pkgconf - found
===>   libreoffice-4.0.1 depends on executable: gcc46 - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/as - found
===>   libreoffice-4.0.1 depends on file: /usr/local/libdata/pkgconfig/xaw7.pc - found
===>   libreoffice-4.0.1 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/moc-qt4 - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/qmake-qt4 - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/perl5.14.2 - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/automake-1.12 - found
===>   libreoffice-4.0.1 depends on file: /usr/local/bin/autoconf-2.69 - found
===>   libreoffice-4.0.1 depends on file: /usr/local/kde4/lib/libkdecore.so.7 - found
===>   libreoffice-4.0.1 depends on shared library: icutu - found
===>   libreoffice-4.0.1 depends on shared library: langtag - found
===>   libreoffice-4.0.1 depends on shared library: orcus-0.4 - found
===>   libreoffice-4.0.1 depends on shared library: curl.6 - found
===>   libreoffice-4.0.1 depends on shared library: cairo.2 - found
===>   libreoffice-4.0.1 depends on shared library: graphite2 - found
===>   libreoffice-4.0.1 depends on shared library: jpeg.11 - found
===>   libreoffice-4.0.1 depends on shared library: cdr - found
===>   libreoffice-4.0.1 depends on shared library: lcms2 - found
===>   libreoffice-4.0.1 depends on shared library: wpg-0.2.2 - found
===>   libreoffice-4.0.1 depends on shared library: png15 - found
===>   libreoffice-4.0.1 depends on shared library: poppler - found
===>   libreoffice-4.0.1 depends on shared library: lpsolve55 - found
===>   libreoffice-4.0.1 depends on shared library: cmis-0.3 - found
===>   libreoffice-4.0.1 depends on shared library: ldap-2.4 - found
===>   libreoffice-4.0.1 depends on shared library: mspub-0.0 - found
===>   libreoffice-4.0.1 depends on shared library: nss3.1 - found
===>   libreoffice-4.0.1 depends on shared library: clucene-core - found
===>   libreoffice-4.0.1 depends on shared library: expat.6 - found
===>   libreoffice-4.0.1 depends on shared library: hunspell-1.3.0 - found
===>   libreoffice-4.0.1 depends on shared library: hyphen.2 - found
===>   libreoffice-4.0.1 depends on shared library: exttextcat-2.0.0 - found
===>   libreoffice-4.0.1 depends on shared library: visio-0.0.0 - found
===>   libreoffice-4.0.1 depends on shared library: xml2.5 - found
===>   libreoffice-4.0.1 depends on shared library: xslt.2 - found
===>   libreoffice-4.0.1 depends on shared library: wpd-0.9.9 - found
===>   libreoffice-4.0.1 depends on shared library: wps-0.2.2 - found
===>   libreoffice-4.0.1 depends on shared library: mythes-1.2.0 - found
===>   libreoffice-4.0.1 depends on shared library: rdf.0 - found
===>   libreoffice-4.0.1 depends on shared library: GL.1 - found
===>   libreoffice-4.0.1 depends on shared library: GLU.1 - found
===>  Configuring for libreoffice-4.0.1
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.0.1.2/dmake/aclocal.m4
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.0.1.2/dmake/configure
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.0.1.2/dmake/acinclude.m4
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.0.1.2/configure
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.0.1.2/aclocal.m4
configure: WARNING: unrecognized options: --with-system-stdlibs, --with-qt-includes, --with-qt-libraries, --with-extra-libs, --with-extra-includes
********************************************************************
*
*   Running LibreOffice build configuration.
*
********************************************************************

checking build system type... amd64-portbld-freebsd10.0
checking host system type... amd64-portbld-freebsd10.0
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for grep... (cached) /usr/bin/grep
checking for sed... /usr/bin/sed
checking the FreeBSD operating system release... found OSVERSION=1000029
checking which thread library to use... -pthread
checking whether build target is Release Build... yes
checking whether to sign windows build... no
checking for gawk... gawk
checking for gawk... /usr/local/bin/gawk
checking for bash... /usr/local/bin/bash
checking for GNU or BSD tar... gtar
checking for tar's option to strip components... --strip-components
checking for ccache... /usr/local/bin/ccache
checking gcc home... /usr
checking for gcc... gcc46
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc46 accepts -g... yes
checking for gcc46 option to accept ISO C89... none needed
checking for gcc46... /usr/local/bin/gcc46
checking the GCC version... gcc 4.6.3
checking whether GCC is actually Clang... no
checking whether gcc46 supports -ggdb2... yes
checking whether gcc46 supports -finline-limit=0... yes
checking whether gcc46 supports -fno-inline... yes
checking for -Bsymbolic-functions linker support ... found 
checking whether gcc46 is already ccached... no
checking whether to build with additional debug utilities... no
checking whether to do a debug build... no
checking whether to include symbols while preserve optimization... no
checking for explicit CFLAGS... -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing
checking for explicit CXXFLAGS... -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46
checking for explicit OBJCFLAGS... no
checking for explicit OBJCXXFLAGS... no
checking for explicit LDFLAGS... -L/usr/local/lib -Wl,-rpath=/usr/local/lib/gcc46
checking which package format to use... native
checking whether to enable crashdump feature... no
checking whether to turn warnings to errors... no
checking whether to have assert to abort in release code... no
checking whether to use linkoo for the smoketest installation... no
checking whether to use link-time optimization... no
checking whether to enable CUPS support... no
checking pkg-config is at least version 0.9.0... yes
checking for FONTCONFIG... yes
checking whether we want to fetch tarballs... no
checking whether to build help... yes
checking whether to include MySpell dictionaries... no
checking whether to use dicts from external paths... yes
checking for spelling dictionary directory... file:///usr/local/share/hunspell
checking for hyphenation patterns directory... file:///usr/local/share/hyphen
checking for thesaurus directory... file:///usr/local/share/mythes
checking whether to enable pch feature... no, obsolete
checking for GNU make... gmake
checking the GNU make version... gmake 3.82
checking whether GNU make supports the 'file' function... no
checking for --hash-style gcc linker support ... gnu 
checking for perl... /usr/bin/perl
checking the Perl version... checked (perl 5)
checking for required Perl modules... all modules found
checking pkg-config is at least version 0.9.0... yes
checking for ar... /usr/local/bin/ar
checking for nm... /usr/local/bin/nm
checking for objdump... /usr/local/bin/objdump
checking for ranlib... /usr/local/bin/ranlib
checking for strip... strip
checking for ANSI C header files... yes
checking whether we are using the GNU C++ compiler... yes
checking whether g++46 accepts -g... yes
checking the GNU C++ compiler version... checked (g++ 4.6.3)
checking whether g++46 is already ccached... no
checking how to run the C++ preprocessor... cpp46
checking how to run the C preprocessor... cpp46
checking size of long... 8
checking size of short... 2
checking size of int... 4
checking size of long long... 8
checking size of double... 8
checking size of void*... 8
checking alignment of short... 2
checking alignment of int... 4
checking alignment of long... 8
checking alignment of double... 8
checking whether byte ordering is bigendian... no
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking whether /usr/local/bin/ccache g++46 supports thread safe statics... yes
checking whether /usr/local/bin/ccache gcc46 supports -fvisibility=hidden... yes
checking whether /usr/local/bin/ccache gcc46 supports -Wno-long-double... yes
checking whether /usr/local/bin/ccache gcc46 supports -mno-avx... yes
checking whether /usr/local/bin/ccache gcc46 supports atomic functions... yes
checking whether /usr/local/bin/ccache g++46 supports -std=gnu++0x without Language Defect 757... yes
checking whether /usr/local/bin/ccache g++46 supports C++11 perfect forwarding... yes
checking if STL headers are visibility safe (GCC bug 22482)... yes
checking if gcc is -fvisibility-inlines-hidden safe with STL headers... yes
checking if gcc is -fvisibility-inlines-hidden safe (Clang bug 11250)... yes
checking if gcc has a visibility bug with class-level attributes (GCC bug 26905)... no
checking if SFINAE is broken with anonymous types... no
checking whether /usr/local/bin/ccache g++46 supports -fno-default-inline... yes
checking whether /usr/local/bin/ccache g++46 supports -fno-enforce-eh-specs... yes
checking which memory allocator to use... system
checking for malloc... yes
checking for realloc... yes
checking for calloc... yes
checking for free... yes
checking for posix_fallocate... yes
checking whether to add custom build version... yes, FreeBSD ports r4.0.1
checking whether to build with Java support... no
checking for dmake... /usr/local/bin/dmake
checking whether the found dmake is the right dmake... yes
checking the dmake version... OK, >= 4.11
checking whether the found dmake is the right dmake... yes
checking the dmake version... OK, >= 4.11
checking which C preprocessor to use in idlc... ucpp
checking which ucpp tp use... external
checking for ucpp... /usr/local/bin/ucpp
checking whether to enable EPM for packing... no
checking for gperf... /usr/local/bin/gperf
checking gperf version... OK
checking whether to build the ODK... no
checking which zlib to use... external
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for deflate in -lz... yes
checking which jpeg to use... external
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking for jpeg_resync_to_restart in -ljpeg... yes
checking which clucene to use... external
checking for CLUCENE... yes
checking for CLucene/analysis/cjk/CJKAnalyzer.h... no
configure: error: Your version of libclucene has contribs-lib missing.
===>  Script "configure" failed unexpectedly.
Please report the problem to office@FreeBSD.org [maintainer] and attach the
"/usr/ports/editors/libreoffice/work/libreoffice-4.0.1.2/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.
root@nucleus:/usr/ports # ^D

Script done on Sun Mar 10 21:32:58 2013
Comment 1 Edwin Groothuis freebsd_committer 2013-03-11 01:40:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Glen Barber freebsd_committer 2013-03-13 21:06:09 UTC
State Changed
From-To: open->closed

This appears to have been due to a broken gcc46 install. 
Sorry for the noise.