Bug 176844 - New port: devel/p5-Data-Record
Summary: New port: devel/p5-Data-Record
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Martin Wilke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-11 10:30 UTC by espen
Modified: 2013-03-29 01:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description espen 2013-03-11 10:30:00 UTC
Sometimes we need data split into records and a simple split on the =
input record separator ($/) or some other value fails because the values =
we're splitting on may allowed in other parts of the data. Perhaps =
they're quoted. Perhaps they're embedded in other data which should not =
be split up. =20

This module allows you to specify what you wish to split the data on, =
but also speficy an "unless" regular expression. If the text in question =
matches the "unless" regex, it will not be split there. This allows us =
to do things like split on newlines unless newlines are embedded in =
quotes.
     =20

Fix: --Apple-Mail=_F17ADFA3-B6BB-43AB-9181-05D39BFCDBC8
Content-Disposition: attachment;
	filename=p5-Data-Record.shar
Content-Type: application/octet-stream;
	x-unix-mode=0644;
	name="p5-Data-Record.shar"
Content-Transfer-Encoding: 7bit



--Apple-Mail=_F17ADFA3-B6BB-43AB-9181-05D39BFCDBC8----eIU7VeFQBSOXhfktLOlDMwPtV3s4KPdCypYbDfh2gqYcHcN1
Content-Type: text/plain; name="file.shar"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.shar"

# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	p5-Data-Record
#	p5-Data-Record/pkg-plist
#	p5-Data-Record/pkg-descr
#	p5-Data-Record/Makefile
#	p5-Data-Record/distinfo
#
echo c - p5-Data-Record
mkdir -p p5-Data-Record > /dev/null 2>&1
echo x - p5-Data-Record/pkg-plist
sed 's/^X//' >p5-Data-Record/pkg-plist << '1e1c1a0133e9db237e36e77fd6885423'
X%%SITE_PERL%%/Data/Record.pm
X%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Record/.packlist
X@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Record
X@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
1e1c1a0133e9db237e36e77fd6885423
echo x - p5-Data-Record/pkg-descr
sed 's/^X//' >p5-Data-Record/pkg-descr << 'bcae6324042daa6f5340684208ebaf27'
XData::Record - "split" on steroids
X
XWWW: http://search.cpan.org/dist/Data-Record/
bcae6324042daa6f5340684208ebaf27
echo x - p5-Data-Record/Makefile
sed 's/^X//' >p5-Data-Record/Makefile << 'd095501734f90d51381b89a1ee1739e5'
XPORTNAME=	Data-Record
XPORTVERSION=	0.02
XCATEGORIES=	devel perl5
XMASTER_SITES=	CPAN
XPKGNAMEPREFIX=	p5-
X
XMAINTAINER=	espen@tagestad.no
XCOMMENT=	Data::Record - "split" on steroids
X
XRUN_DEPENDS=	\
X	p5-MRO-Compat>=0.09:${PORTSDIR}/devel/p5-MRO-Compat \
X	p5-Hash-Util-FieldHash-Compat>0:${PORTSDIR}/devel/p5-Hash-Util-FieldHash-Compat
XBUILD_DEPENDS:=	${RUN_DEPENDS} \
X	p5-ExtUtils-CBuilder>0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
XTEST_DEPENDS=	p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
X	p5-Scope-Guard>=0.20:${PORTSDIR}/devel/p5-Scope-Guard
X
XPERL_CONFIGURE=	yes
X
XMAN3=           Data::Record.3
X
X.include <bsd.port.mk>
d095501734f90d51381b89a1ee1739e5
echo x - p5-Data-Record/distinfo
sed 's/^X//' >p5-Data-Record/distinfo << '64471ff07cf2672efc240e56827f81ea'
XSHA256 (Data-Record-0.02.tar.gz) = 1d6ae66da2767520c21fbf12c538f1007ab27445d92c8eac763653f2b8849ebf
XSIZE (Data-Record-0.02.tar.gz) = 7029
64471ff07cf2672efc240e56827f81ea
exit
How-To-Repeat:         <code/input/activities to reproduce the problem (multiple =
lines)>
Comment 1 Edwin Groothuis freebsd_committer 2013-03-11 10:30:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->perl

perl@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Martin Wilke freebsd_committer 2013-03-11 13:04:45 UTC
Responsible Changed
From-To: perl->miwi

I'll take it.
Comment 3 dfilter service freebsd_committer 2013-03-29 01:31:53 UTC
Author: miwi
Date: Fri Mar 29 01:31:43 2013
New Revision: 315515
URL: http://svnweb.freebsd.org/changeset/ports/315515

Log:
  Data::Record - "split" on steroids
  
  WWW: http://search.cpan.org/dist/Data-Record/
  
  PR:		ports/176844
  Submitted by:	Espen Tagestad <espen@tagestad.no>

Added:
  head/devel/p5-Data-Record/
  head/devel/p5-Data-Record/Makefile   (contents, props changed)
  head/devel/p5-Data-Record/distinfo   (contents, props changed)
  head/devel/p5-Data-Record/pkg-descr   (contents, props changed)
  head/devel/p5-Data-Record/pkg-plist   (contents, props changed)
Modified:
  head/devel/Makefile

Modified: head/devel/Makefile
==============================================================================
--- head/devel/Makefile	Fri Mar 29 01:06:58 2013	(r315514)
+++ head/devel/Makefile	Fri Mar 29 01:31:43 2013	(r315515)
@@ -1697,6 +1697,7 @@
     SUBDIR += p5-Data-Rand-Obscure
     SUBDIR += p5-Data-Random
     SUBDIR += p5-Data-Range-Compare
+    SUBDIR += p5-Data-Record
     SUBDIR += p5-Data-Recursive-Encode
     SUBDIR += p5-Data-Remember
     SUBDIR += p5-Data-Rmap

Added: head/devel/p5-Data-Record/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-Data-Record/Makefile	Fri Mar 29 01:31:43 2013	(r315515)
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME=	Data-Record
+PORTVERSION=	0.02
+CATEGORIES=	devel perl5
+MASTER_SITES=	CPAN
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	espen@tagestad.no
+COMMENT=	Data::Record - "split" on steroids
+
+RUN_DEPENDS=	p5-MRO-Compat>=0.09:${PORTSDIR}/devel/p5-MRO-Compat \
+		p5-Hash-Util-FieldHash-Compat>0:${PORTSDIR}/devel/p5-Hash-Util-FieldHash-Compat
+BUILD_DEPENDS=	p5-MRO-Compat>=0.09:${PORTSDIR}/devel/p5-MRO-Compat \
+		p5-Hash-Util-FieldHash-Compat>0:${PORTSDIR}/devel/p5-Hash-Util-FieldHash-Compat \
+		p5-ExtUtils-CBuilder>0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
+TEST_DEPENDS=	p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+		p5-Scope-Guard>=0.20:${PORTSDIR}/devel/p5-Scope-Guard
+
+PERL_CONFIGURE=	yes
+
+MAN3=		Data::Record.3
+
+.include <bsd.port.mk>

Added: head/devel/p5-Data-Record/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-Data-Record/distinfo	Fri Mar 29 01:31:43 2013	(r315515)
@@ -0,0 +1,2 @@
+SHA256 (Data-Record-0.02.tar.gz) = 1d6ae66da2767520c21fbf12c538f1007ab27445d92c8eac763653f2b8849ebf
+SIZE (Data-Record-0.02.tar.gz) = 7029

Added: head/devel/p5-Data-Record/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-Data-Record/pkg-descr	Fri Mar 29 01:31:43 2013	(r315515)
@@ -0,0 +1,3 @@
+Data::Record - "split" on steroids
+
+WWW: http://search.cpan.org/dist/Data-Record/

Added: head/devel/p5-Data-Record/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-Data-Record/pkg-plist	Fri Mar 29 01:31:43 2013	(r315515)
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/Record.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Record/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Record
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Martin Wilke freebsd_committer 2013-03-29 01:32:07 UTC
State Changed
From-To: open->closed

- Committed thx