Bug 176888 - [PATCH] audio/sonata crashes since last devel/glib20 update
[PATCH] audio/sonata crashes since last devel/glib20 update
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gnome
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-12 18:30 UTC by yamagi
Modified: 2013-08-03 12:30 UTC (History)
0 users

See Also:


Attachments
file.diff (649 bytes, patch)
2013-03-12 18:30 UTC, yamagi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2013-03-12 18:30:00 UTC
Since the last devel/glib20 update audio/sonata crashes at startup with: GLib (gthread-posix.c): Unexpected error from C library during 'pthread_mutex_unlock': Operation not permitted.  Aborting.

Investigation showed that this is mainly caused by enabling GTK threading but still calling pyGTK function without holding the mutex. A simple solution is to desable GTK threading at all, sonata still works correct without it. An updated version of patch-sonata.py.

How-To-Repeat: Upgrade devel/glib20 to 2.34.3 and start sonata.
Comment 1 Edwin Groothuis freebsd_committer 2013-03-12 18:30:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nivit

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Koop Mast freebsd_committer 2013-07-15 21:00:50 UTC
State Changed
From-To: open->analyzed

Grab this is a bug as it is a devel/glib20. 


Comment 3 Koop Mast freebsd_committer 2013-07-15 21:00:50 UTC
Responsible Changed
From-To: nivit->gnome

Grab this is a bug as it is a devel/glib20.
Comment 4 dfilter freebsd_committer 2013-08-03 12:21:03 UTC
Author: kwm
Date: Sat Aug  3 11:20:55 2013
New Revision: 324188
URL: http://svnweb.freebsd.org/changeset/ports/324188

Log:
  Fix threading issue with glib20.
  
  PR:		ports/176888 (reported)
  Submitted by:	Yamagi Burmeister <yamagi@yamagi.org>
  Obtained from:	OpenBSD sonata port.

Added:
  head/audio/sonata/files/patch-sonata_main.py   (contents, props changed)
Modified:
  head/audio/sonata/Makefile

Modified: head/audio/sonata/Makefile
==============================================================================
--- head/audio/sonata/Makefile	Sat Aug  3 10:41:48 2013	(r324187)
+++ head/audio/sonata/Makefile	Sat Aug  3 11:20:55 2013	(r324188)
@@ -7,7 +7,7 @@
 
 PORTNAME=	sonata
 PORTVERSION=	1.6.2.1
-PORTREVISION=	7
+PORTREVISION=	8
 CATEGORIES=	audio python
 MASTER_SITES=	http://codingteam.net/project/sonata/upload/releases/
 

Added: head/audio/sonata/files/patch-sonata_main.py
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/audio/sonata/files/patch-sonata_main.py	Sat Aug  3 11:20:55 2013	(r324188)
@@ -0,0 +1,10 @@
+--- sonata/main.py.orig	2013-08-03 13:13:21.000000000 +0200
++++ sonata/main.py	2013-08-03 13:14:12.000000000 +0200
+@@ -3400,4 +3400,7 @@ class Base(object):
+ 		self.on_currsong_notify(force_popup=True)
+ 	
+ 	def main(self):
++		gtk.gdk.threads_init()
++		gtk.gdk.threads_enter()
+ 		gtk.main()
++		gtk.gdk.threads_leave()
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Koop Mast freebsd_committer 2013-08-03 12:21:08 UTC
State Changed
From-To: analyzed->closed

Committed a fix to the sonata port.