Bug 177211 - net-mgmt/cflowd: cflowd CflowdPacketQueue.cc fix
Summary: net-mgmt/cflowd: cflowd CflowdPacketQueue.cc fix
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-21 22:10 UTC by Juraj Lutter
Modified: 2014-06-02 12:40 UTC (History)
0 users

See Also:


Attachments
file.diff (712 bytes, patch)
2013-03-21 22:10 UTC, Juraj Lutter
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj Lutter freebsd_committer 2013-03-21 22:10:00 UTC
cflowd is unable to create semaphore with error:

Mar 21 02:23:11 ns2 cflowd[39539]: [E] semget(ftok("/usr/local/etc/cflowd.conf",0),2,S_IRWXU|S_IRWXG|S_IRWXO) failed to get semaphore set: Permission denied {CflowdPacketQueue.cc:125}

How-To-Repeat: compile cflowd and run.
Comment 1 John Marino freebsd_committer 2014-04-21 22:32:20 UTC
Responsible Changed
From-To: freebsd-ports-bugs->marino

I'll take it.
Comment 2 John Marino freebsd_committer 2014-06-02 12:19:51 UTC
won't fix.

I scheduled the port for deletion on 15 August 2014.
The port requires dozens of C++ patches to build on clang or modern C++.

After 10 years, there's never been a release; it's still in beta.
The original maintainer gave it up because he couldn't verify operation without netflow-speaking routers.

To save this port, a real maintainer with access to those type of routers needs to patch this software to work on clang and gcc 4.7+, and also provide stage support.
Comment 3 Juraj Lutter freebsd_committer 2014-06-02 12:40:48 UTC
Go ahead, I don't need it anymore :-)