Bug 177307 - x11/florence: [PATCH] fix breakage caused by glib2 update
x11/florence: [PATCH] fix breakage caused by glib2 update
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Kris Moore
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-23 11:10 UTC by draco
Modified: 2013-03-25 14:30 UTC (History)
0 users

See Also:


Attachments
file.diff (299 bytes, patch)
2013-03-23 11:10 UTC, draco
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description draco 2013-03-23 11:10:00 UTC
To restore the building of this port, add the attached patch to files/ with the name "patch-src_trace.c"

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-03-23 11:10:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->kmoore

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter freebsd_committer 2013-03-25 14:23:09 UTC
Author: kmoore
Date: Mon Mar 25 14:23:02 2013
New Revision: 315228
URL: http://svnweb.freebsd.org/changeset/ports/315228

Log:
  - Fix breakage caused by glib2 update
  
  PR: 177307
  Submitted by: John Marino <draco@marino.st>

Added:
  head/x11/florence/files/
  head/x11/florence/files/patch-src_trace.c   (contents, props changed)

Added: head/x11/florence/files/patch-src_trace.c
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11/florence/files/patch-src_trace.c	Mon Mar 25 14:23:02 2013	(r315228)
@@ -0,0 +1,12 @@
+--- src/trace.c.orig	2010-11-28 14:59:13.000000000 +0000
++++ src/trace.c
+@@ -22,9 +22,7 @@
+ #include "trace.h"
+ #include "system.h"
+ #include <glib/gprintf.h>
+-#include <glib/gutils.h>
+-#include <glib/gslist.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <stdio.h>
+ #include <stdarg.h>
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Kris Moore freebsd_committer 2013-03-25 14:23:32 UTC
State Changed
From-To: open->closed

Committed. Thanks!