Bug 177402 - [igb] [pf] problem with ethernet driver igb + pf / altq [regression]
Summary: [igb] [pf] problem with ethernet driver igb + pf / altq [regression]
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on: 194197
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-26 23:10 UTC by Rafael da Silva Espíndola
Modified: 2018-05-29 15:12 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael da Silva Espíndola 2013-03-26 23:10:00 UTC
The Freebsd 9 amd64 is presenting regression problems, the use of Packet
Filter with ALTQ accuses error if used a NIC igb. Already the Freebsd 8.3
works normally.

The error is this:
pfctl: igb0: driver does not support altq

Some data to conference:

Chipset Intel I350-CM2
igb0/igb1 (offboard)
Igb2/igb3 (onboard)

SERVIDOR IBM 7160B2U X3530 M4 XEON E5-2407 QC 2.2GHZ/10MB/1 X 4GB RDIMM

Server IBM: http://download.aldo.com.br/pdfprodutos/Produto24027IdArquivo1358.pdf

Dmesg:

igb0: <Intel(R) PRO/1000 Network Connection version - 2.3.9> mem 0x91b80000-0x91bfffff,0x91c04000-0x91c07fff irq 42 at device 0.0 on pci27
igb0: Using MSIX interrupts with 5 vectors
igb0: Ethernet address: 90:e2:ba:0d:b4:9c
igb0: Bound queue 0 to cpu 0
igb0: Bound queue 1 to cpu 1
igb0: Bound queue 2 to cpu 2
igb0: Bound queue 3 to cpu 3
igb1: <Intel(R) PRO/1000 Network Connection version - 2.3.9> mem 0x91b00000-0x91b7ffff,0x91c00000-0x91c03fff irq 45 at device 0.1 on pci27
igb1: Using MSIX interrupts with 5 vectors
igb1: Ethernet address: 90:e2:ba:0d:b4:9d
igb1: Bound queue 0 to cpu 0
igb1: Bound queue 1 to cpu 1
igb1: Bound queue 2 to cpu 2
igb1: Bound queue 3 to cpu 3
igb2: <Intel(R) PRO/1000 Network Connection version - 2.3.9> port 0x1020-0x103f mem 0x91a20000-0x91a3ffff,0x91ac4000-0x91ac7fff irq 16 at devic
e 0.0 on pci7
igb2: Using MSIX interrupts with 5 vectors
igb2: Ethernet address: 5c:f3:fc:3d:95:68
igb2: Bound queue 0 to cpu 0
igb2: Bound queue 1 to cpu 1
igb2: Bound queue 2 to cpu 2
igb2: Bound queue 3 to cpu 3
igb3: <Intel(R) PRO/1000 Network Connection version - 2.3.9> port 0x1000-0x101f mem 0x91a00000-0x91a1ffff,0x91a80000-0x91a83fff irq 17 at devic
e 0.1 on pci7
igb3: Using MSIX interrupts with 5 vectors
igb3: Ethernet address: 5c:f3:fc:3d:95:69
igb3: Bound queue 0 to cpu 0
igb3: Bound queue 1 to cpu 1
igb3: Bound queue 2 to cpu 2
igb3: Bound queue 3 to cpu 3

Pciconf:

igb0@pci0:27:0:0:       class=0x020000 card=0x12b28086 chip=0x15168086 rev=0x01 hdr=0x00
vendor     = 'Intel Corporation'
device     = '82580 Gigabit Network Connection'
class      = network
subclass   = ethernet
igb1@pci0:27:0:1:       class=0x020000 card=0x12b28086 chip=0x15168086 rev=0x01 hdr=0x00
vendor     = 'Intel Corporation'
device     = '82580 Gigabit Network Connection'
class      = network
subclass   = ethernet
igb2@pci0:7:0:0:        class=0x020000 card=0x15218086 chip=0x15218086 rev=0x01 hdr=0x00
vendor     = 'Intel Corporation'
device     = 'I350 Gigabit Network Connection'
class      = network
subclass   = ethernet
igb3@pci0:7:0:1:        class=0x020000 card=0x15218086 chip=0x15218086 rev=0x01 hdr=0x00
vendor     = 'Intel Corporation'
device     = 'I350 Gigabit Network Connection'
class      = network
subclass   = ethernet
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-03-27 01:43:37 UTC
Responsible Changed
From-To: freebsd-amd64->freebsd-net

Over to maintainer(s).
Comment 2 Sean Bruno freebsd_committer 2015-08-04 15:30:55 UTC
It looks like you need to compile with ALTQ *and* define IGB_LEGACY when you build the kernel.  This is related to a different bug that will turn IGB_LEGACY into a kernel tuneable.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:49:32 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.