Bug 177475 - devel/py-stevedore DOCS require X11
Summary: devel/py-stevedore DOCS require X11
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Nicola Vitale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-29 14:20 UTC by Jimmy Olgeni
Modified: 2013-08-30 01:10 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (546 bytes, patch)
2013-03-29 14:20 UTC, Jimmy Olgeni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy Olgeni freebsd_committer 2013-03-29 14:20:00 UTC
The devel/py-stevedore port requires X11 to build its documentation,
which makes it impossible to run a WITHOUT_X11 build.

By adding DOCS to OPTIONS_DEFINE we can leave docs out for this
port only.
Comment 1 Edwin Groothuis freebsd_committer 2013-03-29 14:20:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nivit

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-08-30 01:07:12 UTC
Author: nivit
Date: Fri Aug 30 00:07:01 2013
New Revision: 325641
URL: http://svnweb.freebsd.org/changeset/ports/325641

Log:
  - Update to 0.10
  - Trim Makefile header  [1]
  - Add LICENSE (AL2)
  - Add a regression-test target
  - Pass long options to BuildDoc command, so it is clear what they do
  - Define DOCS option  [1]
  - Remove files/patch-setup.py
  - Add files/patch-tox.ini
  
  Build log:	https://redports.org/buildarchive/20130829235200-19910/
  PR:	ports/177475  [1]
  Submitted by:	olgeni

Added:
  head/devel/py-stevedore/files/patch-tox.ini   (contents, props changed)
Deleted:
  head/devel/py-stevedore/files/patch-setup.py
Modified:
  head/devel/py-stevedore/Makefile
  head/devel/py-stevedore/distinfo
  head/devel/py-stevedore/pkg-plist   (contents, props changed)

Modified: head/devel/py-stevedore/Makefile
==============================================================================
--- head/devel/py-stevedore/Makefile	Thu Aug 29 23:02:09 2013	(r325640)
+++ head/devel/py-stevedore/Makefile	Fri Aug 30 00:07:01 2013	(r325641)
@@ -1,12 +1,8 @@
-# New ports collection makefile for:	py-stevedore
-# Date created:		2012-08-19
-# Whom:			Nicola Vitale <nivit@FreeBSD.org>
-#
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
 # $FreeBSD$
-#
 
 PORTNAME=	stevedore
-PORTVERSION=	0.8
+PORTVERSION=	0.10
 #PORTREVISION=	0
 CATEGORIES=	devel
 MASTER_SITES=	CHEESESHOP
@@ -15,8 +11,19 @@ PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
 MAINTAINER=	nivit@FreeBSD.org
 COMMENT=	Manage dynamic plugins for Python applications
 
+LICENSE=	AL2
+
+BUILD_DEPENDS=	${PKGNAMEPREFIX}argparse>=1.1:${PORTSDIR}/devel/py-argparse
+TEST_DEPENDS=	${PKGNAMEPREFIX}coverage>=3.5.3:${PORTSDIR}/devel/py-coverage \
+		${PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
+		${PKGNAMEPREFIX}nose>=1.3.0:${PORTSDIR}/devel/py-nose \
+		${PKGNAMEPREFIX}tox>=1.5.0:${PORTSDIR}/devel/py-tox
+
+OPTIONS_DEFINE=	DOCS
 OPTIONSFILE=	${PORT_DBDIR}/py-${PORTNAME}/options
 
+TOX_CMD=	${LOCALBASE}/bin/tox
+
 # Python3 ready
 USE_PYTHON=	yes
 USE_PYDISTUTILS=	easy_install
@@ -29,12 +36,19 @@ USE_PYDISTUTILS=	easy_install
 BUILD_DEPENDS+=	dot:${PORTSDIR}/graphics/graphviz \
 		sphinx-build:${PORTSDIR}/textproc/py-sphinx
 DOCSDIR=	${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
-PYDISTUTILS_BUILD_TARGET+=	build_sphinx -a -E
+PYDISTUTILS_BUILD_TARGET+=	build_sphinx --all-files --fresh-env
 
 post-install:
 	@cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${DOCSDIR}
 .endif
 
+regression-test: build
+	@cd ${WRKSRC} && \
+	${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
+		-e 's,%%PYTHON_SUFFIX%%,${PYTHON_SUFFIX},1' \
+		-e 's,%%WRKSRC%%,${WRKSRC},1' -i.bak tox.ini && \
+	${TOX_CMD}
+
 .if ${PYTHON_REL} >= 320
 .include "${PORTSDIR}/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc"
 .endif

Modified: head/devel/py-stevedore/distinfo
==============================================================================
--- head/devel/py-stevedore/distinfo	Thu Aug 29 23:02:09 2013	(r325640)
+++ head/devel/py-stevedore/distinfo	Fri Aug 30 00:07:01 2013	(r325641)
@@ -1,2 +1,2 @@
-SHA256 (stevedore-0.8.tar.gz) = bf187929f739f86a73ad218193d23bddb34c717c5adb6fd84008c2975043edb6
-SIZE (stevedore-0.8.tar.gz) = 94457
+SHA256 (stevedore-0.10.tar.gz) = 71a6ffb669c6d84ef0f43f44816257101775f955590986c29a95ce07293fd6e8
+SIZE (stevedore-0.10.tar.gz) = 338510

Added: head/devel/py-stevedore/files/patch-tox.ini
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-stevedore/files/patch-tox.ini	Fri Aug 30 00:07:01 2013	(r325641)
@@ -0,0 +1,20 @@
+--- ./tox.ini.orig	2013-06-12 17:01:04.000000000 +0200
++++ ./tox.ini	2013-08-30 01:41:41.000000000 +0200
+@@ -1,5 +1,5 @@
+ [tox]
+-envlist = py26,py27,py32,py33,style,docs
++envlist = py%%PYTHON_SUFFIX%%
+ 
+ [testenv]
+ distribute = False
+@@ -8,6 +8,10 @@
+     nose
+     mock
+     coverage
++setenv =
++    PYTHONPATH = %%WRKSRC%%
++sitepackages = True
++whitelist_externals = %%LOCALBASE%%/bin/nosetests
+ 
+ [testenv:style]
+ deps = flake8

Modified: head/devel/py-stevedore/pkg-plist
==============================================================================
--- head/devel/py-stevedore/pkg-plist	Thu Aug 29 23:02:09 2013	(r325640)
+++ head/devel/py-stevedore/pkg-plist	Fri Aug 30 00:07:01 2013	(r325641)
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
@@ -18,6 +17,27 @@
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/enabled.py
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/enabled.pyc
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/enabled.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/base.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/base.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/base.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/fields.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/fields.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/fields.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/load_as_driver.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/load_as_driver.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/load_as_driver.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/load_as_extension.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/load_as_extension.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/load_as_extension.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/setup.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/setup.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/setup.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/simple.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/simple.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example/simple.pyo
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/extension.py
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/extension.pyc
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/extension.pyo
@@ -42,6 +62,12 @@
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_enabled.py
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_enabled.pyc
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_enabled.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_example_fields.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_example_fields.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_example_fields.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_example_simple.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_example_simple.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_example_simple.pyo
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_extension.py
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_extension.pyc
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_extension.pyo
@@ -52,18 +78,30 @@
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_named.pyc
 %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests/test_named.pyo
 %%PORTDOCS%%%%DOCSDIR%%/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/_images/ceilometer-design.jpg
+%%PORTDOCS%%%%DOCSDIR%%/_images/discovery.jpg
+%%PORTDOCS%%%%DOCSDIR%%/_images/enabling.jpg
 %%PORTDOCS%%%%DOCSDIR%%/_images/graphviz-08fe6220bc1dbd26a74e2669d53a297aa22af2f3.png
 %%PORTDOCS%%%%DOCSDIR%%/_images/graphviz-08fe6220bc1dbd26a74e2669d53a297aa22af2f3.png.map
 %%PORTDOCS%%%%DOCSDIR%%/_images/graphviz-3af069098c975cf4ccc9b878bd4ecfce2f485b8b.png
 %%PORTDOCS%%%%DOCSDIR%%/_images/graphviz-3af069098c975cf4ccc9b878bd4ecfce2f485b8b.png.map
 %%PORTDOCS%%%%DOCSDIR%%/_images/graphviz-c58c2e8e4126e434dc2251649dea48f116f08b19.png
 %%PORTDOCS%%%%DOCSDIR%%/_images/graphviz-c58c2e8e4126e434dc2251649dea48f116f08b19.png.map
+%%PORTDOCS%%%%DOCSDIR%%/_images/importing.jpg
+%%PORTDOCS%%%%DOCSDIR%%/_images/integration.jpg
+%%PORTDOCS%%%%DOCSDIR%%/_images/invocation.jpg
+%%PORTDOCS%%%%DOCSDIR%%/_sources/essays/pycon2013.txt
 %%PORTDOCS%%%%DOCSDIR%%/_sources/history.txt
 %%PORTDOCS%%%%DOCSDIR%%/_sources/index.txt
 %%PORTDOCS%%%%DOCSDIR%%/_sources/install.txt
 %%PORTDOCS%%%%DOCSDIR%%/_sources/managers.txt
 %%PORTDOCS%%%%DOCSDIR%%/_sources/patterns_enabling.txt
 %%PORTDOCS%%%%DOCSDIR%%/_sources/patterns_loading.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/tutorial/creating_plugins.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/tutorial/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/tutorial/loading.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/tutorial/naming.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/tutorial/testing.txt
 %%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
 %%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
 %%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
@@ -84,6 +122,7 @@
 %%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
 %%PORTDOCS%%%%DOCSDIR%%/_static/up.png
 %%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/essays/pycon2013.html
 %%PORTDOCS%%%%DOCSDIR%%/genindex.html
 %%PORTDOCS%%%%DOCSDIR%%/history.html
 %%PORTDOCS%%%%DOCSDIR%%/index.html
@@ -94,11 +133,21 @@
 %%PORTDOCS%%%%DOCSDIR%%/patterns_loading.html
 %%PORTDOCS%%%%DOCSDIR%%/search.html
 %%PORTDOCS%%%%DOCSDIR%%/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/creating_plugins.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/index.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/loading.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/naming.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/testing.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tutorial
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/essays
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/_static
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/_sources/tutorial
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/_sources/essays
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/_sources
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/_images
 %%PORTDOCS%%@dirrm %%DOCSDIR%%
 @dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore/example
 @dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/stevedore
 @dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
 @dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Nicola Vitale freebsd_committer 2013-08-30 01:08:48 UTC
State Changed
From-To: open->closed

Committed, thanks!