Bug 177735 - [update] devel/rapidsvn 0.12.1
[update] devel/rapidsvn 0.12.1
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Jun Kuriyama
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-09 18:50 UTC by robert.ayrapetyan
Modified: 2013-05-19 17:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description robert.ayrapetyan 2013-04-09 18:50:00 UTC
Current version of RapidSVN in ports (0.12.0_3) is quite obsolete and contains fatal bugs in basic functionality (e.g. http://rapidsvn.tigris.org/ds/viewMessage.do?dsForumId=671&dsMessageId=2972891, this is a Fedora report but reproduces on FreeBSD as well). Issue was fixed in 0.12.1, which was released almost a year ago.
Prepared all necessary patches for upgrade.
- new Makefile;
- patch-doc-manpage-Makefile.am - patch for proper building of manpage.
If maintainer agree - may take future maintenance of this port.

Fix: 

Upgrade to version 0.12.1.
How-To-Repeat: 1. Launch rapidsvn;
2. Go to Bookmarks -> Add existing working copy;
3. Select existing local working copy;
4. App crashes.
Comment 1 Edwin Groothuis freebsd_committer 2013-04-09 19:24:31 UTC
Responsible Changed
From-To: freebsd-ports-bugs->kuriyama

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter freebsd_committer 2013-05-19 17:00:30 UTC
Author: kuriyama
Date: Sun May 19 16:00:22 2013
New Revision: 318540
URL: http://svnweb.freebsd.org/changeset/ports/318540

Log:
  - Upgrade to 0.12.1.
  - Pass to submitter.
  
  PR:		ports/177735
  Submitted by:	Robert Ayrapetyan <robert.ayrapetyan@gmail.com>

Added:
  head/devel/rapidsvn/files/patch-doc-manpage-Makefile.am   (contents, props changed)
Deleted:
  head/devel/rapidsvn/files/patch-aclocal.m4
Modified:
  head/devel/rapidsvn/Makefile
  head/devel/rapidsvn/distinfo

Modified: head/devel/rapidsvn/Makefile
==============================================================================
--- head/devel/rapidsvn/Makefile	Sun May 19 15:37:18 2013	(r318539)
+++ head/devel/rapidsvn/Makefile	Sun May 19 16:00:22 2013	(r318540)
@@ -6,17 +6,15 @@
 #
 
 PORTNAME=	rapidsvn
-PORTVERSION=	0.12.0
-PORTREVISION=	3
+PORTVERSION=	0.12.1
 CATEGORIES=	devel
-MASTER_SITES=	http://www.rapidsvn.org/download/release/0.12/
-DISTNAME=	${PORTNAME}-0.12.0-1
+MASTER_SITES=	http://www.rapidsvn.org/download/release/0.12.1/
+DISTNAME=	${PORTNAME}-0.12.1
 
-MAINTAINER=	kuriyama@FreeBSD.org
+MAINTAINER=	robert.ayrapetyan@gmail.com
 COMMENT=	Cross-platform GUI front-end for the Subversion revision system
 
-BUILD_DEPENDS=	neon-config:${PORTSDIR}/www/neon29 \
-		svn:${PORTSDIR}/devel/subversion \
+BUILD_DEPENDS=	svn:${PORTSDIR}/devel/subversion \
 		xsltproc:${PORTSDIR}/textproc/libxslt \
 		${LOCALBASE}/share/xsl/docbook/VERSION:${PORTSDIR}/textproc/docbook-xsl
 
@@ -31,19 +29,18 @@ CONFIGURE_ARGS=	--with-apr-config=apr-1-
 	--with-apu-config=apu-1-config \
 	--with-svn-include=${LOCALBASE}/include \
 	--with-svn-lib=${LOCALBASE}/lib \
-	--with-neon-config=neon-config \
 	--with-xsltproc=xsltproc \
 	--with-docbook-xsl-manpages=${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl \
 	--program-prefix="" \
+	--with-doxygen=no \
 	--with-manpage=yes
 
 USE_LDCONFIG=	yes
 MAN1=		rapidsvn.1
 AUTOTOOLSFILES=	aclocal.m4
 
-post-configure:
-	@${FIND} ${WRKSRC} -name Makefile -print | \
-		${XARGS} ${REINPLACE_CMD} -e 's|MKDIR_P|mkdir_p|'
+pre-configure:
+	@cd ${WRKSRC} && ${AUTORECONF}
 
 post-install:
 	${INSTALL_DATA} ${WRKSRC}/doc/manpage/rapidsvn.1 ${MAN1PREFIX}/man/man1/

Modified: head/devel/rapidsvn/distinfo
==============================================================================
--- head/devel/rapidsvn/distinfo	Sun May 19 15:37:18 2013	(r318539)
+++ head/devel/rapidsvn/distinfo	Sun May 19 16:00:22 2013	(r318540)
@@ -1,2 +1,2 @@
-SHA256 (rapidsvn-0.12.0-1.tar.gz) = ef7d0db528ba5c660f8e8ce4dd7b6d098707b43b04932257e092a6d4ab746ac4
-SIZE (rapidsvn-0.12.0-1.tar.gz) = 1246675
+SHA256 (rapidsvn-0.12.1.tar.gz) = 9744d2481b7e4db52adb0fa03806776463ed239ad39d09c807bc4c1198c4acae
+SIZE (rapidsvn-0.12.1.tar.gz) = 1087511

Added: head/devel/rapidsvn/files/patch-doc-manpage-Makefile.am
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/rapidsvn/files/patch-doc-manpage-Makefile.am	Sun May 19 16:00:22 2013	(r318540)
@@ -0,0 +1,11 @@
+--- doc/manpage/Makefile.am.orig	2013-04-09 01:49:54.889690090 -0700
++++ doc/manpage/Makefile.am	2013-04-09 01:50:04.529042731 -0700
+@@ -2,6 +2,8 @@
+ EXTRA_DIST=$(man_MANS) $(srcdir)/rapidsvn.xml
+ MAKEMAN=@XSLTPROC@ --nonet --novalid @DOCBOOK_MANPAGES@
+ 
++all: manpage
++
+ manpage: rapidsvn.1
+ 
+ rapidsvn.1: @TARGET_MANPAGE@
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Jun Kuriyama freebsd_committer 2013-05-19 17:03:19 UTC
State Changed
From-To: open->closed

Committed, thanks!