Bug 177774 - [patch] net/nbd-server update to 3.3
Summary: [patch] net/nbd-server update to 3.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Pawel Pekala
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-11 02:40 UTC by Hirohisa Yamaguchi
Modified: 2013-05-02 14:20 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (5.78 KB, patch)
2013-04-11 02:40 UTC, Hirohisa Yamaguchi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hirohisa Yamaguchi 2013-04-11 02:40:00 UTC
	The new version of net/nbd-server 3.3 is now available
	 http://sourceforge.net/projects/nbd/files/nbd/3.3/

	This is a revised patch from which I've sent as a follow-up to ports/177626.

Fix: The patch follows:

M       net/nbd-server/Makefile
M       net/nbd-server/distinfo
D       net/nbd-server/files/nbd.h
A       net/nbd-server/files/patch-cliserv.h
M       net/nbd-server/files/patch-nbd-server.c
How-To-Repeat: 	N/A
Comment 1 Pawel Pekala freebsd_committer 2013-05-02 13:45:44 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pawel

I'll take it.
Comment 2 dfilter service freebsd_committer 2013-05-02 14:15:07 UTC
Author: pawel
Date: Thu May  2 13:14:54 2013
New Revision: 317110
URL: http://svnweb.freebsd.org/changeset/ports/317110

Log:
  Update to version 3.3
  
  PR:		ports/177774
  Submitted by:	Hirohisa Yamaguchi <umq@ueo.co.jp>

Added:
  head/net/nbd-server/files/patch-cliserv.h   (contents, props changed)
Deleted:
  head/net/nbd-server/files/nbd.h
Modified:
  head/net/nbd-server/Makefile
  head/net/nbd-server/distinfo   (contents, props changed)
  head/net/nbd-server/files/patch-nbd-server.c   (contents, props changed)

Modified: head/net/nbd-server/Makefile
==============================================================================
--- head/net/nbd-server/Makefile	Thu May  2 13:10:23 2013	(r317109)
+++ head/net/nbd-server/Makefile	Thu May  2 13:14:54 2013	(r317110)
@@ -1,13 +1,12 @@
 # Created by: Christian Laursen <xi@borderworlds.dk>
 # $FreeBSD$
 
-PORTNAME=	nbd-server
-PORTVERSION=	2.8.5
-PORTREVISION=	1
+PORTNAME=	nbd
+PORTVERSION=	3.3
 PORTEPOCH=	1
 CATEGORIES=	net
-MASTER_SITES=	SF/nbd/nbd/${PORTVERSION}
-DISTNAME=	nbd-${PORTVERSION}
+MASTER_SITES=	SF
+PKGNAMESUFFIX=	-server
 
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Server for the Linux network block device (nbd)
@@ -16,12 +15,14 @@ USE_BZIP2=	yes
 USE_GNOME=	glib20
 USES=		pkgconfig
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--prefix=${PREFIX} --enable-lfs --enable-syslog
+CONFIGURE_ARGS=	--enable-lfs --enable-syslog
 
-PLIST_FILES=	bin/nbd-server
-MAN1=		nbd-server.1
+PLIST_FILES=	bin/nbd-server bin/nbd-trdump
+MAN1=		nbd-server.1 nbd-trdump.1
+MAN5=		nbd-server.5
+MAN8=		nbd-client.8
 
-post-extract:
-	@${CP} ${FILESDIR}/nbd.h ${WRKSRC}
+regression-test: build
+		cd ${WRKSRC} && ${MAKE} check
 
 .include <bsd.port.mk>

Modified: head/net/nbd-server/distinfo
==============================================================================
--- head/net/nbd-server/distinfo	Thu May  2 13:10:23 2013	(r317109)
+++ head/net/nbd-server/distinfo	Thu May  2 13:14:54 2013	(r317110)
@@ -1,2 +1,2 @@
-SHA256 (nbd-2.8.5.tar.bz2) = dc77166f086712fa0d1ff63997d487d99eaac238819b1aebff9a8fddfcc0b835
-SIZE (nbd-2.8.5.tar.bz2) = 151053
+SHA256 (nbd-3.3.tar.bz2) = 83105718dcab9eee7ea152d6e5f4928095f0d3e21dcf92e43eef183e29a80c19
+SIZE (nbd-3.3.tar.bz2) = 515909

Added: head/net/nbd-server/files/patch-cliserv.h
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/net/nbd-server/files/patch-cliserv.h	Thu May  2 13:14:54 2013	(r317110)
@@ -0,0 +1,11 @@
+--- ./cliserv.h.orig	2012-05-25 17:09:16.000000000 +0900
++++ ./cliserv.h	2013-04-04 19:36:34.000000000 +0900
+@@ -15,6 +15,8 @@
+ #include <netinet/tcp.h>
+ #include <netinet/in.h>
+ #include <stdlib.h>
++#include <sys/types.h>
++#include <sys/socket.h>
+ 
+ #if SIZEOF_UNSIGNED_SHORT_INT==4
+ typedef unsigned short u32;

Modified: head/net/nbd-server/files/patch-nbd-server.c
==============================================================================
--- head/net/nbd-server/files/patch-nbd-server.c	Thu May  2 13:10:23 2013	(r317109)
+++ head/net/nbd-server/files/patch-nbd-server.c	Thu May  2 13:14:54 2013	(r317110)
@@ -1,18 +1,10 @@
-diff -urN nbd-2.8.3.orig/nbd-server.c nbd-2.8.3/nbd-server.c
---- nbd-2.8.3.orig/nbd-server.c	Thu Dec 22 21:37:20 2005
-+++ nbd-server.c	Sun Jan  8 16:45:30 2006
-@@ -363,12 +363,12 @@
-  * is severely wrong)
-  **/
- void sigchld_handler(int s) {
--        int* status=NULL;
-+        int status;
- 	int* i;
- 	pid_t pid;
- 	int done=0;
- 
--	while(!done && (pid=wait(status)) > 0) {
-+	while(!done && (pid=wait(&status)) > 0) {
- 		if(WIFEXITED(status)) {
- 			msg3(LOG_INFO, "Child exited with %d", WEXITSTATUS(status));
- 			msg3(LOG_INFO, "pid is %d", pid);
+--- ./nbd-server.c.orig	2012-07-04 05:54:53.000000000 +0900
++++ ./nbd-server.c	2013-04-04 19:36:34.000000000 +0900
+@@ -72,6 +72,7 @@
+ #ifdef HAVE_SYS_MOUNT_H
+ #include <sys/mount.h>
+ #endif
++#include <sys/uio.h>
+ #include <signal.h>
+ #include <errno.h>
+ #include <netinet/tcp.h>
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Pawel Pekala freebsd_committer 2013-05-02 14:15:08 UTC
State Changed
From-To: open->closed

Committed. Thanks!