Bug 177949 - [ports] devel/flatzebra 0.1.6 regression on ia64
Summary: [ports] devel/flatzebra 0.1.6 regression on ia64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ganael LAPLANCHE
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-18 09:40 UTC by mexas
Modified: 2013-06-07 11:10 UTC (History)
0 users

See Also:


Attachments
patch-flatzebra.txt (1.36 KB, patch)
2013-06-07 08:01 UTC, Ganael LAPLANCHE
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mexas 2013-04-18 09:40:00 UTC
# svn info
Path: .
Working Copy Root Path: /usr/ports
URL: svn://svn0.us-east.freebsd.org/ports/head/devel/flatzebra
Repository Root: svn://svn0.us-east.freebsd.org/ports
Repository UUID: 35697150-7ecd-e111-bb59-0022644237b5
Revision: 316015
Node Kind: directory
Schedule: normal
Last Changed Author: martymac
Last Changed Rev: 315963
Last Changed Date: 2013-04-17 14:02:44 +0100 (Wed, 17 Apr 2013)

# 

# pkg version -vX flat
flatzebra-0.1.5_2                  <   needs updating (port has 0.1.6)
# 

===>  Building for flatzebra-0.1.6
Making all in src
Making all in flatzebra
/bin/sh /usr/local/bin/libtool  --tag=CXX   --mode=compile c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"flatzebra\" -DVERSION=\"0.1.6\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -I.    -I/usr/local/include/SDL -I/usr/local/include -D_GNU_SOURCE=1 -D_REENTRANT  -I../../src -O2 -pipe -fno-strict-aliasing -W -Wall -MT libflatzebra_0_1_la-RCouple.lo -MD -MP -MF .deps/libflatzebra_0_1_la-RCouple.Tpo -c -o libflatzebra_0_1_la-RCouple.lo `test -f 'RCouple.cpp' || echo './'`RCouple.cpp
libtool: compile:  c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"flatzebra\" -DVERSION=\"0.1.6\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -I. -I/usr/local/include/SDL -I/usr/local/include -D_GNU_SOURCE=1 -D_REENTRANT -I../../src -O2 -pipe -fno-strict-aliasing -W -Wall -MT libflatzebra_0_1_la-RCouple.lo -MD -MP -MF .deps/libflatzebra_0_1_la-RCouple.Tpo -c RCouple.cpp  -fPIC -DPIC -o .libs/libflatzebra_0_1_la-RCouple.o
RCouple.cpp:28: error: 'const double flatzebra::RCouple::tolerance' is not a static member of 'class flatzebra::RCouple'
RCouple.cpp:35: error: no 'bool flatzebra::RCouple::rectangleCollision(const flatzebra::RCouple&, const flatzebra::RCouple&, const flatzebra::RCouple&, const flatzebra::RCouple&)' member function declared in class 'flatzebra::RCouple'
RCouple.cpp:51: error: no 'flatzebra::RCouple flatzebra::RCouple::getClosestPointOnSegment(const flatzebra::RCouple&, const flatzebra::RCouple&) const' member function declared in class 'flatzebra::RCouple'
RCouple.cpp: In member function 'flatzebra::RCouple flatzebra::RCouple::getClosestPointOnSegment(const flatzebra::RCouple&, const flatzebra::RCouple&) const':
RCouple.cpp:53: error: 'assert' was not declared in this scope
RCouple.cpp:56: error: 'class flatzebra::RCouple' has no member named 'dotProduct'
RCouple.cpp:56: error: 'class flatzebra::RCouple' has no member named 'dotProduct'
RCouple.cpp: At global scope:
RCouple.cpp:67: error: no 'bool flatzebra::RCouple::isOnSegment(const flatzebra::RCouple&, const flatzebra::RCouple&) const' member function declared in class 'flatzebra::RCouple'
RCouple.cpp: In member function 'bool flatzebra::RCouple::isOnSegment(const flatzebra::RCouple&, const flatzebra::RCouple&) const':
RCouple.cpp:69: error: 'assert' was not declared in this scope
RCouple.cpp:72: error: 'class flatzebra::RCouple' has no member named 'dotProduct'
RCouple.cpp:72: error: 'class flatzebra::RCouple' has no member named 'dotProduct'
*** [libflatzebra_0_1_la-RCouple.lo] Error code 1

Stop in /usr/ports/devel/flatzebra/work/flatzebra-0.1.6/src/flatzebra.
*** [all-recursive] Error code 1
Comment 1 Edwin Groothuis freebsd_committer 2013-04-18 09:40:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->edwin

edwin@mavetju.org => edwin@ (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2013-04-18 09:40:11 UTC
Maintainer of devel/flatzebra,

Please note that PR ports/177949 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/177949

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2013-04-18 09:40:12 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 mexas 2013-04-22 22:25:43 UTC
It fails to build on amd64/clang too:

===>  Building for flatzebra-0.1.6
Making all in src
Making all in flatzebra
/bin/sh /usr/local/bin/libtool  --tag=CXX   --mode=compile c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"flatzebra\" -DVERSION=\"0.1.6\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -I.    -I/usr/local/include/SDL -I/usr/local/ include -D_GNU_SOURCE=1 -D_REENTRANT  -I../../src -O2 -pipe -fno-strict-aliasing -W -Wall -MT libflatzebra_0_1_la-RCouple.lo -MD -MP -MF .deps/libflatzebra_0_1_la-RCouple.Tpo -c -o libflatzebra_0_1_la-RCouple.lo `test -f 'RCouple.cpp' || echo './'`RCouple.cpp
libtool: compile:  c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"flatzebra\" -DVERSION=\"0.1.6\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -I. -I/usr/local/include/SDL -I/usr/local/include -D_GNU_SOURCE=1 -D_REENTRANT -I../. ./src -O2 -pipe -fno-strict-aliasing -W -Wall -MT libflatzebra_0_1_la-RCouple.lo -MD -MP -MF .deps/libflatzebra_0_1_la-RCouple.Tpo -c RCouple.cpp  -fPIC -DPIC -o .libs/libflatzebra_0_1_la-RCouple.o
RCouple.cpp:28:23: error: no member named 'tolerance' in 'flatzebra::RCouple'
const double RCouple::tolerance = 0.0001;
             ~~~~~~~~~^
RCouple.cpp:32:10: error: out-of-line definition of 'rectangleCollision' does not match any
      declaration in 'flatzebra::RCouple'
RCouple::rectangleCollision(const RCouple &pos1,
         ^~~~~~~~~~~~~~~~~~
RCouple.cpp:50:10: error: out-of-line definition of 'getClosestPointOnSegment' does not match any
      declaration in 'flatzebra::RCouple'
RCouple::getClosestPointOnSegment(const RCouple &segStart,
         ^~~~~~~~~~~~~~~~~~~~~~~~
RCouple.cpp:53:5: error: use of undeclared identifier 'assert'
    assert(segStart != segEnd);  // this condition avoids division by zero
    ^
RCouple.cpp:56:20: error: no member named 'dotProduct' in 'flatzebra::RCouple'
    double t = seg.dotProduct(c) / seg.dotProduct(seg);  // project pt on segment
               ~~~ ^
RCouple.cpp:56:40: error: no member named 'dotProduct' in 'flatzebra::RCouple'
    double t = seg.dotProduct(c) / seg.dotProduct(seg);  // project pt on segment
                                   ~~~ ^
RCouple.cpp:66:10: error: out-of-line definition of 'isOnSegment' does not match any declaration in
      'flatzebra::RCouple'
RCouple::isOnSegment(const RCouple &segStart,
         ^~~~~~~~~~~
RCouple.cpp:69:5: error: use of undeclared identifier 'assert'
    assert(segStart != segEnd);  // this condition avoids division by zero
    ^
RCouple.cpp:72:20: error: no member named 'dotProduct' in 'flatzebra::RCouple'
    double t = seg.dotProduct(c) / seg.dotProduct(seg);  // project pt on segment
               ~~~ ^
RCouple.cpp:72:40: error: no member named 'dotProduct' in 'flatzebra::RCouple'
    double t = seg.dotProduct(c) / seg.dotProduct(seg);  // project pt on segment
                                   ~~~ ^
10 errors generated.
*** [libflatzebra_0_1_la-RCouple.lo] Error code 1

Stop in /usr/ports/devel/flatzebra/work/flatzebra-0.1.6/src/flatzebra.
*** [all-recursive] Error code 1
Comment 5 Ganael LAPLANCHE freebsd_committer 2013-06-07 08:01:55 UTC
Hi Anton, Edwin,

This is due to headers from previous version being included before
headers from the version being built.

Could you try the attached patch and tell me if it fixes the problem ? I
could reproduce the problem and the patch fixed it.

Edwin, is the patch OK for you (can I commit it) ?

Thanks,
Best regards,

--
Ganael LAPLANCHE <ganael.laplanche@martymac.org>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <martymac@FreeBSD.org>, http://www.FreeBSD.org
Comment 6 Ganael LAPLANCHE freebsd_committer 2013-06-07 10:55:10 UTC
Responsible Changed
From-To: edwin->martymac

I will take care of it.
Comment 7 dfilter freebsd_committer 2013-06-07 11:00:34 UTC
Author: martymac
Date: Fri Jun  7 10:00:26 2013
New Revision: 320189
URL: http://svnweb.freebsd.org/changeset/ports/320189

Log:
  Fix build when upgrading from previous version
  
  PR:		ports/177949
  Submitted by:	Anton Shterenlikht <mexas@bris.ac.uk>
  Approved by:	maintainer timeout (7 weeks)

Modified:
  head/devel/flatzebra/Makefile
  head/devel/flatzebra/files/patch-src-flatzebra-Makefile.in   (contents, props changed)

Modified: head/devel/flatzebra/Makefile
==============================================================================
--- head/devel/flatzebra/Makefile	Fri Jun  7 08:57:04 2013	(r320188)
+++ head/devel/flatzebra/Makefile	Fri Jun  7 10:00:26 2013	(r320189)
@@ -3,6 +3,7 @@
 
 PORTNAME=	flatzebra
 PORTVERSION=	0.1.6
+PORTREVISION=	1
 CATEGORIES=	devel games
 MASTER_SITES=	http://perso.b2b2c.ca/sarrazip/dev/
 

Modified: head/devel/flatzebra/files/patch-src-flatzebra-Makefile.in
==============================================================================
--- head/devel/flatzebra/files/patch-src-flatzebra-Makefile.in	Fri Jun  7 08:57:04 2013	(r320188)
+++ head/devel/flatzebra/files/patch-src-flatzebra-Makefile.in	Fri Jun  7 10:00:26 2013	(r320189)
@@ -1,6 +1,6 @@
---- src/flatzebra/Makefile.in.orig	2009-08-21 08:57:35.167862535 +0000
-+++ src/flatzebra/Makefile.in	2009-08-21 08:58:09.594287891 +0000
-@@ -96,7 +96,7 @@
+--- src/flatzebra/Makefile.in.orig	2012-07-14 05:41:48.000000000 +0200
++++ src/flatzebra/Makefile.in	2013-06-06 16:56:34.000000000 +0200
+@@ -120,7 +120,7 @@
  ETAGS = etags
  CTAGS = ctags
  DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
@@ -9,3 +9,14 @@
  ACLOCAL = @ACLOCAL@
  AMTAR = @AMTAR@
  API = @API@
+@@ -274,8 +274,8 @@
+ 	font_13x7.xpm
+ 
+ libflatzebra_0_1_la_CXXFLAGS = \
+-	$(SDL_CFLAGS) \
+-	-I$(top_srcdir)/src
++	-I$(top_srcdir)/src \
++	$(SDL_CFLAGS)
+ 
+ libflatzebra_0_1_la_LIBADD = \
+ 	$(SDL_LIBS)
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 8 Ganael LAPLANCHE freebsd_committer 2013-06-07 11:01:02 UTC
State Changed
From-To: feedback->closed

Committed, thanks!