Bug 177991 - astro/qlandkartegt : upgrade to 1.7.0
Summary: astro/qlandkartegt : upgrade to 1.7.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-20 15:00 UTC by Christoph Moench-Tegeder
Modified: 2013-08-22 13:20 UTC (History)
0 users

See Also:


Attachments
file.diff (1.96 KB, patch)
2013-04-20 15:00 UTC, Christoph Moench-Tegeder
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2013-04-20 15:00:01 UTC
	Included patch updated astro/qlandkartegt to version 1.7.0.
	While at it, I took the liberty of removing the wrapper script added
	three years ago (ports/142915 r242007): currently, the workaround
	in this wrapper rather causes problems on my machine, which indeed
	uses the x11/nvidia-driver (current version, see above) while
	removing the "workaround" make qlandkartegt run just fine. Note:
	I cannot test this change with the "legacy" versions of x1/nvidia-driver-*

Fix: Note removed file astro/qlandkartegt/files/qlandkartegt.in
	Diff via http: http://burggraben.net/hacks/astro_qlandkartegt.diff.gz
How-To-Repeat: 	N/A
Comment 1 Edwin Groothuis freebsd_committer 2013-04-20 15:00:08 UTC
Maintainer of astro/qlandkartegt,

Please note that PR ports/177991 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/177991

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2013-04-20 15:00:09 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Felippe de Meirelles Motta freebsd_committer 2013-07-03 23:45:54 UTC
Submitter, since this patch will remove the bin/qlandkartegt and maybe
someone use it, could you consider an note on UPDATING to alert users
significant changes after this upgrade?

Thanks
lippe@
Comment 4 Christoph Moench-Tegeder freebsd_committer 2013-07-04 07:29:09 UTC
## Felippe de Meirelles Motta (lippe@FreeBSD.org):

> Submitter, since this patch will remove the bin/qlandkartegt and maybe
> someone use it, could you consider an note on UPDATING to alert users
> significant changes after this upgrade?

Uhm, no (I just checked again in case I messed up).
I dropped the wrapper script and put the original qlandkartegt executable
(which was renamed to qlandkartegt.bin before) in it's place. That's how
it was intended before we (FreeBSD, that is, the original maintainer)
introduced the wrapper script. As already noted in the PR, the wrapper
caused problems for me when using nvidia graphics (but the wrapper was
apparently for working around problems with the nvidia driver, so I guess
_that_ problem has been fixed in the meantime), and qlandkartegt works
just fine out-of-the-box without the wrapper on nvidia and intel graphics.
So I decided to just drop the wrapper and have qlandkartegt executed
directly.
This is how it looks now:
cmt@reindeer:qlandkartegt$ ls -lh /usr/local/bin/qlandkartegt*
-rwxr-xr-x  1 root  wheel     8M Jul  4 08:17 /usr/local/bin/qlandkartegt

Hope that clarifies my intentions?

Regards,
Christoph

-- 
Spare Space
Comment 5 Christoph Moench-Tegeder freebsd_committer 2013-07-17 19:44:00 UTC
As there's already the next update to qlandkartegt out
( http://article.gmane.org/gmane.comp.gis.qlandkartegt.user/1226 ),
i took the liberty to update the patch to match the current port and
the new qlandkartegt release at once.

Patch via HTTP: http://burggraben.net/hacks/astro_qlandkartegt.diff.gz
and enclosed:

$ svn status
M       Makefile
M       distinfo
D       files/qlandkartegt.in
M       pkg-plist

(note deleted file, as already discussed in this PR)

Index: Makefile
===================================================================
--- Makefile	(revision 323181)
+++ Makefile	(working copy)
@@ -2,8 +2,7 @@
 # $FreeBSD$
 
 PORTNAME=	qlandkartegt
-PORTVERSION=	1.5.1
-PORTREVISION=	1
+PORTVERSION=	1.7.1
 CATEGORIES=	astro
 MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}/QLandkarteGT%20${PORTVERSION}
 
@@ -10,7 +9,7 @@
 MAINTAINER=	i@levsha.me
 COMMENT=	The ultimate outdoor aficionado's tool
 
-LICENSE=	GPLv2
+LICENSE=	GPLv3
 
 LIB_DEPENDS=	gdal:${PORTSDIR}/graphics/gdal \
 		proj:${PORTSDIR}/graphics/proj \
@@ -22,12 +21,6 @@
 USE_GL=		glu
 MAKE_JOBS_SAFE=	yes
 
-SUB_FILES=	qlandkartegt
-
 MAN1=		qlandkartegt.1
 
-post-install:
-	${MV} ${PREFIX}/bin/qlandkartegt ${PREFIX}/bin/qlandkartegt.bin
-	${INSTALL_SCRIPT} ${WRKDIR}/qlandkartegt ${PREFIX}/bin
-
 .include <bsd.port.mk>
Index: distinfo
===================================================================
--- distinfo	(revision 323181)
+++ distinfo	(working copy)
@@ -1,2 +1,2 @@
-SHA256 (qlandkartegt-1.5.1.tar.gz) = 095cd2390684eead61b2868e1efc85500d6d61e95f3d54d0fd255cd95f55aadd
-SIZE (qlandkartegt-1.5.1.tar.gz) = 7113881
+SHA256 (qlandkartegt-1.7.1.tar.gz) = 156ae80bda0e7004f63867f0880b8737fb4e175388fc9edf6d541f2901686737
+SIZE (qlandkartegt-1.7.1.tar.gz) = 8390094
Index: files/qlandkartegt.in
===================================================================
--- files/qlandkartegt.in	(revision 323181)
+++ files/qlandkartegt.in	(working copy)
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-if ( ldd %%LOCALBASE%%/lib/libGL.so | fgrep -Fq libnvidia )
-then
-	LD_PRELOAD="$(ls %%LOCALBASE%%/lib/XXX-libGL.so.*.%%.libGL-*|tail -1)"
-	export LD_PRELOAD
-fi
-
-%%PREFIX%%/bin/qlandkartegt.bin
-
Index: pkg-plist
===================================================================
--- pkg-plist	(revision 323181)
+++ pkg-plist	(working copy)
@@ -1,8 +1,9 @@
 bin/cache2gtiff
 bin/map2gcm
+bin/map2jnx
 bin/map2rmap
+bin/map2rmp
 bin/qlandkartegt
-bin/qlandkartegt.bin
 share/applications/qlandkartegt.desktop
 share/pixmaps/qlandkartegt.png
 %%DATADIR%%/translations/qlandkartegt_cs.qm
@@ -14,5 +15,5 @@
 %%DATADIR%%/translations/qlandkartegt_nl.qm
 %%DATADIR%%/translations/qlandkartegt_ru.qm
 @dirrm %%DATADIR%%/translations
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%
 @dirrmtry share/applications


Regards,,
Christoph

-- 
Spare Space
Comment 6 Max Brazhnikov freebsd_committer 2013-08-22 13:20:44 UTC
State Changed
From-To: feedback->closed

Superseded by ports/181381