Bug 178220 - print/a2ps: ===> Applying FreeBSD patches for a2ps-4.13b_5 2 out of 2 hunks failed--saving rejects to Makefile.in.rej
Summary: print/a2ps: ===> Applying FreeBSD patches for a2ps-4.13b_5 2 out of 2 hunks ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-28 15:10 UTC by O. Hartmann
Modified: 2013-05-13 14:58 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2013-04-28 15:10:00 UTC
The update port print/a2ps fails due to the follwoing error message:

===>>> All >> print/a2ps (1/2)

===>  Cleaning for a2ps-4.13b_5
===>  License GPLv2 accepted by the user
===>  Found saved configuration for a2ps-4.13b_5
===>   a2ps-4.13b_5 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by a2ps-4.13b_5 for building
===>  Extracting for a2ps-4.13b_5
=> SHA256 Checksum OK for a2ps-4.13b.tar.gz.
=> SHA256 Checksum OK for i18n-fonts-0.1.tar.gz.
===>   a2ps-4.13b_5 depends on file: /usr/local/bin/perl5.16.2 - found
===>  Patching for a2ps-4.13b_5
===>   a2ps-4.13b_5 depends on file: /usr/local/bin/perl5.16.2 - found
===>  Applying FreeBSD patches for a2ps-4.13b_5
2 out of 2 hunks failed--saving rejects to Makefile.in.rej
=> Patch patch-contrib-emacs-Makefile.in failed to apply cleanly.
=> Patch(es) patch-ad patch-ae applied cleanly.
*** [do-patch] Error code 1

Stop in /usr/ports/print/a2ps.
*** [build] Error code 1

Stop in /usr/ports/print/a2ps.

===>>> make failed for print/a2ps
===>>> Aborting update

===>>> Update for print/a2ps failed
===>>> Aborting update

===>>> Killing background jobs
Terminated
Comment 1 Edwin Groothuis freebsd_committer 2013-04-28 15:10:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Dirk Meyer freebsd_committer 2013-05-01 09:46:59 UTC
State Changed
From-To: open->feedback



I can not reproduce your error. 

builds fine on 8.3 and 9.1. 

I have no CURRENT to test on. 
Your ports tree might be inconsitent.
Comment 3 dfilter service freebsd_committer 2013-05-02 20:34:58 UTC
Author: dinoex
Date: Thu May  2 19:34:48 2013
New Revision: 317141
URL: http://svnweb.freebsd.org/changeset/ports/317141

Log:
  - make bsdpatch happy
  PR:     178220
  
  - merge and cleanup patches

Added:
  head/print/a2ps/files/patch-localealias.c
     - copied unchanged from r316986, head/print/a2ps/files/patch-intl-localealias.c
  head/print/a2ps/files/patch-ogonkify-Makefile.in
     - copied unchanged from r316986, head/print/a2ps/files/patch-ad
  head/print/a2ps/files/patch-options.c
     - copied unchanged from r316986, head/print/a2ps/files/patch-ae
Deleted:
  head/print/a2ps/files/patch-ad
  head/print/a2ps/files/patch-ae
  head/print/a2ps/files/patch-intl-localealias.c
  head/print/a2ps/files/patch-lib-xgethostname.c
Modified:
  head/print/a2ps/files/patch-contrib-emacs-Makefile.in
  head/print/a2ps/files/patch-xgethostname.c

Modified: head/print/a2ps/files/patch-contrib-emacs-Makefile.in
==============================================================================
--- head/print/a2ps/files/patch-contrib-emacs-Makefile.in	Thu May  2 19:04:05 2013	(r317140)
+++ head/print/a2ps/files/patch-contrib-emacs-Makefile.in	Thu May  2 19:34:48 2013	(r317141)
@@ -1,6 +1,6 @@
 Index: contrib/emacs/Makefile.in
---- Makefile.in.orig	2011-09-27 15:17:26.000000000 +0900
-+++ Makefile.in	2011-09-27 15:18:10.000000000 +0900
+--- contrib/emacs/Makefile.in.orig	2011-09-27 15:17:26.000000000 +0900
++++ contrib/emacs/Makefile.in	2011-09-27 15:18:10.000000000 +0900
 @@ -159,8 +159,9 @@
  
  install-dist_lispLISP: $(dist_lisp_LISP) $(ELCFILES)

Copied: head/print/a2ps/files/patch-localealias.c (from r316986, head/print/a2ps/files/patch-intl-localealias.c)
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/print/a2ps/files/patch-localealias.c	Thu May  2 19:34:48 2013	(r317141, copy of r316986, head/print/a2ps/files/patch-intl-localealias.c)
@@ -0,0 +1,20 @@
+--- intl/localealias.c.orig	Tue Aug 31 13:29:35 1999
++++ intl/localealias.c	Tue Aug 12 11:09:53 2003
+@@ -329,6 +329,17 @@
+ 		      FREE_BLOCKS (block_list);
+ 		      return added;
+ 		    }
++		  if (string_space != new_pool)
++		    {
++		      size_t i;
++
++		      for (i = 0; i < nmap; i++)
++			{
++			  map[i].alias += new_pool - string_space;
++			  map[i].value += new_pool - string_space;
++			}
++		    }
++
+ 		  string_space = new_pool;
+ 		  string_space_max = new_size;
+ 		}

Copied: head/print/a2ps/files/patch-ogonkify-Makefile.in (from r316986, head/print/a2ps/files/patch-ad)
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/print/a2ps/files/patch-ogonkify-Makefile.in	Thu May  2 19:34:48 2013	(r317141, copy of r316986, head/print/a2ps/files/patch-ad)
@@ -0,0 +1,11 @@
+--- ogonkify/Makefile.in.orig	Tue Apr 20 00:07:03 1999
++++ ogonkify/Makefile.in	Tue Apr 20 00:07:07 1999
+@@ -37,7 +37,7 @@
+ 
+ DESTDIR =
+ 
+-pkgdatadir = $(datadir)/@PACKAGE@
++pkgdatadir = $(datadir)/a2ps/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ 

Copied: head/print/a2ps/files/patch-options.c (from r316986, head/print/a2ps/files/patch-ae)
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/print/a2ps/files/patch-options.c	Thu May  2 19:34:48 2013	(r317141, copy of r316986, head/print/a2ps/files/patch-ae)
@@ -0,0 +1,18 @@
+--- lib/options.c.orig	Thu Sep 21 23:22:36 2000
++++ lib/options.c	Thu Sep 21 23:22:42 2000
+@@ -493,6 +493,15 @@
+ 	  /* A font size is given */
+ 	  job->fontsize = get_length ("--font-size", cp,
+ 				      0.0, 0.0, "pt", range_min_strict);
++	  if (job->fontsize == 0.0) 
++	  {
++	    error (0, 0, _("invalid argument %s for -f or --font-size option"),
++	      cp);
++	    fprintf (stderr,
++	      _("Valid arguments are floats with optonal units!\n"));
++	    fprintf (stderr, _("Try `a2ps --help' for more information.\n"));
++	    exit (EXIT_FAILURE);
++	  }
+ 	  job->columns_requested = 0;
+ 	  job->lines_requested = 0;
+ 	}

Modified: head/print/a2ps/files/patch-xgethostname.c
==============================================================================
--- head/print/a2ps/files/patch-xgethostname.c	Thu May  2 19:04:05 2013	(r317140)
+++ head/print/a2ps/files/patch-xgethostname.c	Thu May  2 19:34:48 2013	(r317141)
@@ -1,6 +1,23 @@
---- lib/xgethostname.c	Tue Sep  4 00:51:26 2001
-+++ lib/xgethostname.c.new	Tue Sep  4 00:55:39 2001
-@@ -63,7 +63,7 @@
+--- lib/xgethostname.c.orig	Tue Sep  4 00:51:26 2001
++++ lib/xgethostname.c	Tue Sep  4 00:55:39 2001
+@@ -21,6 +21,7 @@
+ # include <config.h>
+ #endif
+ 
++#include <sys/param.h>
+ #include <sys/types.h>
+ 
+ #include <errno.h>
+@@ -38,7 +39,7 @@
+ int gethostname ();
+ 
+ #ifndef INITIAL_HOSTNAME_LENGTH
+-# define INITIAL_HOSTNAME_LENGTH 34
++# define INITIAL_HOSTNAME_LENGTH MAXHOSTNAMELEN
+ #endif
+ 
+ char *
+@@ -63,7 +64,7 @@
        if (err == 0 && hostname[k] == '\0')
  	break;
  #ifdef ENAMETOOLONG
@@ -9,4 +26,3 @@
  	error (EXIT_FAILURE, errno, "gethostname");
  #endif
        size *= 2;
-
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Dirk Meyer freebsd_committer 2013-05-13 14:56:31 UTC
State Changed
From-To: feedback->closed

- feedback was received. 
There is a regression in bsd-patch, it does not parse the path in the "Index:" line. 

A workaround was committed, thanks.