Bug 178410 - devel/automake-wrapper doesn't symlink aclocal properly
Summary: devel/automake-wrapper doesn't symlink aclocal properly
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Bryan Drewery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-08 06:10 UTC by Enji Cooper
Modified: 2013-08-31 00:30 UTC (History)
0 users

See Also:


Attachments
autoconf-wrapper-use-LN-sfh.patch (466 bytes, patch)
2013-05-17 02:59 UTC, Enji Cooper
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2013-05-08 06:10:00 UTC
I've seen this issue several times when trying to make reinstall the devel/autoconf-wrapper port:

devel/automake-wrapper: /usr/ports/devel/automake-wrapper
devel/automake-wrapper: ===>  Installing for automake-wrapper-20101119
devel/automake-wrapper: ===>   Generating temporary packing list
devel/automake-wrapper: ln: /usr/local/bin/aclocal: File exists
devel/automake-wrapper: *** [do-install] Error code 1
devel/automake-wrapper: 
devel/automake-wrapper: Stop in /usr/ports/devel/automake-wrapper.
devel/automake-wrapper: *** [/usr/ports/devel/automake-wrapper/work/.install_done.automake-wrapper._usr_local] Error code 1
devel/automake-wrapper: 
devel/automake-wrapper: Stop in /usr/ports/devel/automake-wrapper.
devel/automake-wrapper: *** [reinstall] Error code 1
devel/automake-wrapper: 
devel/automake-wrapper: Stop in /usr/ports/devel/automake-wrapper.

The problem is it's not calling ln with the correct arguments and thus failing when make install is called.

Fix: 

Call ln with -fsh.
How-To-Repeat: cd devel/automake-wrapper; make install; make reinstall
Comment 1 Edwin Groothuis freebsd_committer 2013-05-08 06:10:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->autotools

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Enji Cooper freebsd_committer 2013-05-17 02:59:25 UTC
	Here's a patch for the issue.
Thanks!
-Garrett
Comment 3 Bryan Drewery freebsd_committer 2013-08-30 19:38:23 UTC
Responsible Changed
From-To: autotools->bdrewery

I'll take it.
Comment 4 Bryan Drewery freebsd_committer 2013-08-31 00:22:14 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 5 dfilter service freebsd_committer 2013-08-31 00:22:15 UTC
Author: bdrewery
Date: Fri Aug 30 23:22:07 2013
New Revision: 325731
URL: http://svnweb.freebsd.org/changeset/ports/325731

Log:
  - Fix 'make reinstall' in devel/automake-wrapper and devel/autoconf-wrapper
  
  PR:		ports/178410 [1]
  Submitted by:	Garrett Cooper <yaneurabeya@gmail.com> [1]
  PR:		ports/174775 [2]
  Submitted by:	nemysis

Modified:
  head/devel/autoconf-wrapper/Makefile

Modified: head/devel/autoconf-wrapper/Makefile
==============================================================================
--- head/devel/autoconf-wrapper/Makefile	Fri Aug 30 23:21:51 2013	(r325730)
+++ head/devel/autoconf-wrapper/Makefile	Fri Aug 30 23:22:07 2013	(r325731)
@@ -33,7 +33,7 @@ do-configure:
 do-install:
 	@${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
 .for tool in ${WRAPPED_TOOLS}
-	@${LN} -s ${PORTNAME} ${PREFIX}/bin/${tool}
+	@${LN} -sf ${PORTNAME} ${PREFIX}/bin/${tool}
 .endfor
 
 .include <bsd.port.post.mk>
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"