Bug 178840 - [PATCH] devel/guichan: enable OPENGL by default
Summary: [PATCH] devel/guichan: enable OPENGL by default
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Marcus von Appen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-22 19:00 UTC by Dmitry Marakasov
Modified: 2013-05-22 20:20 UTC (History)
1 user (show)

See Also:


Attachments
guichan-0.8.2_6.patch (382 bytes, patch)
2013-05-22 19:00 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov 2013-05-22 19:00:00 UTC
Like SDL, OPENGL is required by guichang consumers (at least games/diameter) and should be enabled by default.

Port maintainer (mva@FreeBSD.org) is cc'd.

Generated with FreeBSD Port Tools 0.99_7 (mode: change, diff: ports)
Comment 1 Edwin Groothuis freebsd_committer 2013-05-22 19:00:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mva

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-05-22 20:19:11 UTC
Author: mva
Date: Wed May 22 19:19:03 2013
New Revision: 318789
URL: http://svnweb.freebsd.org/changeset/ports/318789

Log:
  - Enable OPENGL by default, since several ports rely on it
  - Bump PORTREVISION
  
  PR:		ports/178840
  Submitted by:	amdmi@

Modified:
  head/devel/guichan/Makefile

Modified: head/devel/guichan/Makefile
==============================================================================
--- head/devel/guichan/Makefile	Wed May 22 18:39:37 2013	(r318788)
+++ head/devel/guichan/Makefile	Wed May 22 19:19:03 2013	(r318789)
@@ -3,7 +3,7 @@
 
 PORTNAME=	guichan
 PORTVERSION=	0.8.2
-PORTREVISION=	6
+PORTREVISION=	7
 CATEGORIES=	devel games
 MASTER_SITES=	${MASTER_SITE_GOOGLE_CODE}
 
@@ -20,7 +20,7 @@ CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
 
 OPTIONS_DEFINE=		SDL ALLEGRO OPENGL
-OPTIONS_DEFAULT=	SDL
+OPTIONS_DEFAULT=	SDL OPENGL
 ALLEGRO_DESC=	Allegro support
 
 .include <bsd.port.options.mk>
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Marcus von Appen freebsd_committer freebsd_triage 2013-05-22 20:20:00 UTC
State Changed
From-To: open->closed

Duplicate of ports/178839