Bug 179105 - math/octave: e texi file error causes octave-3.6.4 install failure
math/octave: e texi file error causes octave-3.6.4 install failure
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Maho Nakata
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 12:50 UTC by xiechen
Modified: 2013-08-16 02:46 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xiechen 2013-05-30 12:50:00 UTC
There is something wrong with doc texi files.

x# cd /usr/ports/math/octave/
x# make install
..
(cd /usr/ports/math/octave/work/octave-3.6.4; /usr/bin/env SHELL=/bin/sh NO_LINT=YES F77="gfortran46" FC="gfortran46" FFLAGS=
"-O -Wl,-rpath=/usr/local/lib/gcc46" ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" AS="/usr/local/bin/as" CPPFI
LT="/usr/local/bin/c++filt" GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" OBJCOPY="/usr/local/bi
n/objcopy" OBJDUMP="/usr/local/bin/objdump" RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" SIZE="/usr/local/
bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  LOCALBASE=/usr/local  MOTIFLIB="-L/usr/local/lib -lXm -lXp" LIB
DIR="/usr/lib"  CC="gcc46" CFLAGS="-O2 -pipe -march=core2 -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-al
iasing"  CPP="cpp46" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib -pthread -L/usr/local/lib -pthread -Wl,-rpat
h=/usr/local/lib/gcc46"  CXX="g++46" CXXFLAGS="-O2 -pipe -march=core2 -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -f
no-strict-aliasing -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install
  -s -o root -g wheel -m 555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  BSD_INSTALL_SCRIPT="install  -o root -g
 wheel -m 555"  BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  -o root -g wheel -m 444" gmake
  check)
Makefile:2549: warning: overriding recipe for target `check'
Makefile:2128: warning: ignoring old recipe for target `check'
gmake  all-recursive
gmake[1]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4'
Makefile:2549: warning: overriding recipe for target `check'
Makefile:2128: warning: ignoring old recipe for target `check'
Making all in libgnu
gmake[2]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/libgnu'
gmake  all-recursive
gmake[3]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/libgnu'
gmake[4]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/libgnu'
gmake[4]: Nothing to be done for `all-am'.
gmake[4]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/libgnu'
gmake[3]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/libgnu'
gmake[2]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/libgnu'
Making all in libcruft
gmake[2]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/libcruft'
gmake[2]: Nothing to be done for `all'.
gmake[2]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/libcruft'
Making all in liboctave
gmake[2]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/liboctave'
gmake  all-am
gmake[3]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/liboctave'
gmake[3]: Nothing to be done for `all-am'.
gmake[3]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/liboctave'
gmake[2]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/liboctave'
Making all in src
gmake[2]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/src'
gmake  all-am
gmake[3]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/src'
gmake[3]: Nothing to be done for `all-am'.
gmake[3]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/src'
gmake[2]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/src'
Making all in scripts
gmake[2]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/scripts'
making plot/gnuplot_binary.m from plot/gnuplot_binary.in
plot/gnuplot_binary.m is unchanged
gmake[2]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/scripts'
Making all in doc
gmake[2]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/doc'
Making all in faq
gmake[3]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/doc/faq'
gmake[3]: Nothing to be done for `all'.
gmake[3]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/doc/faq'
Making all in icons
gmake[3]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/doc/icons'
gmake[3]: Nothing to be done for `all'.
gmake[3]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/doc/icons'
Making all in interpreter
gmake[3]: Entering directory `/usr/ports/math/octave/work/octave-3.6.4/doc/interpreter'
restore=: && backupdir=".am$$" && \
am__cwd=`pwd` && CDPATH="${ZSH_VERSION+.}:" && cd . && \
rm -rf $backupdir && mkdir $backupdir && \
if (/usr/local/bin/makeinfo --version) >/dev/null 2>&1; then \
  for f in octave.info octave.info-[0-9] octave.info-[0-9][0-9] octave.i[0-9] octave.i[0-9][0-9]; do \
    if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
  done; \
else :; fi && \
cd "$am__cwd"; \
if /usr/local/bin/makeinfo   -I . \
 -o octave.info octave.texi; \
then \
  rc=0; \
  CDPATH="${ZSH_VERSION+.}:" && cd .; \
else \
  rc=$?; \
  CDPATH="${ZSH_VERSION+.}:" && cd . && \
  $restore $backupdir/* `echo "./octave.info" | sed 's|[^/]*$||'`; \
fi; \
rm -rf $backupdir; exit $rc
octave.texi:132: warning: @end should only appear at a line beginning
./strings.texi:1139: @itemx must follow @item
./io.texi:1393: warning: @table has text but no @item
./plot.texi:2711: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2714: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2717: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2720: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2734: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2737: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2740: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:2743: must be after `@deftypefn' to use `@deftypefnx'
./plot.texi:3150: @itemx must follow @item
./plot.texi:3165: @itemx must follow @item
./plot.texi:4142: @itemx must follow @item
./plot.texi:4146: @itemx must follow @item
./plot.texi:6299: @itemx must follow @item
./plot.texi:6303: @itemx must follow @item
./plot.texi:6307: @itemx must follow @item
./plot.texi:6445: must be after `@deftypefn' to use `@deftypefnx'
./set.texi:154: must be after `@deftypefn' to use `@deftypefnx'
./poly.texi:86: must be after `@deftypefn' to use `@deftypefnx'
./signal.texi:458: must be after `@deftypefn' to use `@deftypefnx'
./signal.texi:462: must be after `@deftypefn' to use `@deftypefnx'
./signal.texi:467: must be after `@deftypefn' to use `@deftypefnx'
./audio.texi:150: must be after `@deftypefn' to use `@deftypefnx'
./audio.texi:154: must be after `@deftypefn' to use `@deftypefnx'
./audio.texi:157: must be after `@deftypefn' to use `@deftypefnx'
./audio.texi:160: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:842: warning: command @dots does not accept arguments
./system.texi:1264: warning: @itemx should not begin @table
./system.texi:1266: @itemx must follow @item
./system.texi:2793: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2811: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2814: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2882: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2885: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2888: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2893: must be after `@deftypefn' to use `@deftypefnx'
./system.texi:2906: must be after `@deftypefn' to use `@deftypefnx'
./tips.texi:301: warning: @item missing argument
./tips.texi:304: warning: @item missing argument
./tips.texi:307: warning: @item missing argument
./tips.texi:310: warning: @item missing argument
./tips.texi:313: warning: @item missing argument
./plot.texi:3392: warning: node `Printing and Saving Plots' is next for `Multiple Plot Windows' in menu but not in sectioning
./plot.texi:3957: warning: node `Multiple Plot Windows' is prev for `Printing and Saving Plots' in menu but not in sectioning
gmake[3]: *** [octave.info] Error 1
gmake[3]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/doc/interpreter'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4/doc'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/math/octave/work/octave-3.6.4'
gmake: *** [all] Error 2
*** [check] Error code 2

Stop in /usr/ports/math/octave.

Fix: 

Octave-3.6.4 in Gentoo has the identical bug.
https://bugs.gentoo.org/show_bug.cgi?id=465536
Their texinfo.patch is here:
https://465536.bugs.gentoo.org/attachment.cgi?id=347084
How-To-Repeat: x# cd /usr/ports/math/octave
x# make install
Comment 1 Edwin Groothuis freebsd_committer 2013-05-31 00:20:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->maho

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Maho Nakata freebsd_committer 2013-06-04 02:27:10 UTC
State Changed
From-To: open->feedback

I cannot reproduce this error. Could you please test it 
again with the newest ports tree and try again? 
Best 
Nakata Maho
Comment 3 1wkmmr 2013-07-14 11:27:59 UTC
Hi,

The similar problem happens to me.  It's 100% sure.  My system is as
follows.

> uname -a
FreeBSD  9.2-PRERELEASE FreeBSD 9.2-PRERELEASE #0 r253336: Sun Jul 14
15:05:56 JST 2013
root@:/usr/obj/nanobsd.full/mnt2/usr/src9/sys/MYGEN  amd64

# ( cd /usr/src/ ; make update )
--------------------------------------------------------------
>>> Updating /mnt2/usr/src9 using Subversion
--------------------------------------------------------------
Updating '.':
At revision 253338.

# grep -v ^# /etc/make.conf | uniq
SVN_UPDATE=     yes
SVN=            /usr/local/bin/svn
SVNFLAGS=

TEX_DEFAULT=texlive

PERL_VERSION=5.14.4
-- 
-----
Mamoru Iwaki
Japan
Comment 4 dfilter freebsd_committer 2013-08-16 02:29:15 UTC
Author: maho
Date: Fri Aug 16 01:29:00 2013
New Revision: 324788
URL: http://svnweb.freebsd.org/changeset/ports/324788

Log:
  Unbreak for texinfo 5.1, patch was taken from Gentoo site.
  Portrevision bumped.
  
  > Octave-3.6.4 in Gentoo has the identical bug.
  > https://bugs.gentoo.org/show_bug.cgi?id=465536
  > Their texinfo.patch is here:
  > https://465536.bugs.gentoo.org/attachment.cgi?id=347084
  
  PR:		179105
  Submitted by:	Chen Xie <xiechen@mail.ustc.edu.cn>

Added:
  head/math/octave/files/patch-octave-doc   (contents, props changed)
Modified:
  head/math/octave/Makefile

Modified: head/math/octave/Makefile
==============================================================================
--- head/math/octave/Makefile	Thu Aug 15 23:01:27 2013	(r324787)
+++ head/math/octave/Makefile	Fri Aug 16 01:29:00 2013	(r324788)
@@ -3,7 +3,7 @@
 
 PORTNAME=	octave
 PORTVERSION=	3.6.4
-PORTREVISION=	4
+PORTREVISION=	5
 CATEGORIES=	math
 MASTER_SITES=	ftp://ftp.gnu.org/gnu/octave/ \
 		ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/

Added: head/math/octave/files/patch-octave-doc
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/math/octave/files/patch-octave-doc	Fri Aug 16 01:29:00 2013	(r324788)
@@ -0,0 +1,360 @@
+
+--- doc/interpreter/audio.texi	2013-02-21 21:37:50.000000000 +0100
++++ doc/interpreter/audio.texi	2013-05-01 23:23:21.338665377 +0200
+@@ -146,18 +146,18 @@
+ Load the RIFF/WAVE sound file @var{filename}, and return the samples
+ in vector @var{y}.  If the file contains multichannel data, then
+ @var{y} is a matrix with the channels represented as columns.
+-
+-@deftypefnx {Function File} {[@var{y}, @var{Fs}, @var{bps}] =} wavread (@var{filename})
++@end deftypefn
++@deftypefn {Function File} {[@var{y}, @var{Fs}, @var{bps}] =} wavread (@var{filename})
+ Additionally return the sample rate (@var{fs}) in Hz and the number of bits
+ per sample (@var{bps}).
+-
+-@deftypefnx {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n})
++@end deftypefn
++@deftypefn {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n})
+ Read only the first @var{n} samples from each channel.
+-
+-@deftypefnx {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n1} @var{n2})
++@end deftypefn
++@deftypefn {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n1} @var{n2})
+ Read only samples @var{n1} through @var{n2} from each channel.
+-
+-@deftypefnx {Function File} {[@var{samples}, @var{channels}] =} wavread (@var{filename}, "size")
++@end deftypefn
++@deftypefn {Function File} {[@var{samples}, @var{channels}] =} wavread (@var{filename}, "size")
+ Return the number of samples (@var{n}) and channels (@var{ch})
+ instead of the audio data.
+ @seealso{@ref{doc-wavwrite,,wavwrite}}
+
+--- doc/interpreter/io.texi	2013-02-21 21:37:51.000000000 +0100
++++ doc/interpreter/io.texi	2013-05-01 22:59:08.537582265 +0200
+@@ -1391,22 +1391,22 @@
+ for the file.  Valid values for @var{arch} are:
+ 
+ @table @asis
+-@samp{native}
++@item @samp{native}
+ The format of the current machine (this is the default).
+ 
+-@samp{ieee-be}
++@item @samp{ieee-be}
+ IEEE big endian format.
+ 
+-@samp{ieee-le}
++@item @samp{ieee-le}
+ IEEE little endian format.
+ 
+-@samp{vaxd}
++@item @samp{vaxd}
+ VAX D floating format.
+ 
+-@samp{vaxg}
++@item @samp{vaxg}
+ VAX G floating format.
+ 
+-@samp{cray}
++@item @samp{cray}
+ Cray floating format.
+ @end table
+ 
+
+--- doc/interpreter/octave.texi	2013-02-21 21:19:23.000000000 +0100
++++ doc/interpreter/octave.texi	2013-05-01 22:58:26.561420772 +0200
+@@ -129,7 +129,9 @@
+ @sp 2
+ @multitable @columnfractions 0.4 0.025 0.65
+ @item
+-@flushright @image{octave_logo,2.1in} @end flushright
++@flushright
++@image{octave_logo,2.1in}
++@end flushright
+ @tab
+ @c this is a spacer column
+ @tab
+
+--- doc/interpreter/plot.texi	2013-02-21 21:37:52.000000000 +0100
++++ doc/interpreter/plot.texi	2013-05-01 23:07:36.586442176 +0200
+@@ -2707,21 +2707,20 @@
+ Set the data aspect ratio of the current axes.  The aspect ratio is
+ a normalized 3-element vector representing the span of the x, y, and
+ z-axes limits.
+-
+-@deftypefnx {Function File} {@var{data_aspect_ratio} =} daspect ( )
++@end deftypefn
++@deftypefn {Function File} {@var{data_aspect_ratio} =} daspect ( )
+ Return the data aspect ratio of the current axes.
+-
+-@deftypefnx {Function File} {} daspect (@var{mode})
++@end deftypefn
++@deftypefn {Function File} {} daspect (@var{mode})
+ Set the data aspect ratio mode of the current axes.
+-
+-@deftypefnx {Function File} {@var{data_aspect_ratio_mode} =} daspect ("mode")
++@end deftypefn
++@deftypefn {Function File} {@var{data_aspect_ratio_mode} =} daspect ("mode")
+ Return the data aspect ratio mode of the current axes.
+-
+-@deftypefnx {Function File} {} daspect (@var{hax}, @dots{})
++@end deftypefn
++@deftypefn {Function File} {} daspect (@var{hax}, @dots{})
+ Use the axes, with handle @var{hax}, instead of the current axes.
+-
+-@seealso{@ref{doc-axis,,axis}, @ref{doc-pbaspect,,pbaspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
+ @end deftypefn
++@seealso{@ref{doc-axis,,axis}, @ref{doc-pbaspect,,pbaspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
+ 
+ 
+ @c pbaspect scripts/plot/pbaspect.m
+@@ -2730,21 +2729,20 @@
+ Set the plot box aspect ratio of the current axes.  The aspect ratio
+ is a normalized 3-element vector representing the rendered lengths of
+ the x, y, and z-axes.
+-
+-@deftypefnx {Function File} {@var{plot_box_aspect_ratio} =} pbaspect ( )
++@end deftypefn
++@deftypefn {Function File} {@var{plot_box_aspect_ratio} =} pbaspect ( )
+ Return the plot box aspect ratio of the current axes.
+-
+-@deftypefnx {Function File} {} pbaspect (@var{mode})
++@end deftypefn
++@deftypefn {Function File} {} pbaspect (@var{mode})
+ Set the plot box aspect ratio mode of the current axes.
+-
+-@deftypefnx {Function File} {@var{plot_box_aspect_ratio_mode} =} pbaspect ("mode")
++@end deftypefn
++@deftypefn {Function File} {@var{plot_box_aspect_ratio_mode} =} pbaspect ("mode")
+ Return the plot box aspect ratio mode of the current axes.
+-
+-@deftypefnx {Function File} {} pbaspect (@var{hax}, @dots{})
++@end deftypefn
++@deftypefn {Function File} {} pbaspect (@var{hax}, @dots{})
+ Use the axes, with handle @var{hax}, instead of the current axes.
+-
+-@seealso{@ref{doc-axis,,axis}, @ref{doc-daspect,,daspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
+ @end deftypefn
++@seealso{@ref{doc-axis,,axis}, @ref{doc-daspect,,daspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
+ 
+ 
+ @node Three-dimensional Function Plotting
+@@ -3147,7 +3145,7 @@
+ @item "hide"
+   Hide legend on the plot
+ 
+-@itemx "toggle"
++@item "toggle"
+   Toggles between "hide" and "show"
+ 
+ @item "boxon"
+@@ -3162,7 +3160,7 @@
+ @item "right"
+   Place text to the right of the keys
+ 
+-@itemx "off"
++@item "off"
+   Delete the legend object
+ @end table
+ @end deftypefn
+@@ -4139,11 +4137,11 @@
+ is sent to a file the size is determined by the plot box defined by
+ the figure's "paperposition" property.
+ 
+-@itemx -append
++@item -append
+   Appends the PS, or PDF output to a pre-existing file of the
+ same type.
+ 
+-@itemx -r@var{NUM}
++@item -r@var{NUM}
+   Resolution of bitmaps in pixels per inch.  For both metafiles and
+ SVG the default is the screen resolution, for other it is 150 dpi.
+ To specify screen resolution, use "-r0".
+@@ -6296,15 +6294,15 @@
+ A character indicating a plot marker to be place at each data point, or
+ @code{"none"}, meaning no markers should be displayed.
+ 
+-@itemx markeredgecolor
++@item markeredgecolor
+ The color of the edge around the marker, or @code{"auto"}, meaning that
+ the edge color is the same as the face color.  @xref{Colors}.
+ 
+-@itemx markerfacecolor
++@item markerfacecolor
+ The color of the marker, or @code{"none"} to indicate that the marker
+ should not be filled.  @xref{Colors}.
+ 
+-@itemx markersize
++@item markersize
+ A number specifying the size of the marker.  The default is 1.  A value
+ of 2 is twice as large as the default, etc.
+ @end table
+@@ -6442,7 +6440,8 @@
+ @deftypefn {Function File} {@var{value} =} getappdata (@var{h}, @var{name})
+ Return the @var{value} for named application data for the object(s) with
+ handle(s) @var{h}.
+-@deftypefnx {Function File} {@var{appdata} =} getappdata (@var{h})
++@end deftypefn
++@deftypefn {Function File} {@var{appdata} =} getappdata (@var{h})
+ Return a structure, @var{appdata}, whose fields correspond to the appdata
+ properties.
+ @end deftypefn
+
+--- doc/interpreter/poly.texi	2013-02-21 21:37:52.000000000 +0100
++++ doc/interpreter/poly.texi	2013-05-01 23:28:59.515000917 +0200
+@@ -82,8 +82,8 @@
+ (@var{x}-@var{mu}(1))/@var{mu}(2).
+ If @var{x} is a vector or matrix, the polynomial is evaluated for each of
+ the elements of @var{x}.
+-
+-@deftypefnx {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s})
++@end deftypefn
++@deftypefn {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s})
+ @deftypefnx {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s}, @var{mu})
+ In addition to evaluating the polynomial, the second output
+ represents the prediction interval, @var{y} +/- @var{dy}, which
+
+--- doc/interpreter/set.texi	2013-02-21 21:37:52.000000000 +0100
++++ doc/interpreter/set.texi	2013-05-01 23:30:00.161810855 +0200
+@@ -150,8 +150,9 @@
+        3   4
+ @end group
+ @end example
++@end deftypefn
+ 
+-@deftypefnx {Function File} {[@var{c}, @var{ia}, @var{ib}] =} union (@var{a}, @var{b})
++@deftypefn {Function File} {[@var{c}, @var{ia}, @var{ib}] =} union (@var{a}, @var{b})
+ 
+ Return index vectors @var{ia} and @var{ib} such that @code{a(ia)} and
+ @code{b(ib)} are disjoint sets whose union is @var{c}.
+
+--- doc/interpreter/signal.texi	2013-02-21 21:37:52.000000000 +0100
++++ doc/interpreter/signal.texi	2013-05-01 23:31:41.111833440 +0200
+@@ -454,17 +454,17 @@
+ 
+ For fastest computation, @var{n} should factor into a small number of
+ small primes.
+-
+-@deftypefnx {Function File} {@var{h} =} freqz (@var{b}, @var{a}, @var{w})
++@end deftypefn
++@deftypefn {Function File} {@var{h} =} freqz (@var{b}, @var{a}, @var{w})
+ Evaluate the response at the specific frequencies in the vector @var{w}.
+ The values for @var{w} are measured in radians.
+-
+-@deftypefnx {Function File} {[@dots{}] =} freqz (@dots{}, @var{Fs})
++@end deftypefn
++@deftypefn {Function File} {[@dots{}] =} freqz (@dots{}, @var{Fs})
+ Return frequencies in Hz instead of radians assuming a sampling rate
+ @var{Fs}.  If you are evaluating the response at specific frequencies
+ @var{w}, those frequencies should be requested in Hz rather than radians.
+-
+-@deftypefnx {Function File} {} freqz (@dots{})
++@end deftypefn
++@deftypefn {Function File} {} freqz (@dots{})
+ Plot the pass band, stop band and phase response of @var{h} rather
+ than returning them.
+ @end deftypefn
+
+--- doc/interpreter/strings.texi	2013-02-21 21:37:52.000000000 +0100
++++ doc/interpreter/strings.texi	2013-05-01 22:27:29.646311770 +0200
+@@ -1136,7 +1136,7 @@
+ @item %s
+ The word is parsed as a string.
+ 
+-@itemx %f
++@item %f
+ @itemx %n
+ The word is parsed as a number and converted to double.
+ 
+
+--- doc/interpreter/system.texi	2013-02-21 21:37:52.000000000 +0100
++++ doc/interpreter/system.texi	2013-05-01 23:45:09.981978551 +0200
+@@ -839,7 +839,7 @@
+ @deftypefnx {Function File} {} datetick (@var{axis}, @var{form})
+ @deftypefnx {Function File} {} datetick (@dots{}, "keeplimits")
+ @deftypefnx {Function File} {} datetick (@dots{}, "keepticks")
+-@deftypefnx {Function File} {} datetick (@dots{ax}, @dots{})
++@comment @deftypefnx {Function File} {} datetick (@dots{ax}, @dots{})
+ Add date formatted tick labels to an axis.  The axis the apply the
+ ticks to is determined by @var{axis} that can take the values "x",
+ "y" or "z".  The default value is "x".  The formatting of the labels is
+@@ -1261,9 +1261,10 @@
+ interpreted as filename globbing patterns (as they are used by Unix shells).
+ Within a pattern
+ @table @code
+-@itemx *
++
++@item *
+ matches any string, including the null string,
+-@itemx ?
++@item ?
+ matches any single character, and
+ 
+ @item [@dots{}]
+@@ -2789,8 +2790,8 @@
+ Display a header containing the current Octave version number, license
+ string and operating system, followed by the installed package names,
+ versions, and installation directories.
+-
+-@deftypefnx {Function File} {v =} ver ()
++@end deftypefn
++@deftypefn {Function File} {v =} ver ()
+ Return a vector of structures, respecting Octave and each installed package.
+ The structure includes the following fields.
+ 
+@@ -2807,11 +2808,11 @@
+ @item Date
+ Date respecting the version/revision.
+ @end table
+-
+-@deftypefnx {Function File} {v =} ver ("Octave")
++@end deftypefn
++@deftypefn {Function File} {v =} ver ("Octave")
+ Return version information for Octave only.
+-
+-@deftypefnx {Function File} {v =} ver (@var{package})
++@end deftypefn
++@deftypefn {Function File} {v =} ver (@var{package})
+ Return version information for @var{package}.
+ 
+ @seealso{@ref{doc-version,,version}, @ref{doc-octave_config_info,,octave_config_info}}
+@@ -2878,19 +2879,19 @@
+ @anchor{doc-license}
+ @deftypefn {Function File} {} license
+ Display the license of Octave.
+-
+-@deftypefnx {Function File} {} license ("inuse")
++@end deftypefn
++@deftypefn {Function File} {} license ("inuse")
+ Display a list of packages currently being used.
+-
+-@deftypefnx {Function File} {@var{retval} =} license ("inuse")
++@end deftypefn
++@deftypefn {Function File} {@var{retval} =} license ("inuse")
+ Return a structure containing the fields @code{feature} and @code{user}.
+-
+-@deftypefnx {Function File} {@var{retval} =} license ("test", @var{feature})
++@end deftypefn
++@deftypefn {Function File} {@var{retval} =} license ("test", @var{feature})
+ Return 1 if a license exists for the product identified by the string
+ @var{feature} and 0 otherwise.  The argument @var{feature} is case
+ insensitive and only the first 27 characters are checked.
+-
+-@deftypefnx {Function File} {} license ("test", @var{feature}, @var{toggle})
++@end deftypefn
++@deftypefn {Function File} {} license ("test", @var{feature}, @var{toggle})
+ Enable or disable license testing for @var{feature}, depending on
+ @var{toggle}, which may be one of:
+ 
+@@ -2902,8 +2903,8 @@
+ @item "disable"
+ Future tests for the specified license of @var{feature} return 0.
+ @end table
+-
+-@deftypefnx {Function File} {@var{retval} =} license ("checkout", @var{feature})
++@end deftypefn
++@deftypefn {Function File} {@var{retval} =} license ("checkout", @var{feature})
+ Check out a license for @var{feature}, returning 1 on success and 0
+ on failure.
+ 
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Maho Nakata freebsd_committer 2013-08-16 02:46:08 UTC
State Changed
From-To: feedback->closed

closed, thanks!