Bug 179207 - security/pinentry-qt: QT3 is deprecated
Summary: security/pinentry-qt: QT3 is deprecated
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Max Brazhnikov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 18:10 UTC by Scot Hetzel
Modified: 2013-06-19 15:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scot Hetzel 2013-06-02 18:10:00 UTC
security/pinentry-qt defaults to depending on the x11-toolkits/qt33 port which is deprecated.  This is causing issues when installing/updating ports that depend on the QT4 ports.

security/pinentry-qt should either:
- be changed depend on QT4 (i.e. change PORT_OPTIONS to QT4)
  Note: there is a security/pinentry-qt4 port already

- mark port deprecated and add an updating entry informing users to switch to
  the security/pinentry-qt4 port.
  Note: any port that depends on security/pinentry-qt would need to be changed
        to depend on security/pinentry-qt4.

How-To-Repeat: Install the security/pinentry-qt port without changing the default selection for QT3, then try to install devel/qt4-corelibs.

devel/qt4-corelibs will use the wrong include files.
Comment 1 Glen Barber freebsd_committer 2013-06-02 18:13:56 UTC
Responsible Changed
From-To: freebsd-bugs->makc

Over to maintainer.
Comment 2 dfilter service freebsd_committer 2013-06-19 15:14:27 UTC
Author: makc
Date: Wed Jun 19 14:14:13 2013
New Revision: 321253
URL: http://svnweb.freebsd.org/changeset/ports/321253

Log:
  Disable Qt3 frontend: Qt3 ports are deprecated.
  
  PR:		ports/179207
  Reported by:	Scot Hetzel <swhetzel at gmail.com>

Modified:
  head/security/pinentry/Makefile

Modified: head/security/pinentry/Makefile
==============================================================================
--- head/security/pinentry/Makefile	Wed Jun 19 14:10:02 2013	(r321252)
+++ head/security/pinentry/Makefile	Wed Jun 19 14:14:13 2013	(r321253)
@@ -27,7 +27,7 @@ LDFLAGS+=	-L${LOCALBASE}/lib
 .if !defined(PINENTRY_SLAVE)
 OPTIONS_MULTI=	FRONTEND
 OPTIONS_MULTI_FRONTEND=	NCURSES GTK GTK2 QT3 QT4
-OPTIONS_DEFAULT=	${OPTIONS_MULTI_FRONTEND}
+OPTIONS_DEFAULT=	${OPTIONS_MULTI_FRONTEND:NQT3}
 
 NCURSES_DESC=	Curses frontend
 GTK_DESC=	Gtk+1 frontend
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Max Brazhnikov freebsd_committer 2013-06-19 15:15:00 UTC
State Changed
From-To: open->closed

Committed. Thanks!