Bug 179420 - www/seamonkey freezes completely by accessing citrix xenapp virtual desktop
Summary: www/seamonkey freezes completely by accessing citrix xenapp virtual desktop
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Johannes Jost Meixner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-07 22:40 UTC by Piotr
Modified: 2014-12-09 09:07 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr 2013-06-07 22:40:00 UTC
I've installed net/citrix_ica from ports:

# cd /usr/ports/net/citrix_ica     
# make install clean

# cd /usr/ports/www/nspluginwrapper
# make install clean

$ nspluginwrapper -v -a -i
Auto-install plugins from /usr/local/lib/browser_plugins
Looking for plugins in /usr/local/lib/browser_plugins
Install plugin /usr/local/lib/browser_plugins/libflashplayer.so
  into /home/bsd/.mozilla/plugins/npwrapper.libflashplayer.so
Auto-install plugins from /usr/local/lib/seamonkey/plugins
Looking for plugins in /usr/local/lib/seamonkey/plugins
Auto-install plugins from /usr/local/lib/npapi/linux-f10-flashplugin
Looking for plugins in /usr/local/lib/npapi/linux-f10-flashplugin
Install plugin /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so
 ... already installed system-wide, skipping
Auto-install plugins from /home/bsd/.mozilla/plugins
Looking for plugins in /home/bsd/.mozilla/plugins


Now if I try to connect to the citrix xenapp virtual desktop the browser freezes completely with the following error:

$ seamonkey
*** NSPlugin Viewer  *** ERROR: /usr/local/lib/browser_plugins/npica.so: cannot open shared object file: No such file or directory

Fix: 

*** NSPlugin Viewer  *** ERROR: /usr/local/lib/browser_plugins/npica.so: cannot open shared object file: No such file or directory
How-To-Repeat: install net/citrix_ica,nspluginwrapper,seamonkey on FreeBSD and try to access citrix xenapp virtual desktop via seamonkey browser.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-06-17 00:29:49 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

ports PR.
Comment 2 Edwin Groothuis freebsd_committer 2013-06-17 00:30:50 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gecko

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 Carlo Strub freebsd_committer 2014-09-14 10:32:27 UTC
Is this PR still relevant?
Comment 4 Jan Beich freebsd_committer 2014-11-04 22:46:54 UTC
/usr/local/lib/browser_plugins/npica.so is neither installed by net/citrix_ica nor created by nspluginwrapper. The former changed since ports r349559 while PLIST_SUB+=MOZILLA_HOME is forgotten.

Handing over to xmj@ if he wants to fix regression with USES=webplugin:linux.

(In reply to upiter77 from comment #0)
> # cd /usr/ports/net/citrix_ica     
> # make install clean
> 
> # cd /usr/ports/www/nspluginwrapper
> # make install clean
> 
> $ nspluginwrapper -v -a -i

Until the plugin is moved to WEBPLUGIN_DIR replace the last command with

  $ nspluginwrapper -v -i /usr/local/ICAClient/npica.so
Comment 5 Johannes Jost Meixner freebsd_committer 2014-11-05 13:24:51 UTC
Note that the aforementioned revision ports r349559 didn't change anything about the WEBPLUGIN behavior.

That being said, I'll have a patch ready and will commit it shortly.
Comment 6 commit-hook freebsd_committer 2014-11-07 14:06:45 UTC
A commit references this bug:

Author: xmj
Date: Fri Nov  7 14:06:34 UTC 2014
New revision: 372265
URL: https://svnweb.freebsd.org/changeset/ports/372265

Log:
  net/citrix_ica: Add webplugin USES flag

  - Add USES= webplugin:linux
  - Plist cleanup

  PR: 		179420
  Differential Revision:	https://reviews.freebsd.org/D1112
  Submitted by: 	upiter77@lycos.com
  Approved by:	swills (mentor)

Changes:
  head/net/citrix_ica/Makefile
  head/net/citrix_ica/pkg-plist
Comment 7 Johannes Jost Meixner freebsd_committer 2014-11-17 21:48:38 UTC
Can you please check if the original problem still persists?
Comment 8 Johannes Jost Meixner freebsd_committer 2014-12-09 09:07:19 UTC
Marking this as closed due to a commit,
and failure to respond within three weeks.