Bug 179448 - New port: devel/py-ecdsa ECDSA cryptographic signature library (pure python)
Summary: New port: devel/py-ecdsa ECDSA cryptographic signature library (pure python)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-09 23:50 UTC by kyuupichan
Modified: 2013-06-11 19:30 UTC (History)
0 users

See Also:


Attachments
file.shar (2.65 KB, text/plain)
2013-06-09 23:50 UTC, kyuupichan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kyuupichan 2013-06-09 23:50:01 UTC
This is a python library that is a dependency of the Electrum bitcoin client, which I have ported.

portlint reports no problems and installed cleanly in poudriere in test mode.

SHAR file attached (.txt extension)

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-06-09 23:50:24 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

freebsd-python@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2013-06-10 09:30:58 UTC
Responsible Changed
From-To: freebsd-python->rm

I will take it.
Comment 3 dfilter service freebsd_committer 2013-06-11 19:25:30 UTC
Author: rm
Date: Tue Jun 11 18:25:17 2013
New Revision: 320621
URL: http://svnweb.freebsd.org/changeset/ports/320621

Log:
  ECDSA cryptographic signature library (pure python).
  
  WWW: http://github.com/warner/python-ecdsa
  
  PR:		179448
  Submitted by:	Neil Booth Neil Booth <kyuupichan@gmail.com>

Added:
  head/security/py-ecdsa/
  head/security/py-ecdsa/Makefile   (contents, props changed)
  head/security/py-ecdsa/distinfo   (contents, props changed)
  head/security/py-ecdsa/pkg-descr   (contents, props changed)
  head/security/py-ecdsa/pkg-plist   (contents, props changed)
Modified:
  head/security/Makefile

Modified: head/security/Makefile
==============================================================================
--- head/security/Makefile	Tue Jun 11 18:24:08 2013	(r320620)
+++ head/security/Makefile	Tue Jun 11 18:25:17 2013	(r320621)
@@ -741,6 +741,7 @@
     SUBDIR += py-crack
     SUBDIR += py-cracklib
     SUBDIR += py-cryptkit
+    SUBDIR += py-ecdsa
     SUBDIR += py-fail2ban
     SUBDIR += py-gnupg
     SUBDIR += py-gnutls

Added: head/security/py-ecdsa/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/security/py-ecdsa/Makefile	Tue Jun 11 18:25:17 2013	(r320621)
@@ -0,0 +1,21 @@
+# Created by: Neil Booth
+# $FreeBSD$
+
+PORTNAME=	ecdsa
+PORTVERSION=	0.8
+CATEGORIES=	security python
+MASTER_SITES=	CHEESESHOP
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER=	kyuupichan@gmail.com
+COMMENT=	ECDSA cryptographic signature library (pure python)
+
+LICENSE=	MIT
+
+USE_PYTHON=	-2.7
+USE_PYDISTUTILS=	yes
+
+regression-test: build
+	@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.include <bsd.port.mk>

Added: head/security/py-ecdsa/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/security/py-ecdsa/distinfo	Tue Jun 11 18:25:17 2013	(r320621)
@@ -0,0 +1,2 @@
+SHA256 (ecdsa-0.8.tar.gz) = 926dbc7f31f5e099079884e1ae8121d25c43b17f1db48d77c9540cd1e40acc1a
+SIZE (ecdsa-0.8.tar.gz) = 35754

Added: head/security/py-ecdsa/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/security/py-ecdsa/pkg-descr	Tue Jun 11 18:25:17 2013	(r320621)
@@ -0,0 +1,3 @@
+ECDSA cryptographic signature library (pure python).
+
+WWW: http://github.com/warner/python-ecdsa

Added: head/security/py-ecdsa/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/security/py-ecdsa/pkg-plist	Tue Jun 11 18:25:17 2013	(r320621)
@@ -0,0 +1,31 @@
+%%PYTHON_SITELIBDIR%%/ecdsa/__init__.py
+%%PYTHON_SITELIBDIR%%/ecdsa/__init__.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/__init__.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/_version.py
+%%PYTHON_SITELIBDIR%%/ecdsa/_version.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/_version.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/curves.py
+%%PYTHON_SITELIBDIR%%/ecdsa/curves.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/curves.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/der.py
+%%PYTHON_SITELIBDIR%%/ecdsa/der.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/der.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/ecdsa.py
+%%PYTHON_SITELIBDIR%%/ecdsa/ecdsa.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/ecdsa.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/ellipticcurve.py
+%%PYTHON_SITELIBDIR%%/ecdsa/ellipticcurve.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/ellipticcurve.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/keys.py
+%%PYTHON_SITELIBDIR%%/ecdsa/keys.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/keys.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/numbertheory.py
+%%PYTHON_SITELIBDIR%%/ecdsa/numbertheory.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/numbertheory.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/test_pyecdsa.py
+%%PYTHON_SITELIBDIR%%/ecdsa/test_pyecdsa.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/test_pyecdsa.pyo
+%%PYTHON_SITELIBDIR%%/ecdsa/util.py
+%%PYTHON_SITELIBDIR%%/ecdsa/util.pyc
+%%PYTHON_SITELIBDIR%%/ecdsa/util.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/ecdsa
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Ruslan Makhmatkhanov freebsd_committer 2013-06-11 19:30:25 UTC
State Changed
From-To: open->closed

New port added with minor changes. Thank you. It's better fit to 
security category, imho.