Bug 179824 - [ixgbe] System (9.1-p4) hangs on heavy ixgbe network traffic with hw.ixgbe.num_queues=6
Summary: [ixgbe] System (9.1-p4) hangs on heavy ixgbe network traffic with hw.ixgbe.nu...
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2013-06-22 00:40 UTC by lt
Modified: 2015-08-03 17:38 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lt 2013-06-22 00:40:00 UTC
A 6-CPU core 9.1-RELEASE-p4 system equipped with intel 82599EB NIC with hw.ixgbe.num_queues=6 hangs when traffic volume is heavy.

The system hang can be workarounded by setting hw.ixgbe.num-queues=4

Fix: 

change hw.ixgbe.num_queues=4 (or 2) in /boot/loader.conf
How-To-Repeat: HW/SW setup - 9.1-RELEASE-p4 with the 82599EB NIC on a 6-CPU core system

Using a nginx webserver and use clients like http_load to stress the 10G network interface. System will hang within 30 seconds.

Hard reboot is required.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-06-23 07:22:04 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Sean Bruno freebsd_committer 2015-08-03 17:38:15 UTC
This is not happening for me when I turn num_queues to any value.  I suspect it is fixed.  Please reopen this issue if it is still occuring.