Bug 179835 - net/freerdp - missing dependency
net/freerdp - missing dependency
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Dima Panov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-22 11:20 UTC by kvedulv
Modified: 2013-06-24 03:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kvedulv 2013-06-22 11:20:00 UTC
As xrdp now depends on freerdp, I have to build the port. The following is happening:

[...]
-- Finding suggested package XKBFile.
--   Disable this using "-DWITH_XKBFILE=OFF".
CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:97 (message):
  Could NOT find XKBFile (missing: XKBFILE_LIBRARY XKBFILE_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindXKBFile.cmake:41 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  cmake/FindOptionalPackage.cmake:37 (find_package)
  libfreerdp-kbd/CMakeLists.txt:38 (find_suggested_package)

After installing x11/libxkbfile everything is building fine.
Comment 1 Edwin Groothuis freebsd_committer 2013-06-22 11:20:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->fluffy

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 fluffy 2013-06-22 18:17:35 UTC
22.06.13, 21:11, Michael Moll пиÑеÑ:
> 
>> Number:         179835
>> Category:       ports
>> Synopsis:       net/freerdp - missing dependency
>> Confidential:   no
>> Severity:       non-critical
>> Priority:       low
>> Responsible:    freebsd-ports-bugs
>> State:          open
>> Quarter:        
>> Keywords:       
>> Date-Required:
>> Class:          sw-bug
>> Submitter-Id:   current-users
>> Arrival-Date:   Sat Jun 22 10:20:00 UTC 2013
>> Closed-Date:
>> Last-Modified:
>> Originator:     Michael Moll
>> Release:        9-STABLE
>> Organization:
>> Environment:
> FreeBSD marduk.kvedulv.de 9.1-STABLE FreeBSD 9.1-STABLE #0 r251934M: Tue Jun 18 15:19:01 CEST 2013     mmoll@marduk.kvedulv.de:/usr/obj/svn/base/stable/9/sys/MARDUK  amd64
>> Description:
> As xrdp now depends on freerdp, I have to build the port. The following is happening:
> 
> [...]
> -- Finding suggested package XKBFile.
> --   Disable this using "-DWITH_XKBFILE=OFF".
> CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:97 (message):
>   Could NOT find XKBFile (missing: XKBFILE_LIBRARY XKBFILE_INCLUDE_DIR)
> Call Stack (most recent call first):
>   /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE)
>   cmake/FindXKBFile.cmake:41 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
>   cmake/FindOptionalPackage.cmake:37 (find_package)
>   libfreerdp-kbd/CMakeLists.txt:38 (find_suggested_package)
> 
> After installing x11/libxkbfile everything is building fine.



Something broken with your xorg installation, because libxkbfile is
already listed as dependency by this define:
USE_XORG=       x11 xkbfile xcursor xextproto xv xinerama xext xcursor

Please rebuild your packages.



-- 
Dima Panov (fluffy@FreeBSD.org)
(KDE, Office)@FreeBSD team

Facebook: http://www.facebook.com/fluffy.khv
IRC: fluffy@EFNet, fluffykhv@FreeNode
twitter: fluffy_khv | skype: dima.panov
Comment 3 kvedulv 2013-06-22 19:01:26 UTC
Hi,

On Sun, Jun 23, 2013 at 04:17:35AM +1100, Dima Panov wrote:
> Something broken with your xorg installation, because libxkbfile is
> already listed as dependency by this define:
> USE_XORG=       x11 xkbfile xcursor xextproto xv xinerama xext xcursor
> 
> Please rebuild your packages.

All packages were newly built today. I have "WITH_NEW_XORG=yes" in my
make.conf, otherwise there should be no interfering settings. However,
those packages don't get installed:

# pkg_info |egrep '(x11|xkbfile|xcursor|xextproto|xv|xinerama|xext|xcursor)'
libxkbfile-1.0.8    XKB file library
xextproto-7.2.1     XExt extension headers
xineramaproto-1.2.1 Xinerama extension headers
Comment 4 fluffy 2013-06-23 03:32:33 UTC
23.06.13, 5:01, Michael Moll пиÑеÑ:
> Hi,
> 
> On Sun, Jun 23, 2013 at 04:17:35AM +1100, Dima Panov wrote:
>> Something broken with your xorg installation, because libxkbfile
>> is already listed as dependency by this define: USE_XORG=
>> x11 xkbfile xcursor xextproto xv xinerama xext xcursor
>> 
>> Please rebuild your packages.
> 
> All packages were newly built today. I have "WITH_NEW_XORG=yes" in
> my make.conf, otherwise there should be no interfering settings.
> However, those packages don't get installed:
> 
> # pkg_info |egrep
> '(x11|xkbfile|xcursor|xextproto|xv|xinerama|xext|xcursor)' 
> libxkbfile-1.0.8    XKB file library xextproto-7.2.1     XExt
> extension headers xineramaproto-1.2.1 Xinerama extension headers
> 


I can't reproduce this error on 10/amd64 and 9.1/amd64, with gcc and
clang (and WITH_NEW_XORG, of course), sorry. In any case freerdp get
full dependencies list and builds fine.

Please try again with clean portstree and make.conf


-- 
Dima Panov (fluffy@FreeBSD.org)
(KDE, Office)@FreeBSD team

Facebook: http://www.facebook.com/fluffy.khv
IRC: fluffy@EFNet, fluffykhv@FreeNode
twitter: fluffy_khv | skype: dima.panov
Comment 5 kvedulv 2013-06-23 14:42:29 UTC
On Sun, Jun 23, 2013 at 01:32:33PM +1100, Dima Panov wrote:
> I can't reproduce this error on 10/amd64 and 9.1/amd64, with gcc and
> clang (and WITH_NEW_XORG, of course), sorry. In any case freerdp get
> full dependencies list and builds fine.

I think I know now, what's going on... As freerdp was needed only
because the xrdp port added it as dependency, I dsiabled all options for
it, so X11 was never set und thus the X11 dependencies don't get
installed.

As it seems, even with -DWITH_X11=OFF libxkbfile is required by the
rules of the CMakefile.
Comment 6 fluffy 2013-06-23 16:26:17 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

24.06.13, 0:42, Michael Moll ?????:
> On Sun, Jun 23, 2013 at 01:32:33PM +1100, Dima Panov wrote:
>> I can't reproduce this error on 10/amd64 and 9.1/amd64, with gcc
>> and clang (and WITH_NEW_XORG, of course), sorry. In any case
>> freerdp get full dependencies list and builds fine.
> 
> I think I know now, what's going on... As freerdp was needed only 
> because the xrdp port added it as dependency, I dsiabled all
> options for it, so X11 was never set und thus the X11 dependencies
> don't get installed.
> 
> As it seems, even with -DWITH_X11=OFF libxkbfile is required by
> the rules of the CMakefile.
> 
Right. To completely disable X11 components,-DWITH_XKBFILE=OFF is also
required.
Will be fixed at morning.

- -- 
Dima Panov (fluffy@FreeBSD.org)
(KDE, Office)@FreeBSD team

Facebook: http://www.facebook.com/fluffy.khv
IRC: fluffy@EFNet, fluffykhv@FreeNode
twitter: fluffy_khv | skype: dima.panov
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.19 (Darwin)
Comment: GPGTools - http://gpgtools.org

iQIcBAEBAgAGBQJRxxOWAAoJEPuLoJ3VOY8paIQP/A7dZ6zVIamCaU+JogB4vaU8
onTPRf2X+aX2pwIp3xVD7mBUP4oHxVA/gR9Vv91zNIuP7gazThNzf8sRYOOFo82g
qItr39b7uDJOWQbMdTHkExFEy3h7G1ViNOgj6T2+EjOYM1DmO3YRN1hdxDtaf7pb
pZF09nSvfhJ8nxGQ8+BdLZv0dLW+GCdGA1KELywOOwmaWQXbfWFxAFjZhbLmM0vL
Fu7j9W5wCON0SfZdJUQPIOdk5AEMpOObi2/ZVLlKGIuBH6jxRTr3SX014RFHleJE
eSO1NSg2eV3LJ/mgMIaWQBHLJ3rDzZkGgeu+w/MPIYOjG7OCT1YeArtzQE8MC1+t
LdcX1YJk9cI8zK+uDXraE1Ikp5/IGNT7HRGBEpccY75ACjJhdMLRkIZ9hRLUWhCX
ndFp8saeeXWijvmQa8BCRc6aBrT9uNdvdyoOkMH/MdxpAg7h22azj6HCBj8GjPN4
WYGCLSqJH+eyBxC2bBSyU1YXJbaX1cTyWal1hMl5JFUmEYYZ4pO0T2f5V5fFt69v
ryA7kY5PwcDO5Qndsix9wn0ygAkGJZsczqYCeTrrU6eN+uXBEXKhyneaWX9hZ0Or
PxQFNybOI68QYts0MIKh+Sxg6gt4wfPGSsPDpC/wUbCLy5b3SgtgbKS9FfXpr6Uf
JjYcIySJo8RkTK2+Jsca
=AQCG
-----END PGP SIGNATURE-----
Comment 7 dfilter freebsd_committer 2013-06-24 03:43:46 UTC
Author: fluffy
Date: Mon Jun 24 02:43:38 2013
New Revision: 321660
URL: http://svnweb.freebsd.org/changeset/ports/321660

Log:
  - Explicitly disable libxkbfile detection when no X11 option is selected
  
  PR:		179835
  Reported by:	Michael Moll <kvedulv AT kvedulv DOT de>

Modified:
  head/net/freerdp/Makefile

Modified: head/net/freerdp/Makefile
==============================================================================
--- head/net/freerdp/Makefile	Mon Jun 24 00:58:54 2013	(r321659)
+++ head/net/freerdp/Makefile	Mon Jun 24 02:43:38 2013	(r321660)
@@ -37,7 +37,7 @@ BUILD_DEPENDS+=	xmlto:${PORTSDIR}/textpr
 MAN1=		xfreerdp.1
 PLIST_SUB+=	X11=""
 .else
-CMAKE_ARGS+=	-DWITH_X11=OFF
+CMAKE_ARGS+=	-DWITH_X11=OFF -DWITH_XKBFILE=OFF
 PLIST_SUB+=	X11="@comment "
 .endif
 
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 8 Dima Panov freebsd_committer 2013-06-24 03:44:46 UTC
State Changed
From-To: open->closed

Fix was committed. Thanks for report!