Bug 180240 - [maintainer update] x11-fm/doublecmd: update to version 0.5.5
Summary: [maintainer update] x11-fm/doublecmd: update to version 0.5.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: William Grzybowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-03 17:20 UTC by Beñat Gonzalez Etxepare
Modified: 2013-07-04 23:49 UTC (History)
0 users

See Also:


Attachments
file.txt (15.49 KB, text/plain)
2013-07-03 17:20 UTC, Beñat Gonzalez Etxepare
no flags Details
doublecmd-0.5.5_fixed.patch (15.46 KB, patch)
2013-07-04 19:25 UTC, Beñat Gonzalez Etxepare
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beñat Gonzalez Etxepare 2013-07-03 17:20:00 UTC
Changelog:
- Update to version 0.5.5


Renamed files (with changes):
- files/patch-src-dmhelpmanager.pas to files/patch-src__dmhelpmanager.pas
- files/patch-src-uGlobsPaths.pas to files/patch-src__uGlobsPaths.pas

New files:
- files/patch-components__doublecmd__dcosutils.pas
- files/patch-src__ucmdlineparams.pas

Deleted files:
- files/patch-install-linux-doublecmd.desktop
- files/patch-src-foptions.pas
- files/patch-src-ftweakplugin.pas


Patch tested in RedPorts (rev. 14327):
http://redports.org/buildarchive/20130703141802-89527/

Fix: Patch attached with submission follows:
Comment 1 William Grzybowski freebsd_committer 2013-07-04 02:54:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wg

I'll take it.
Comment 2 William Grzybowski 2013-07-04 15:29:10 UTC
The build is not completely clean:

pkg_delete: file
'/usr/local/share/examples/lazarus/designerbaseclass/lib' doesn't
exist
pkg_delete: unable to completely remove directory
'/usr/local/share/examples/lazarus/designerbaseclass/lib'
pkg_delete: file
'/usr/local/share/examples/lazarus/codetools/jumptoimplementation/lib'
doesn't exist
pkg_delete: unable to completely remove directory
'/usr/local/share/examples/lazarus/codetools/jumptoimplementation/lib'
pkg_delete: file
'/usr/local/share/examples/lazarus/androidlcl/android/libs/armeabi'
doesn't exist
pkg_delete: unable to completely remove directory
'/usr/local/share/examples/lazarus/androidlcl/android/libs/armeabi'
pkg_delete: file
'/usr/local/share/examples/lazarus/androidlcl/android/libs' doesn't
exist
pkg_delete: unable to completely remove directory
'/usr/local/share/examples/lazarus/androidlcl/android/libs'
pkg_delete: couldn't entirely delete package `lazarus-1.0.8'
(perhaps the packing list is incorrectly specified?)


Can you check please?
http://redports.org/~bbtruk/20130703141802-89527-130763/doublecmd-0.5.5.log


--
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 3 Beñat Gonzalez Etxepare 2013-07-04 18:07:48 UTC
On Thu, 4 Jul 2013 11:29:10 -0300, William wrote:

> The build is not completely clean:
> pkg_delete: file
> '/usr/local/share/examples/lazarus/designerbaseclass/lib' doesn't
> exist
> [..]
> 
> Can you check please?
> http://redports.org/~bbtruk/20130703141802-89527-130763/doublecmd-0.5.5.log

If I am not mistaken, legacy packages (the ones before pkgng) didn't
store information about empty directories (only files), so when Lazarus
port tries to remove these directories, it fails. It is kind of a 'bug' in
the package system. More info in the handbook:

7.2.2 Creating Empty Directories
http://www.freebsd.org/doc/en/books/porters-handbook/plist-cleaning.html


I can confirm that all directories listed are empty in a clean
installation of Lazarus. So I think this shouldn't be considered an error
(at least not of doublecmd port).
Comment 4 William Grzybowski 2013-07-04 18:10:58 UTC
On Thu, Jul 4, 2013 at 2:07 PM, Be=F1at Gonzalez Etxepare
<bbtruk@users.sourceforge.net> wrote:
> On Thu, 4 Jul 2013 11:29:10 -0300, William wrote:
>
>> The build is not completely clean:
>> pkg_delete: file
>> '/usr/local/share/examples/lazarus/designerbaseclass/lib' doesn't
>> exist
>> [..]
>>
>> Can you check please?
>> http://redports.org/~bbtruk/20130703141802-89527-130763/doublecmd-0.5.5.=
log
>
> If I am not mistaken, legacy packages (the ones before pkgng) didn't
> store information about empty directories (only files), so when Lazarus
> port tries to remove these directories, it fails. It is kind of a 'bug' i=
n
> the package system. More info in the handbook:
>
> 7.2.2 Creating Empty Directories
> http://www.freebsd.org/doc/en/books/porters-handbook/plist-cleaning.html
>
>
> I can confirm that all directories listed are empty in a clean
> installation of Lazarus. So I think this shouldn't be considered an error
> (at least not of doublecmd port).

Thats not the case.
I'm pretty sure it is a bug in generating pkg-plist and can be workarounded=
.

Thanks for your understanding.

--
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 5 Beñat Gonzalez Etxepare 2013-07-04 18:37:13 UTC
> I'm pretty sure it is a bug in generating pkg-plist and can be workarounded.

Sorry, I don't know if I understand your answer correctly. Do you mean the
problem is not caused by lazarus' pkg-plist and that I should correct
pkg-plist creation for doublecmd port?
Comment 6 William Grzybowski 2013-07-04 18:44:45 UTC
On Thu, Jul 4, 2013 at 2:37 PM, Be=F1at Gonzalez Etxepare
<bbtruk@users.sourceforge.net> wrote:
>> I'm pretty sure it is a bug in generating pkg-plist and can be workaroun=
ded.
>
> Sorry, I don't know if I understand your answer correctly. Do you mean th=
e
> problem is not caused by lazarus' pkg-plist and that I should correct
> pkg-plist creation for doublecmd port?

I think it is caused by pkg-plist or install of examples files and it
should be fixed.
The make package complains about examples dirs that do not exist and
are expected to.

--
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 7 Beñat Gonzalez Etxepare 2013-07-04 19:25:32 UTC
I am sorry, as the log in RedPorts only warns about pkg_delete failing in
Lazarus, I completely missed the same is happening in doublecmd with the
patch I sent (I am using pkgng and so it didn't give any warning in my
local system either).

I attach a new patch with pkg-plist corrected. Now doublecmd is cleanly
removed using pkg_delete also.


And sorry again for wasting your time.
Comment 8 William Grzybowski freebsd_committer 2013-07-04 23:49:54 UTC
State Changed
From-To: open->closed

Committed. Thanks!