Bug 180723 - editors/libreoffice: calc spreadsheet external data link by URL not working
Summary: editors/libreoffice: calc spreadsheet external data link by URL not working
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-21 17:20 UTC by Tom Vier
Modified: 2016-01-17 14:17 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Vier 2013-07-21 17:20:00 UTC
Pulling html tables works fine under openoffice on Windows or debian 6. On freebsd, building from a recent ports tarball or installing with pkg_add -r, libreoffice doesn't. Both versions 3 and 4 have the same problem.

When opening such a spreadsheet, the normal prompt "This file contains links to other files. Should they be updated?" appears. After clicking 'Yes', there's usually a delay as it gets the URL, but with the ports version, it doesn't seem to even try. The spreadsheet immediately shows "The link could not be updated.".

Going to Edit -> Links..., Modify... pops up an error:

Error loading document
http://bigcharts.marketwatch.com/quotes/multi.asp?view=q&msymb=BSV+LTPZ+TLT+VTI+VXUS
Object not accessible.
The object cannot be accessed
due to insufficient user rights.

If you paste that URL into a browser, there's no problem. I don't see any config

How-To-Repeat: 1) Existing link: I have an example file I can provide, with an existing link that works in other builds.

2) Add new link:
Open new spreadsheet.
Insert -> Link to External Data...

Paste in the URL (see bug description), hit <enter>. It should list the html tables, but does not.
Comment 1 Edwin Groothuis freebsd_committer 2013-07-21 20:58:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Baptiste Daroussin freebsd_committer 2014-08-26 05:51:26 UTC
Is this still happening on newer version of libreoffice?