Bug 180852 - [re] re0 not working with 9.1-RELEASE
Summary: [re] re0 not working with 9.1-RELEASE
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net (Nobody)
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-25 20:20 UTC by Ville Koskela
Modified: 2019-03-30 13:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ville Koskela 2013-07-25 20:20:00 UTC
- Had a working 8.0-RELEASE installation on my network gateway. Decided to make a fresh install with 9.1-RELEASE i386. 

- Started install: onboard LAN died. Switch won't light up the 1GB light and re0 cannot get IP from DHCP. (onboard NIC, Realtek RTL8168/8111 PCIe Gigabit Ethernet)

- Did ton of reinstalls, tried tricks with bios, ifconfig etc. 

- Finally tested amd64 version of the 9.1-RELEASE, lights from LAN-port died and even switch won't show a light telling the cable is there. 

- i386 and amd64 versions both keep on telling that the status is "no carrier" while cable is just like it has always been. 

- Decided to install Windows Vista home premium, but Windows kept telling "device cannot start (code 10)", but after installing latest Realtek-drivers the LAN came back to life. Everything works perfectly and 1GB light is showing at the switch. 

- Tried reinstalling 9.1-RELEASE i386: LAN died again. 

- Took uname -a 

- Installed Vista and latest drivers again, LAN came alive again. 

- Started installing 8.4-RELEASE i386: LAN works like a charm. 

Seems there is a problem with the re driver in 9.1-RELEASE. I asked help for my problems at the freebsd-forums. Thread can be found at: http://forums.freebsd.org/showthread.php?p=228061

Fix: 

Install 8.4-RELEASE
How-To-Repeat: Install 9.1-RELEASE
Comment 1 Remko Lodder freebsd_committer 2013-07-26 15:19:54 UTC
Responsible Changed
From-To: freebsd-i386->yongari

reassign to yongari, he did a lot of work on the if_re driver.
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:22 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 3 Andriy Voskoboinyk freebsd_committer 2019-03-30 13:37:18 UTC
Is it still broken on the recent RELEASE / 13.0-CURRENT