Bug 181236 - [igb] igb driver unstable work
Summary: [igb] igb driver unstable work
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2013-08-12 09:10 UTC by Igor Krasnov
Modified: 2018-05-29 15:34 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Krasnov 2013-08-12 09:10:01 UTC
The same problems have been observed at 9.1-stable after the regular upgrade to stable/9. The system has been upgraded to 9.2-beta. There are problems with the network card  igb: <Intel(R) PRO/1000 Network Connection version - 2.3.10(Quad Port Server Adapter), which is installed in the new HP DL380 g8 server. After the server is loaded everything seems to be fine but when the network load is high (about 500 users), there occur TCP sessions breaks (connections to exchange server, ssh, sql sessions break). I would like to point out that these problems are caused by a large number of TCP connections within the network and not by the volume of  transmitted traffic or NAT load as the stable traffic 200 mb/s caused no problems at all.

In my opinion, the program configuration is completely workable, as it functions perfectly well on another device (FreeBSD 7.1 system) and there are no problems with the current system as well if the load is medium. Only high network load causes problems.

How-To-Repeat: Don't know, need huge trafic generator...
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-08-13 04:12:19 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:44:07 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 3 Sean Bruno freebsd_committer 2018-05-29 15:34:14 UTC
At this point, FreeBSD 9 isn't supported anylonger.  However, if these problems are still hapening.  Let's dig in further and see what is actually going on.