Bug 181257 - [bge] bge link status change
Summary: [bge] bge link status change
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-13 10:20 UTC by ikv
Modified: 2019-08-01 04:59 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ikv 2013-08-13 10:20:00 UTC
bge interfaces doesn't logging link state changes.
Interface is up and status is active, after unplugging cable there's no message either in /var/log/messages nor on console (kern.consmute=0). If plug cable in interface, there's no message in log also.
But if exec "ifconfig" command when cable unplaged - message appears. After plug cable back appears "link up" message.

Fix: 

There's no way to solve the problem.
How-To-Repeat: 1.Plug network cable into bge interface, bring it up.
2.Unplug cable from bge interface. (there's no log messages)
3.Plug cable back. (still no messages)
4. Unplug cable from bge interface. (still no messages)
5. exec "ifconfig" command from terminal.
6. Message 'link down' appears.
7. Plug cable in bge interface. Link change to up appears.
8. If unplug cable from bge there's no message until "ifconfig" executed.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-08-14 03:08:11 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:32 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 3 NewUse 2019-06-09 11:11:40 UTC
I am running FreeBSD 8.4, no messages at devd until "ifconfig bge*" is executed.


IC: BCM5704
Comment 4 NewUse 2019-07-03 23:46:56 UTC
after some research I found out that there is no interrupt generated on cable de-touch. But link LED does gone down, so theoretically there is possibility to catch this event. May be there is bug in IC firmware. As work around I could try to write a watchdog but there is a bad idea. may by some one have any other ideas to fix?
Comment 5 NewUse 2019-07-04 21:20:19 UTC
My firmware version:
Boot code 3.41
IPMI code 2.49
Comment 6 Bhargava Chenna. Marreddy 2019-07-18 09:30:50 UTC
Hi,

By chance, Do you know if this used to work earlier (with older/newer version of FreeBSD, on different card, etc..).
Comment 7 NewUse 2019-07-20 16:19:35 UTC
I have just tested with IC BCM5721(FW: 3.65), also bge  driver, and it is working just fine, seems that it is IC or FW specific, I could try to test with latest FreeBSD version, but it there where no changes for a long time in src code of bge driver in this part. Could you, please test if there where any changes in latest IC FW, and could you provide latest FW for BCM5704 based card?
Comment 8 Bhargava Chenna. Marreddy 2019-08-01 04:59:55 UTC
Hi,

>>  and could you provide latest FW for BCM5704 based card?
<Bhargava> 
Looks like 5704 is owned by Qlogic. Can you please contact QLogic.