Bug 181322 - devel/jenkins - update to 1.527
devel/jenkins - update to 1.527
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Li-Wen Hsu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 14:10 UTC by c.kworr
Modified: 2013-08-18 12:40 UTC (History)
0 users

See Also:


Attachments
file.diff (945 bytes, patch)
2013-08-15 14:10 UTC, c.kworr
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description c.kworr 2013-08-15 14:10:00 UTC
What's new in 1.527 (2013/08/12)

    Fixed NoSuchFieldError: triggers with older Maven plugin (issue 18677)
    Added bytecode transformation driven compatibility ensurance mechanism (discussion)
    Improve search to locate items inside folders. (pull request 848) (pull request 893)
    Windows path separators not correctly escaped in Maven properties configuration. (issue 10539)
    Improved EnvironmentContributor to support project-level insertion. (issue 19042) 

What's new in 1.526 (2013/08/05)

    Report an user friendly error page if a deletion of a build fails. (pull request 827)
    Maven build failure wasn't describing errors like Maven CLI does. (issue 15025)
    MavenModuleSetBuild.getResult is expensive. (issue 18895)
    Revisited fix to be compatible for plugins. (issue 18119)
    Ensuring /log/all shows only INFO and above messages, even if custom loggers display FINE or below. (issue 18959)
    Added a new monitor that detects and fixse out-of-order builds records. (issue 18289)
    Can't build using maven 3.1.0 (issue 15935)
    Fixed Winstone+mod_proxy_ajp+SSL combo issue. (issue 5753)
    JENKINS_DEBUG_LEVEL misinterpreted by Winstone, causing excessive logging. (issue 18701)
    Since 1.520, Jenkins requires Java 6 or later, breaking Maven builds set to use JDK 5. Now falls back to JVM of slave agent but sets compile/test flags to use defined JDK. (issue 18403)
    Since 1.517, Maven projects using Maven 2 could not build projects using extensions depending on Apache Commons Codec. (issue 18178)
    Test harness was packing copies of Maven into plugin archives under some conditions. (issue 18918)
    Provided maven settings.xml in maven builder is lost. (issue 15976)
    Exception when running polling with a Maven installation not defined on master. (issue 18898)
    Since 1.477 GET on /view//config.xml included a spurious wrapper element. (issue 17302)
    Clearer display of log messages: chronological order, and coloration of repeated vs. fresh metadata (date, log level, log source).
    Fixed a regression that broke some plugins' form validation (issue 18776)
    People View does Not Populate if JQuery plugin enabled. (issue 18641)

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-08-15 14:10:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lwhsu

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Li-Wen Hsu freebsd_committer 2013-08-18 12:37:15 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 3 dfilter freebsd_committer 2013-08-18 12:37:19 UTC
Author: lwhsu
Date: Sun Aug 18 11:37:06 2013
New Revision: 324900
URL: http://svnweb.freebsd.org/changeset/ports/324900

Log:
  - Update to 1.527
  
  PR:		ports/181322, ports/181351
  Submitted by:	Volodymyr Kostyrko <c.kworr@gmail.com>
  		Sergey Brunov <sergey.v.brunov@gmail.com>

Modified:
  head/devel/jenkins/Makefile
  head/devel/jenkins/distinfo

Modified: head/devel/jenkins/Makefile
==============================================================================
--- head/devel/jenkins/Makefile	Sun Aug 18 10:41:10 2013	(r324899)
+++ head/devel/jenkins/Makefile	Sun Aug 18 11:37:06 2013	(r324900)
@@ -1,7 +1,7 @@
 # $FreeBSD$
 
 PORTNAME=	jenkins
-PORTVERSION=	1.525
+PORTVERSION=	1.527
 CATEGORIES=	devel java
 MASTER_SITES=	http://mirrors.jenkins-ci.org/war/${PORTVERSION}/
 DISTNAME=	jenkins

Modified: head/devel/jenkins/distinfo
==============================================================================
--- head/devel/jenkins/distinfo	Sun Aug 18 10:41:10 2013	(r324899)
+++ head/devel/jenkins/distinfo	Sun Aug 18 11:37:06 2013	(r324900)
@@ -1,2 +1,2 @@
-SHA256 (jenkins/1.525/jenkins.war) = 675d660cfbf4e1786d4c9e7567e9812c69d4d2c0af92097c2a48334cbbdb3325
-SIZE (jenkins/1.525/jenkins.war) = 61317736
+SHA256 (jenkins/1.527/jenkins.war) = 3be747425c6d1b1fab8010790ae3bd4b7a5143c2eba549c0043c024e349271fc
+SIZE (jenkins/1.527/jenkins.war) = 61468371
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"